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Getting Started

Artlandia® SymmetryShop® is all you need to create professional-quality pattern
designs in Adobe® Photoshop®.

Installation

SymmetryShop requires Adobe Photoshop 7.0 or later (Photoshop CS4 or later
recommended). To install the plug-in, follow the instructions for your computer
system provided in the file Installation.txt that came with your plug-in.

Demo version

The newly installed plug-in works in the demo mode, which may not have all the
features of the full version. The limitations are described in a separate document (see
the file Demo.txt in your SymmetryShop folder).

Unlocking the full version

Purchase the plug-in to unlock the full version. Then click the Register button in the
SymmetryShop panel and follow the on-screen instructions. Detailed instructions for
unlocking the plug-in are also provided in the file Installation.txt.
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About this guide

This guide assumes that you have a basic knowledge of Photoshop, including how to
operate Photoshop menus, choose tools, select the desired part of your artwork, and
use the Layers, Channels, Paths, and Actions panels. For help with any of these
techniques, please refer to your Photoshop documentation.

An electronic version of this guide is available as a PDF file located in the
SymmetryShop folder.

Supplementary materials

•  The Quick Start dialog walks you through SymmetryShop basics. To access the
dialog, click the Help button  in the SymmetryShop panel.

•  The plug-in comes with the Quick Reference card, available as a PDF document,
and the Sampler files, available as Photoshop files.

•  Also available with the plug-in are Photoshop files that accompany the tutorial
part of this guide. The files can be found in the Tutorial folder in the SymmetryShop
folder.

Web resources

Additional pattern design resources, answers to frequently asked questions, and the
latest information about Artlandia products are always available on the Artlandia
web site at www.artlandia.com. To access the web site from Photoshop, click the icon
at the top of the SymmetryShop panel (you must have an Internet connection and a
web browser installed).
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Among the available resources is Artlandia Wonderland, a collection of tips,
interactive tutorials, and books on symmetry, pattern design, and their applications,
located at www.artlandia.com/wonderland. Many pattern design terms are defined
and illustrated in the Artlandia Glossary of Pattern Design at
www.artlandia.com/wonderland/glossary.

Customer support

You may be entitled to technical support. For more information, refer to the
Artlandia web site and/or the technical support card that came with this guide.

Other products from Artlandia

Also available from Artlandia is Artlandia® SymmetryWorks®, a powerful,
interactive pattern editor for Adobe Illustrator. You may find this complementary
plug-in useful for creating repeat patterns from vector art objects and for combining
vector and raster elements in your pattern designs. SymmetryShop and
SymmetryWorks are similar in many respects, yet they work quite differently and
have their own uses. For a detailed comparison, visit

www.artlandia.com/SymmetryWorks

Supplementing SymmetryWorks is the Artlandia Collection, a library of unique,
royalty-free pattern designs that let you interactively explore the ready-made
patterns and quickly produce a wealth of similar—or dissimilar—designs. Visit

www.artlandia.com/collection
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for a list of currently available volumes and sample art.

For designers familiar with computer programming, Artlandia also offers its
namesake software, Artlandia. If you wish to create your artworks by a set of
commands in a computer language, you may want to explore that program.

More information about Artlandia products is available on the Artlandia web site,
www.artlandia.com
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What’s New in SymmetryShop 3

SymmetryShop 3 features multiple productivity enhancements and improvements in
the pattern design workflow that make working with the plug-in easier and more
efficient. Most of these enhancements are available in Photoshop CS4 and later
versions.

Floating SymmetryShop panel  Access the plug-in at any time as a regular
Photoshop free-floating panel. Move the panel to a convenient place on your screen
or dock it with other Photoshop panels. See “The SymmetryShop panel” on page 8.

Support for large images  Use images of any size that are supported in your version
of Photoshop. SymmetryShop 3 removes the 30,000 pixels restriction on image size
that was set in previous versions. See “Supported objects” on page 38.

Dynamically adjusted image size  Dramatically increase speed and improve
performance while working on a pattern by automatically lowering its image size.
SymmetryShop preserves the quality of your original seed image in a smart object
and lets you rebuild the pattern to its the original size with a click as soon as the
pattern is ready. See “Reducing the image size” on page 37.

Easy targeting of the pattern and the seed layers  Switch to editing the seed layer
of your pattern on the fly. The new Target Seed/Pattern Layer button  lets you
quickly toggle between working on a pattern and on the seed image. See “The
SymmetryShop Layer” on page 17.

One-click selection of the control path  Instantly select the control path to
visualize or transform it as needed. Deselect it with a click, too. The new
Select/Deselect Control Path button  in the SymmetryShop panel lets you quickly
switch between editing pattern elements and changing the repeat size. See “Work
path” on page 20.

Easy editing of the control path  Use the Photoshop Transform Path command to
change the repeat size of your pattern. SymmetryShop will automatically rebuild the
pattern as soon as you apply the transformation. Or easily edit the control path with
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your other favorite Photoshop vector tools. Then update the pattern with a click. See
“To edit the control path using Photoshop tools” on page 55.

Enhanced pattern preview  Fill the entire SymmetryShop Layer with a pattern or
preview the pattern in another layer. Fill the whole layer or a selected region. The
new Preview Pattern button  lets you instantly see the exact pattern that will be
produced when you export your SymmetryShop pattern as a Photoshop preset. See
“SymmetryShop patterns and Photoshop patterns” on page 40.

Other productivity improvements  Work faster and more efficiently by taking
advantage of multiple technical improvements in many SymmetryShop operations,
such as the canvas extension management (see “Automatic canvas extension” on
page 16), autorun (see “Autorun” on page 57), and others.

What’s changed  SymmetryShop 3 automatically deselects the seed image after
creating the pattern. This lets you keep working on your pattern without the need to
deselect the image first. Your selection is still saved in the SymmetryShop Selection
channel (as in previous versions) and you can re-apply it to the seed image at any
time. Ctrl-click (Windows) or Command-click (Mac OS) the Target Seed/Pattern
Layer button  to re-apply the SymmetryShop Selection. See “The SymmetryShop
Layer” on page 17.



Part I
Practical Introduction

This part gives you an overview of key features of the Artlandia
SymmetryShop plug-in and introduces basic techniques you will
find useful in your work.

Contents

Chapter 1
An Overview of Artlandia SymmetryShop

Chapter 2
Working with SymmetryShop Patterns

Chapter 3
Layouts and Repeat Systems
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Chapter 1
An Overview of Artlandia SymmetryShop

Artlandia SymmetryShop automates pattern design in Photoshop. The plug-in
creates a pattern in a new layer, called the SymmetryShop Layer. Your original
(“seed”) layer is left intact and can be accessed through the Layers panel. You can
create patterns from raster images, vector shapes, or smart objects.

If you select an area of the seed layer before making a SymmetryShop pattern, the
plug-in will construct the pattern from the selected area and then save your selection
in an alpha channel called the SymmetryShop Selection. The channel can be found in
the Channels panel. You can also use layer and vector masks to isolate your motif in
the seed layer.

Typically, the plug-in will add yet another channel to your artwork, called the
SymmetryShop Tile. That channel contains the exact rectangle that you can use to
create a Photoshop pattern preset.

Finally, the plug-in adds a work path (or modifies the existing work path) to include
the control path that defines the repeat size and orientation of your pattern.

Taken together, these features allow you to continue working on your pattern design
throughout many invocations of the plug-in in multiple Photoshop sessions. The
basics of SymmetryShop are introduced in this chapter.

The SymmetryShop panel

The SymmetryShop panel lets you launch the SymmetryShop plug-in to create a
pattern and change its properties. To open the SymmetryShop panel in Photoshop
CS4 and later versions, choose Window > Extensions > SymmetryShop. You can
move the free-floating panel on your screen and dock it with other Photoshop panels.

Note: SymmetryShop is not a filter and therefore cannot be found under the Filter menu.
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In Photoshop CS3 and earlier versions, SymmetryShop is available through the File >
Automate menu among other commands that automate your work. To launch
SymmetryShop, choose File > Automate > Artlandia SymmetryShop.

B
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The SymmetryShop panel (on your computer the panel may look different).
A. Symmetry controls B. Set image size C. Toggle Image Size button D. Layouts E. Delete Replicas
button F. Tiling size controls G. Refresh Panel button H. Target Seed/Pattern Layer button
I. Select/Deselect Control Path button J. Show/Hide SymmetryShop Tile button K. Preview Pattern
button L. Export button M. Set the horizontal and vertical positions of the control path N. Set the
width and height of the control path O. Set the control path skew P. Rotate the control path Q. Click to
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change the width and height simultaneously R. Menu to choose half-drop, quarter-drop, etc., shift
S. Clip controls

Some controls in the SymmetryShop panel can be disabled until you open an RGB or CMYK
document and create a pattern.

SymmetryShop panel may update automatically upon completion of some operations. In
other cases, you will need to click the Refresh Panel button  to update panel settings.

The SymmetryShop panel lets you make a pattern and change its properties. There
are seventeen types of planar symmetry available through the symmetry controls.
Additionally, by selecting a layout from the Layout list, you can quickly create
predefined variations within some symmetry types. For an example of a pattern of
each symmetry type and layout, see files in the Sampler folder inside your
SymmetryShop folder.

The image size controls give you a convenient way to dramatically increase
performance by temporarily reducing the image size of your document while
working on pattern iterations. Then restore the original size of your seed image with
a click and rebuild the final pattern in full quality.

The text boxes and sliders in the Control Path section let you adjust the repeat size
and orientation of the pattern, and the controls in the Clipping section let you
instantly switch between overlapping and self-confined units of repetition.

The Tiling controls change the number of rows and columns in your pattern
fragment. You can export your SymmetryShop pattern as a Photoshop pattern preset
using the Export button  and preview the exported pattern using the Preview
Pattern button .

The buttons in the lower row of controls let you refresh the panel settings (using the
Refresh Panel button ) and work with SymmetryShop pattern components. Using
the Target Seed/Pattern Layer button , you can quickly toggle between working on
a pattern and on the seed image; the Select/Deselect Control Path button  lets you
visualize the control path and transform it with Photoshop vector tools; and the
Show/Hide SymmetryShop Tile button  lets you preview the exact rectangle area
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that will be exported as a Photoshop pattern preset when you click the Export
button .

Finally, SymmetryShop Options in the pop-up panel menu let you change your
SymmetryShop preferences.

Tool tips and usage hints  To provide a quick help, most controls in the
SymmetryShop panel have tool tips. For symmetry controls, tool tips give you an
idea of what operations the plug-in performs to build the pattern. You can choose
between the long and shorthand (mathematical) versions of tool tips in
SymmetryShop preferences. You can also enable and disable all SymmetryShop
panel tool tips in Photoshop preferences together with tool tips for other Photoshop
panels and tools.

Key features at a glance

Making a SymmetryShop pattern  To make your first pattern, open an existing RGB
or CMYK image file, or create a new file and paint something in it, then open the
SymmetryShop panel (by choosing Window > Extensions > SymmetryShop), and
click the Make button. This will create a pattern using the active settings in the
SymmetryShop panel.

If the Make button is inactive (gray), or if the panel displays the Update button, click the
Refresh Panel button  to activate the Make button.

About patterns  Notice that a part of the
original image was used as a “seed” (motif)
of the pattern. The plug-in replicates the seed
and transforms it as necessary to produce a
pattern according to symmetry laws.

Creating a SymmetryShop pattern (right) from an
image (left). Symmetry setting: Quarter-turns &

rotated mirrors ; tiling 2 × 2.
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A pattern typically consists of a number of
“tiles.” Each tile consists of one or more
smaller units of repetition. Each smaller unit
is identical to the seed and called an “image”
of the seed. How the images are stacked
together depends on the chosen symmetry
type. Changing the symmetry in the
SymmetryShop panel lets you quickly
generate a variety of visual effects from the
same seed. Preset layouts give you even
greater flexibility by allowing you to create
different-looking variations within the same
symmetry type.

A SymmetryShop pattern.
A. Seed B. Tile
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B CA D

Sample patterns produced from the same seed using different symmetry settings.

A. The seed  B. Simple shift   C. Double mirror   D. Mirror & glide   E. Parallel mirrors &

glide   F. Double glide   G. Three rotations & mirrors   H. Quarter-turns & mirrors 

I. Kaleidoscope   J. Three mirrors 
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C

A

D

B

A butterfly in different layouts chosen from the Layout list.
A. Half-drop  B. Diamond  C. 5 spot  D. Gradation and scale   

Using selection  If you select a part of your artwork before making a pattern,
SymmetryShop creates the pattern from that selected part. If you do not select
anything, the plug-in builds a pattern from your entire image. The plug-in can also
automatically select a geometric region appropriate for your symmetry type. The
automatic selection is based on the control path. See “The control path” on page 23
and “Clip at Control Path” on page 33. The automatic selection often brings about
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patterns that appear “mechanical” or kaleidoscopic. In contrast, by using your own
selection—or removing irrelevant parts of the image, such as the background—you
can typically create a more organic look.

Patterns produced from the same seed with selection (left) and without selection (right). Symmetry

setting: Double glide ; tiling 2 × 2 (fragment).

Layer and vector masks  You can also
apply layer and vector masks to isolate
(mask) parts of your seed layer that you
do not want to use in a pattern.
SymmetryShop will then build a pattern
from the remaining (unmasked) areas.
For more about creating masks, see
“Masking layers” in Photoshop’s User
Guide.

A seed with a layer mask applied.
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Position of the seed  One important
distinction between SymmetryShop and
Photoshop filters is that filters modify the
selected part of the artwork in place while
SymmetryShop copies the selected part to a
new layer where it then creates a pattern by
rotating, reflecting, and/or otherwise
transforming the selection according to
symmetry laws. Therefore, SymmetryShop
generally needs more space around the
selection. If you select a relatively small part
of your artwork in the lower-left quadrant,

Typical position of a selection in the lower-left
quadrant of the artwork.

not too close to either the bottom or the left boundary, then the plug-in will typically
have enough room to build a pattern without gaps and other defects.

Automatic canvas extension  If SymmetryShop determines that the available
canvas space is insufficient, it will try to automatically extend the canvas by adding
space around your seed image (the selection). It is possible that the added space will
still be insufficient. In that case, the plug-in alerts you with a beep and displays the
insufficient canvas size warning icon . To further increase the canvas size, click the
icon.

Note: SymmetryShop adds the same amount of canvas space to the left and right of your
image (or at the top and bottom of the image) so that if the change takes place inside a smart
object, the object will retain its relative position in the enclosing document.

If you do not wish to rely on the automatic canvas extension, increase the work area of your
document by choosing Image > Canvas Size before making the pattern (or before further
updates).

The added extra space does not have to be in your final document. If you move your
SymmetryShop pattern to a smart object, you will be able to crop the smart object to any
desired size in the outer document and still reliably rebuild the pattern inside. See “To create
a SymmetryShop pattern in a smart object” on page 49.
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Components of a SymmetryShop pattern  When making a pattern, SymmetryShop
reorganizes your artwork to make it easy for you to rebuild the pattern after editing
the seed or resume your work in another Photoshop session, even after the pattern
file was closed and then re-opened.

As mentioned in the beginning of this chapter, the plug-in creates a pattern in a new
layer, called the SymmetryShop Layer.  The new layer appears on top of your original
seed layer, which becomes invisible, but otherwise remains intact. The plug-in also
adds a work path that contains the control path that determines the repeat size and
orientation of your pattern. If you have selected a part of your artwork before
launching SymmetryShop, the plug-in may also add an alpha channel that
remembers your selection. That channel is called the SymmetryShop Selection. Finally,
the plug-in typically adds another channel, called the SymmetryShop Tile, which
contains the exact rectangle that you can use to define a usual Photoshop pattern (a
pattern preset). During its operation, the plug-in may modify any of these
components (that is, the SymmetryShop Layer, the SymmetryShop Selection, the
SymmetryShop Tile, and the work path) so, when you are updating a SymmetryShop
pattern, you should not presume that all these components will remain unchanged.

If you wish to preserve some pattern components, duplicate and rename them before
launching SymmetryShop.

Use the controls at the bottom of the SymmetryShop panel to show or hide the pattern
components.

The SymmetryShop Layer  The plug-in
builds the pattern layer (the SymmetryShop
Layer) on top of your original seed layer.
This gives you the opportunity to come back
and edit the original seed at any time after
the pattern is built. To edit the seed, click the
Target Seed/Pattern Layer button . This
automatically selects the seed layer in the
Layers panel and makes it visible, and at the
same time hides the SymmetryShop layer.

Layers of a SymmetryShop pattern.
A. The seed layer (invisible) B. The
SymmetryShop Layer
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You can then edit your motif in the seed layer and click Update in the
SymmetryShop panel to rebuild the pattern. See “To rebuild a SymmetryShop
pattern from the old seed layer” on page 46 for more detailed instructions on
rebuilding a pattern.

To apply the SymmetryShop Selection while switching to the seed layer, hold down the Ctrl
key (Windows) or the Command key (Mac OS) and click the Target Seed/Pattern Layer
button .

You can click the Target Seed/Pattern Layer button  second time to switch back to the
SymmetryShop Layer.

Note: When rebuilding a pattern or selecting the seed layer, SymmetryShop will look for the
seed layer by its name. It is therefore recommended not to rename the seed layer.

The SymmetryShop Selection  The
SymmetryShop Selection saved with the
artwork allows you to re-apply the selection
to your original seed layer if you wish to edit
your seed image after a SymmetryShop
pattern is created. You can also edit the
selection itself. When rebuilding a pattern,
the plug-in always checks for the presence of
the SymmetryShop Selection, so you do not
have to apply the selection to the seed layer if
you simply want to continue working with
the previous selection. By convention, the
plug-in applies the SymmetryShop Selection

SymmetryShop channels.
A. The SymmetryShop Tile  B. The
SymmetryShop Selection

to your seed layer automatically, as long as you launch the plug-in without selecting
anything in the artwork. Launching SymmetryShop with another selection overrides
the old selection channel. See “To rebuild a SymmetryShop pattern from the old seed
layer” on page 46 for details.

Note: The plug-in does not create the SymmetryShop Selection channel if you call it without
selecting anything in the artwork.
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You can use layer and vector masks as alternatives to selecting something in the seed layer.
See “Layer and vector masks” on page 15.

You can also use layer and vector masks in combination with the selection.

Note: When creating a pattern at a reduced image size, the plug-in saves your selection as a
layer mask (rather than the SymmetryShop Selection channel).

The plug-in also automatically converts the SymmetryShop Selection to a layer mask when
you switch from 100% image size to a lower image size for an already made pattern. See “To
edit the selection applied as a layer mask in a smart object” on page 54.

The SymmetryShop Tile  While you can always create pattern presets from your
SymmetryShop patterns simply by clicking the Export button  (see “SymmetryShop
patterns and Photoshop patterns” on page 40), the plug-in provides you with
additional flexibility by automatically saving the SymmetryShop Tile alpha channel.
For example, by moving the SymmetryShop Tile selection, you can choose the exact
area to export as a pattern preset. Or you can create more complex presets by
doubling (or tripling, and so on) the repeat size and modifying the pattern area
inside the new repeat rectangle. See “The Spools: Creating Complex Repeats” on
page 83 for step-by-step instructions.

B CA D
Producing more complex repeats by colorizing a pattern.

A. The original pattern; symmetry setting: Quarter-turns & rotated mirrors   B. Repeat size defined
by the SymmetryShop Tile  C. Repeat size increased two times in the horizontal direction  D. Repeat
size increased two times in both the horizontal and vertical directions
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Note: The plug-in does not save the SymmetryShop Tile if you deselect the Snap to
Rectangular Grid check box or if you select None from the Constrain Shift pop-up menu.

You can use the Show/Hide SymmetryShop Tile button  to access the SymmetryShop tile.
Hold down the Ctrl button (Windows) or the Command button (Mac OS) and click the
Show/Hide SymmetryShop Tile button  to apply the SymmetryShop Tile channel as a
selection.

Work path  SymmetryShop saves the control
path as a work path in your document. The
control path defines the repeat size and
orientation of your pattern. See “The control
path” on page 23. In the beginning, you will
let SymmetryShop to create a control path for
you and edit it using the sliders in the
SymmetryShop panel. However, as you gain

Work path contains the control path.

experience, you will often find it more convenient to access the control path directly by
using the Select/Deselect Control Path button  or through the Paths panel. This lets you
interactively edit the path using the usual Photoshop tools, such as the Path Selection
tool, the Direct Selection tool, or the free-transform handles that you can activate by
choosing Edit > Transform Path. You will then re-run the plug-in by clicking the Update
button in the SymmetryShop panel. See “To edit the control path using Photoshop tools”
on page 55.

When using the Transform Path command, SymmetryShop will update your pattern
automatically as soon as you commit a transformation.

The symmetry controls and the tiling size controls

The symmetry controls determine how SymmetryShop patterns are organized and the
tiling size controls determine how many “rows” and “columns” of tiles are displayed.
For the default pattern orientation, the first and second tiling controls set the number of
tiles in the vertical and horizontal directions, respectively. Together, the symmetry and
the tiling size controls determine the shape of a pattern fragment produced by the plug-
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in. In most cases, the fragment will not be rectangular. However, you can easily export
the rectangular part that seamlessly tiles the plane by clicking the Export button ,
provided that you have built a large enough fragment. See “SymmetryShop patterns and
Photoshop patterns” on page 40.

Even if you eventually need a bigger tiling, it is a good idea to work with a tiling of a smaller
size while making edits; then increase the tiling size in the final artwork. The tiling size 2 × 2
or 3 × 3 is often a good choice for edits.

Changing the symmetry type from Double glide  (left) to Three rotations  (right).
Tiling size 2 × 3.

Layouts

Preset (built-in) layouts available in the Layout section of the SymmetryShop panel
let you create some of the most commonly used types of patterns with a single click.
These include stripe, brick, drop, diamond, gradation, spot, and grid repeats. See
“Layouts and Repeat Systems” on page 62. The Layouts folder inside your
SymmetryShop folder contains examples of the built-in layouts. To create a pattern
with a particular layout, choose a layout of your choice in the Layout list and click
the Make button. You can also change a layout after a pattern is created or try
different layouts in turn. You can also apply a different symmetry setting to the
chosen layout.
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Layout list and symmetry setting  Notice the small symmetry icons to the left of the
layout names in the Layout list. Each layout is based on one of the seventeen primary
symmetry types. When you choose a layout, the corresponding symmetry control is
selected. The only exception to this rule is the Normal layout, which could be based
on any symmetry.

Replicas  A basic unit of repetition in many
preset layouts consists of several copies of the
seed objects that are rotated, reflected, and/or
scaled to produce the desired effect.
Additional copies of the seed that are
included in the basic unit are called replicas.
The number of replicas in each layout is
different as are the sizes and orientations of
replicas. By creating a pattern with a preset
layout and applying a different symmetry
type, you can capture the replicas and put
them in a different repeat. This lets you create
an even richer variety of patterns. To delete
replicas, click the Delete Replicas button 
in the Layout section.

An example of a 3 × 3 grid layout. The basic unit
of repetition consists of the selection and 8
replicas.

The Normal layout and replicas  Changing the symmetry (and in many cases the
size of the control path) switches the layout in the Layout list to the Normal layout. If
the Normal layout inherits replicas from a previous layout, the replica source is
indicated in the text of the Normal entry. The existence of extra replicas is also
highlighted by the Extra Replicas icon . By itself, switching to the Normal layout
changes neither the symmetry setting nor the number or position of replicas. The
Normal layout can correspond with any symmetry.
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Using the replicas created by the Vertical gradation layout (left) in a pattern with the

symmetry type Double glide  (right).

The control path

At the outset of building a pattern, SymmetryShop checks for the presence of a work
path in your document. If no work path exists, the plug-in will add one. The path
object in the work path is called the control path and it serves the same purpose as the
bounding box in Photoshop’s patterns. You can use the control path to interactively
adjust the layout and the repeat size of your pattern. The shape of the control path is
different for different types of symmetry. To see the control path, click the
Select/Deselect Control Path button  in the SymmetryShop panel.
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The rules for creating the control path are as follows:

1 If there is a work path in the document, the plug-in uses it as a starting point. See
“Prototype control path” on page 26.

2 In the absence of a work path, SymmetryShop checks whether there is a selection.
If a selection is present, the plug-in builds the control path based on the
bounding box of the selection.

3 If there is no selection, the plug-in selects (unmasked parts of) the artwork and
uses that region to create the control path.

In most cases, you will start by selecting an interesting part of your artwork and launching
SymmetryShop without any work path. The plug-in will create the control path for you and
let you edit it interactively using the Transform Path command, other Photoshop tools, or
sliders in the SymmetryShop panel.

If your artwork contains a work path that you do not wish to use as a control path, rename it
before launching the plug-in.

Editing the control path  The SymmetryShop panel lets you move the control path
in the horizontal and vertical directions using the X and Y position text boxes . You
can also change the width and height (if the selected symmetry allows) of the control
path using the W and H scale boxes . For the default pattern orientation, the width
and height of the control path determine the repeat size of your pattern in the
horizontal and vertical directions respectively.

Not all symmetries allow you to change the width and height independently. If the
change is prohibited by the symmetry laws, the Height box is dimmed. If the change
is allowed, you can still change the width and height simultaneously by pressing the
Link button .

Although text boxes in the SymmetryShop panel display values in whole units, you can enter
them with higher precision (for example, 2.25) to make precise alignments.

For some symmetries, you can also distort the control path using the skew controls
: the skew menu, which lets you choose between the skew in the horizontal,

vertical, and arbitrary directions, and the Amount text box. The skew controls are
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particularly useful for creating drop and brick repeats. See “To create a brick or drop
repeat manually” on page 29. Not all skew directions and amounts are allowed if you
want to keep your pattern repeating with a certain step in both horizontal and
vertical directions. SymmetryShop will automatically pick the correct amount that is
closest to your choice as long as the Snap to Rectangular Grid check box is selected
and the Constrain Shift is set to any value other than None. See “Snap to Rectangular
Grid” on page 28.

Finally, you can rotate the control path using the rotation angle box  and thus build
the pattern in directions other than the default horizontal and vertical directions.
Rotation of the control path can make your pattern not repeat in the horizontal and
vertical directions (it would still repeat in some other directions). When the Snap to
Rectangular Grid check box is selected, SymmetryShop will prevent you from
making such choices. See “Snap to Rectangular Grid” on page 28.

Note: Some layouts are defined only on a rectangular grid. SymmetryShop disables the skew
 and rotation  boxes in such cases. To enable them, choose the Normal layout from the

list.

You will often find it convenient to edit the control path with regular Photoshop tools. See
“To edit the control path using Photoshop tools” on page 55 and “Control points” next. Also,
see “The Tulips: Editing the Control Path” on page 80 for step-by-step instructions.

Control points  You will need to know a little more about the control path if you
wish to edit it using the usual Photoshop tools. Depending on the symmetry type, the
control path can have three or four anchors, of which you can freely move two or
three. The rest are uniquely determined by symmetry laws. The free anchors are
called the control anchors or control points. If you move control anchors and rebuild the
pattern, your edits will result in pattern changes. If, however, you attempt to move a
dependent anchor, you will see that the anchor simply restores its position.
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Dragging an anchor of the control path with the direct-selection tool and the result after
rebuilding the pattern.

Prototype control path  Once you familiarize yourself with how the control paths
look, you will sometimes find it simpler to give the plug-in a recommendation for
constructing the control path, by creating a prototype. A prototype can be supplied
as a work path in your document. If the prototype is suitable (contains enough
control points), the plug-in will not add an extra path to your artwork, but rather will
modify the prototype in place as necessary to create the control path.

To create a work path, make sure that no paths are highlighted in the Paths panel,
select the Pen tool in the Photoshop toolbox, click the Paths button in the options bar,
and then click several times in the artwork with the Pen tool to create a path. For
more on creating and editing a work path, see Photoshop’s User Guide.

Important:  Do not leave any path that you want to preserve in your document as a work
path. To preserve a work path it is sufficient to rename it. Double-click the path in the Paths
panel to supply a new name.



Artlandia SymmetryShop
User Guide

 27

Creating a pattern with a prototype control path. In the resulting pattern, points of the control path are

close to the points of the prototype. Symmetry setting: Perpendicular mirrors & glide , tiling 2 × 2.

When constructing the control path from
a prototype, SymmetryShop takes the
first two control points directly from the
prototype, in the order in which they
appear in the prototype. Then the plug-
in builds the third (and, for some
symmetries, the fourth) point moving in
the counterclockwise direction. The new
points are placed as close to the
consecutive points in the prototype as
symmetry permits. The remaining
points in the prototype, if any, are
discarded.

2 1

1 2

Clicking the same points 1 and 2 in the prototype
control path in a different order brings about
different patterns. Symmetry setting:

Kaleidoscope , tiling 1 × 1.

It is not necessary to figure out exactly where all the points in the prototype control path
should be to satisfy symmetry laws. To get started, it is usually sufficient to click two or three
times (depending on the symmetry type) in the seed area of the artwork with the Pen tool.
Then you launch SymmetryShop and adjust the control path interactively.
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Repeat directions

By skewing and rotating the control path, you can create the brick and drop repeats
and change the pattern orientation. Typically, you will do so using the usual
Photoshop vector path tools or the Skew Direction pop-up menu, the Skew Amount
box, and (less frequently) the Rotation Angle box in the Control Path section of the
SymmetryShop panel. The Horizontal and Vertical choices in the Skew menu let you
create brick repeats and drop repeats, respectively, and by rotating the control path
and using the Arbitrary skew, you can create intermediate cases.

By default, SymmetryShop makes patterns that repeat both horizontally and
vertically. This is achieved by (a) restricting orientation of certain control points
relative to the artboard, and (b) limiting incremental changes in the position of other
control point(s). You can lessen, or lift these restrictions altogether, using two
separate controls that are available at the bottom of the Control Path area of the
SymmetryShop panel.

Snap to Rectangular Grid  When the Snap
to Rectangular Grid check box is selected, the
pattern repeats in either the horizontal or
vertical direction, for all possible symmetries.
If, in addition, you choose any value other

Controls for restricting pattern orientation in the
SymmetryShop panel.

than None from the Constrain Shift pop-up menu, the pattern will repeat in both
directions. To ensure alignment, the plug-in makes the anchors of the control path
snap into appropriate positions. Deselecting the Snap to Rectangular Grid check box
also disables the Constrain Shift pop-up menu and gives you complete freedom in
choosing the pattern orientation. However, it also disables the Export button  and
the Preview Pattern button  and prevents the plug-in from creating the
SymmetryShop Tile channel (see “SymmetryShop patterns and Photoshop patterns”
on page 40).

Even if you deselect the Snap to Rectangular Grid check box, you can still make patterns that
repeat in horizontal and vertical directions and later create a proper bounding box and define
a preset pattern in Photoshop. However, this usually requires a considerable amount of
manual work.
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Constrain Shift  The default setting of the Constrain Shift pop-up menu, 1/2, allows
you to easily create the brick and half-drop repeats, in which the repeating units in
the next row (column) of the pattern are shifted halfway relative to the previous row
(column). You can also choose 1/3, 1/4, and smaller shifts from the list, down to 1/12.

Using smaller shifts, you can make a richer line of repeats. For example, with the 1/6 shift,
you can create a 1/6, 1/3 (2 × 1/6), half-drop (3 × 1/6), 2/3 (4 × 1/6), 5/6, and the full-drop or
straight repeat (0 × 1/6 or 6 × 1/6).

As long as Constrain Shift is set to a numeric value, you do not have to figure out which
skew amount is appropriate for your desired type of repeat. You can simply drag the Skew
Amount pop-up slider and the plug-in will automatically choose the closest allowed amount
as soon as you release the mouse button.

You can make the simple brick and half-drop repeats by selecting the Brick or Half-
drop layouts from the Layout list. However, it is also useful to learn to make these
repeats manually, which enables you to create many variations, for instance, smaller
drop repeats, drop repeats with replicas, and others.

To create a brick or drop repeat manually:

1 Create a SymmetryShop pattern of the desired symmetry type, typically, Simple
shift . For special effects, you may choose the Mirror & glide , Perpendicular
mirrors & glide , or Half-turn  symmetries.

2 Make sure that the Snap to Rectangular Grid check box is selected and choose the
desired value in the Constrain Shift pop-up menu (1/2 for half-drop, 1/4 for quarter-
drop, and so on).

3 Choose Horizontal from the Skew Direction pop-up menu for the brick repeat or
Vertical for the half-drop repeat.

4 Drag the Skew Amount slider to a value close to 50% (for the brick and half-drop
repeats). As soon as you release the mouse button, the value snaps to exactly 50%.
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Creating the brick repeat (left) and the half-drop repeat (right) by choosing the Horizontal and Vertical

settings (respectively) from the Skew Direction pop-up menu. Symmetry setting: Simple shift ,
tiling 4 × 4, constrain shift ½, skew amount 50%.

The SymmetryShop Tile selection for the half-drop repeat, created with the constrain-shift setting 1/2
(left) and the quarter-drop repeat, created with the constrain-shift setting 1/4 (right). Symmetry

setting: Simple shift , tiling 4 × 4.
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Tile size  The smaller the shift in brick and drop repeats, the more lines of repeat you
need before the pattern rights itself in the vertical (for brick repeats) or horizontal
(for drop repeats) direction. You must keep this in mind if you plan to export your
pattern for use as a pattern preset (see “SymmetryShop patterns and Photoshop
patterns” on page 40). For half-drop, the pattern repeats after two lines, for quarter-
drop, after four lines, and so on. The Show/Hide SymmetryShop Tile button  lets
you see the exact rectangle that is used by the Export button .

If the pattern fragment created by SymmetryShop does not completely cover the
SymmetryShop Tile selection, increase the tiling size as necessary to avoid gaps in the
exported pattern.

Interlocking and self-contained units of repetition

By letting the seed objects extend beyond the boundaries of the control path, you can
create interconnected (interlocking) patterns or achieve special effects when the
objects overlap with their own images in the neighboring units. In such cases, you
need to be aware of the order in which SymmetryShop builds patterns.

Painting order  SymmetryShop always starts by copying the seed image from the
seed layer to the pattern layer (the SymmetryShop Layer). Then the plug-in creates
replicas, if any. The seed and replicas form a unit of repetition. The plug-in then
duplicates that unit and transforms it as necessary to create the first tile. Then it
duplicates the tile to create the first row. Finally, the plug-in copies the row as many
times as necessary to finish the pattern fragment. The tiling size controls in the
SymmetryShop panel determine the number of tiles in a row and number of rows in
the pattern fragment.
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Creating an interlocking pattern from an object that extends beyond the boundaries of the

control path. Symmetry setting: Six rotations , tiling 2 × 2. The tutorial “The Tulips:
Editing the Control Path” on page 80 gives another example.

Special effects produced by overlapping images of the seed (left). Symmetry setting:

Double glide , tiling 2 × 2.
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Self-contained units of repetition produced by clipping a “brush” seed image (left) at

the boundaries of the control path. Symmetry setting: Six rotations , tiling 2 × 2.

Clip at Control Path  To clip your motif
(that is, the selected part of the seed layer)
at the boundaries of the control path,
check the Clip at Control Path box in the
Clipping section of the SymmetryShop
panel. This option allows you to build a
pattern from self-contained units of
repetition and is especially useful for
creating block repeats (see “Block repeats”
on page 35).

Selecting the Clip at Control Path check box in the
SymmetryShop panel. Symmetry setting: Quarter-

turns & rotated mirrors , tiling 1 × 3.



34 Chapter 1
An Overview of Artlandia SymmetryShop

Clip options  The options in the Clipping
section of the SymmetryShop panel let
you choose between separate and fused
units of repetition and further specify how
fused units should be blended. With the
Overlap and Feather boxes, you choose an
appropriate amount of overlap between
neighboring units and the feather radius
to ensure a smooth transition between
units. To have crisp, separate units, set
both the overlap and feather values to
zero (and possibly deselect the Anti-
aliased check box). Separate (top) and fused (bottom) units of repetition.

The fused units extend beyond the boundaries of the
control path by the amount of overlap. Symmetry

setting: Pinwheel , tiling 1 × 3.

Using the feather effect to blend overlapping units clipped at the boundaries of the

control path. Symmetry setting: Glide reflection , tiling 1 × 2.
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Block repeats  Block repeats can be instantly created from rectangular images or by
letting the plug-in pick up a rectangular seed element based on the control path. You
can use symmetry types that involve reflection, glide reflection, or 180° rotation, such
as Double mirror , Double glide , or Half-turn —or even Simple Shift —to
quickly produce a block pattern or a border. For block repeats, you will typically use
a very small or no overlap and a small or no feather radius.

Creating a block repeat from the selected rectangle. Symmetry setting: Double mirror , tiling 1 × 2.

Feathered selection edges  Just as you use the feather effect to blend units clipped
by the control path, you can apply the usual Photoshop feather effect to edges of
your selection before launching SymmetryShop. Choose Select > Feather to apply the
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feather effect to the selection. Then launch SymmetryShop and let the units of repeat
overlap by using the control path sliders. The plug-in will blend overlapping units.

Putting a zebra design in the half-drop repeat. To blend the overlapping units, the feather effect is

applied to edges of the selection. Symmetry setting: Simple shift  , tiling 4 × 4 (fragment).

When editing the contour of the selected region to achieve a suitable blending, you may find it
convenient to re-apply SymmetryShop multiple times without switching to the seed layer.
The option Seed Layer Has Priority Over Pattern Layer, which you can set in the Preferences
dialog, makes interactive editing of the selection contour easier. See “Seed Layer Has Priority
Over Pattern Layer” on page 50.
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Reducing the image size

Working with reduced-size images lets you build your patterns much faster. To
create a pattern at a reduced size, type in a value between 1% and 100% in the Image
size text box and press the Enter key. Then click the Make button in the
SymmetryShop panel. You can also change the image size after you create a pattern.

Click the Toggle Image Size button  to toggle between the 20% and the 100% image size.

When reducing the image size, SymmetryShop converts your seed layer to a smart
object. A selection, if any, is converted to a layer mask. This lets you retain the
original motif and rebuild the pattern at full quality when you are ready.

A pattern created from a high-resolution motif at 2% image size (lower-left) and at 10% image size

(main image). Symmetry setting: Simple shift   (5-spot layout), tiling 2 × 2 (fragment).
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You must select either the SymmetryShop Layer or the seed layer in the Layers panel to
change the image size setting in an existing pattern.

Note: Working with reduced-size images is not fully supported when running
SymmetryShop as an action or in autorun.

Supported objects

Besides the usual raster images (of any size that is supported in your version of
Photoshop), you can use fill and shape layers (filled with a solid color, a gradient, or
a pattern), type layers, as well as smart objects, as the source of your SymmetryShop
patterns. Smart objects are especially useful because they give you essentially
unlimited flexibility by letting you use any Photoshop or Illustrator object, and any
combination of such objects, as the pattern seed. See ”Using smart objects” on page
48.

An optical pattern created from a pattern fill. Symmetry setting: Double glide ,
tiling 2 × 2.

You can use vector and layer masks in combination with all layer types. See “Layer and
vector masks” on page 15.
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In your seed layer, all vector elements (shape and type layers, vector masks, etc.) remain in
their original vector form so you can edit them and rebuild the pattern at any time.

Locking the seed layer When working on your patterns, you may find it convenient
to lock the seed layer fully or partially to prevent further changes to the entire seed
layer, its non-transparent contents, or the positioning of the seed objects.
SymmetryShop does not modify your seed layer and allows you to use all types of
locks that are appropriate for your task.

Note: You cannot lock a seed layer that needs to be converted to a smart object when working
with reduced size images.

If you wish to protect contents of a layer from changes while working with reduced-size
images, lock the layer and convert it to a smart object yourself. Then set the image size in the
SymmetryShop panel and click Make.

A half-drop pattern created with type. Symmetry setting: Simple shift , tiling
6 × 6 (fragment).
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A SymmetryShop pattern created from a smart object that contains a SymmetryWorks pattern (plaid)
and several raster floral elements. All components remain separately editable, including the plaid that

can be interactively edited with SymmetryWorks in Illustrator. Symmetry setting: Double glide ,
tiling 2 × 2 (fragment).

SymmetryShop patterns and Photoshop patterns

While working with the SymmetryShop panel, you can save (export) a snapshot of
your pattern as a pattern preset. To save a pattern preset, click the Export button .

To specify a non-default name for your preset, hold down the Alt key (Windows) or the
Option key (Mac OS) and click the Export button .

The exported pattern is based on a rectangular tile that is selected in the middle of
the pattern fragment produced by the plug-in. The fragment must have enough rows
and columns to completely cover the tile. This ensures a seamless exported pattern,
without gaps or other defects. You can preview the exported area by clicking the
Show/Hide SymmetryShop Tile button  in the SymmetryShop panel. Typically,
2 × 2 or 3 × 3 tilings are sufficient to cover the tile area. However, you may need a
bigger tiling to make brick or drop repeats or in cases where parts of the seed image
extend far beyond the boundaries of the control path. You can preview the exported
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pattern by clicking the Preview Pattern button . The previewed pattern is also built
in the SymmetryShop Layer.

To preview the pattern in a separate layer, hold the Ctrl key (Windows) or the Command key
(Mac OS) and click the Preview Pattern button .

Select an area of the artwork to build the pattern preview only in that area.

Parts of all visible layers in the artwork that fall within boundaries of the SymmetryShop Tile
are included in the exported pattern and pattern preview.

Note: The Export button  and the Preview Pattern button  are not available when the
Snap to Rectangular Grid check boxes are deselected or the Constrain Shift pop-up menu is
set to None.

When building a SymmetryShop pattern, the plug-in saves the rectangular tile
selection for your pattern in the alpha channel called SymmetryShop Tile. You can
load that channel as the selection at any time and define a pattern preset “manually,”
exactly as you would define any other pattern preset (see “To define an image as a
preset pattern” in Photoshop’s User Guide).

To define a pattern preset manually:

1 Open a file with a SymmetryShop pattern (if it is not open).

2 Select the SymmetryShop Layer in the Layers panel (if it is not selected).

3 Load the SymmetryShop Tile selection by doing one of the following:

• Hold down the Ctrl key (Windows) or the Command key (Mac OS) and
click the Show/Hide SymmetryShop Tile button .

• Open the Channels panel and Ctrl-click (Windows) or Command-click
(Mac OS) the SymmetryShop Tile channel thumbnail.

4 Optionally, use Photoshop’s tools to move the selection to some other position in
the artwork. For example, you can move it so the area that you wish to edit is entirely
inside the selection (as in the pattern based on the SymmetryShop Tile on page 56).
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The tutorial “The Spools: Creating Complex Repeats” on page 83 gives another example
where you make your work easier by moving the tile selection.

When moving the SymmetryShop Tile selection, you do not need to take any special
precautions to position the selection relative to any symmetry axes or other elements of the
pattern. As long as you move the selection around without changing its size, and the
selection remains within the repeating part of the SymmetryShop pattern fragment, the
pattern preset based on the selection will repeat seamlessly.

5 Optionally, make edits inside the selected area.

You can make arbitrary changes inside the selected area. The pattern preset will repeat
seamlessly as long as your edits do not touch the boundaries of the selection.

6 Choose Edit > Define Pattern, fill in the pattern name, and click OK.

Pattern presets created with SymmetryShop or manually are available for all usual
Photoshop uses with the Paint Bucket, Pattern Stamp, Healing Brush, and Patch
tools, or with the Layer Style dialog box. See Photoshop’s User Guide for details.

Exporting to web browsers and textile CAD programs

To make a background for a web page or to use a pattern in a textile CAD program,
you need to create and export a rectangular tile that seamlessly covers the surface.
The SymmetryShop Tile channel saved with your pattern lets you easily export one
such tile. To export a rectangular tile, load the selection defined by the
SymmetryShop Tile (follow the first three steps in the preceding section), then choose
Image > Crop, and save the file.

Applying preset styles

Since the SymmetryShop pattern layer is a usual Photoshop layer, you can treat it as
one once the pattern is made. In particular, you can apply various Photoshop
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Layer styles copied from the seed layer and applied automatically while patterns are
being edited. The two patterns are produced from the same seed using different layer

styles. Symmetry settings: Kaleidoscope , tiling 2 × 3 (top) and Simple shift 
(Vertical gradation layout), tiling 3 × 7.
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preset styles to quickly enhance a pattern created with the plug-in. You will also find
it useful to apply a preset style to the seed layer before launching SymmetryShop. In
this case, the plug-in will copy the style to the pattern layer and apply it
automatically while you interactively edit your pattern with the SymmetryShop
panel. This lets you easily find parameters that are suitable for the pattern you are
developing.

Applying preset Photoshop styles to a SymmetryShop pattern (left). Symmetry setting: Pinwheel ,
tiling 2 × 2.

Multiple windows

When working with complex patterns, you may find it helpful to open a second
(third, and so on) window and zoom in on different areas in different windows while
keeping an overall pattern preview in your main window. This lets you see different
areas of the pattern while working with the SymmetryShop panel. To open a second
window, choose Window > Arrange > New Window for your file, as described in
Photoshop’s User Guide.

In Photoshop CS3 and later, you can run SymmetryShop automatically inside a smart object.
This lets you edit the seed in one window and observe the pattern in another window. See “To
autorun in a smart object” on page 58.
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Chapter 2
Working with SymmetryShop Patterns

SymmetryShop creates patterns from either RGB or CMYK images. If your image is
neither of these, you must convert it before SymmetryShop can be applied. Choose
either Image > Mode > RGB Color or Image > Mode > CMYK Color to convert.
Further, you must have only one layer selected in the Layers panel when launching
SymmetryShop.

If you wish to build a pattern from multiple layers, either combine them in a smart object (in
Photoshop CS2 and later versions) or merge the layers, as instructed in Photoshop’s User
Guide.

SymmetryShop remembers its numerous settings and automatically applies them
every time you launch the plug-in. When rebuilding a previously made
SymmetryShop pattern, the settings are the ones that you used to create the pattern.
For a new pattern, the panel retains the settings from the last created pattern.

Click the Refresh Panel button  to show the setting used in the currently selected
SymmetryShop pattern.

Creating patterns

SymmetryShop builds a pattern based on your selection, if you supply one when you
create a pattern. That selection is saved in the SymmetryShop Selection channel. It is
not necessary to re-apply the selection every time you rebuild the pattern. If there is
no active selection in the artwork, the plug-in automatically loads the SymmetryShop
Selection channel, restoring the selection that you used the first time. This makes it
easy to re-create a SymmetryShop pattern in another session.

If, on the other hand, you select something in the artwork before re-launching
SymmetryShop, the plug-in will treat your active layer (the layer highlighted in the
Layers panel) as a new seed layer. By default, this rule applies even if your active



46 Chapter 2
Working with SymmetryShop Patterns

layer is the SymmetryShop Layer. This lets you use the pattern layer as a new seed
layer. However, you can also choose to apply the selection to your old seed layer
even when the SymmetryShop Layer is active. To do so, select the check box Seed
Layer Has Priority Over Pattern Layer in the Preferences dialog box (see “Seed Layer
Has Priority Over Pattern Layer” on page 50).

To create a SymmetryShop pattern:

1 Select a seed layer in the Layers panel. The layer must be visible (click the eye
icon to make the layer visible).

2 Optionally, apply a layer and/or vector mask to isolate (mask)  areas that you do
not want to use in your pattern. See “Layer and vector masks” on page 15.

3 Optionally, select a part of the image that you want to use as a seed with one of
Photoshop’s selection tools (for example, the Lasso tool).

4 Optionally, to control the initial appearance of the pattern, draw a prototype
control path (a work path). See “Prototype control path” on page 26.

5 Choose the symmetry type and the tiling size in the SymmetryShop panel (you
can change these settings once the pattern is created).

6 Optionally, to create a smaller image from a high-resolution motif, set the
desired value in the Image Size text box or click the Toggle Image Size button . See
“Reducing the image size” on page 37.

7 Click Make in the SymmetryShop panel.

To rebuild a SymmetryShop pattern from the old seed layer:

1 Do one of the following:

• Activate the seed layer (for example, by clicking the Target Seed/Pattern
Layer button ).

• Deselect the artwork (for example, using Select > Deselect) and leave the
SymmetryShop Layer selected in the Layers panel.

2 Click Update in the SymmetryShop panel.
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Note: If an artwork contains a layer named the SymmetryShop Layer, the plug-in will apply
a selection channel named the SymmetryShop Selection (if there is one) if you launch the
plug-in without selecting anything in the artwork.

To discard the previously used selection, either delete (or rename) the SymmetryShop Layer
or delete (or rename) the SymmetryShop Selection.

To create a pattern using the SymmetryShop Layer as a new seed layer:

1 Select the SymmetryShop Layer in the Layers panel (if it is not yet selected).

2 Make sure that the SymmetryShop Layer is visible (click the eye icon to make the
layer visible).

3 Select a part of the SymmetryShop Layer using any of Photoshop’s selection tools
(for example, the Lasso tool).

4 Click Update in the SymmetryShop panel.

To use the SymmetryShop Layer as a seed layer without selecting anything in the artwork,
rename the SymmetryShop Layer. To rename, double-click the name of the layer in the Layers
panel and type in a new name.

When working on a pattern, you will often want to add space around your seed
elements to give the plug-in more room to build your pattern. This is necessary, for
example, when the document is not sufficiently large to fit enough rows and columns
of the pattern or when you wish to add the exact amount of canvas space yourself
rather then relying on the plug-in to extend canvas for you. In such cases, you will
simply increase the canvas size and rebuild the pattern.

Note: All SymmetryShop components, including the SymmetryShop Selection and the work
path, are automatically repositioned when you change the canvas size or the image size of
your document. Therefore, in most cases, you will not need to change (or re-apply) your
selection or move the control path to the new location.

To rebuild the pattern when changing the document size:

1 Choose Image > Canvas Size. Fill in the necessary fields in the dialog, and click
OK.
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2 Click Update in the SymmetryShop panel.

Similarly, you can use the Crop tool (or Image > Crop) when you need to decrease
the size of your document. As long as you leave enough space for the plug-in to
rebuild your pattern, you do not need to reposition your selection and the control
path.

Using smart objects

Smart objects (available in Photoshop CS2 and later versions) provide a powerful and
convenient way to build a wide variety of patterns. You can use a smart object as a
seed layer or build a SymmetryShop pattern inside a smart object. These two uses
have their own advantages and they can be combined. That is, with smart objects,
you can nest SymmetryShop patterns.

For example, you will find it convenient to build a pattern inside smart objects to:

• Create several SymmetryShop patterns in one artwork.

• Crop a SymmetryShop pattern (and still be able to rebuild the pattern
inside).

• Use the autorun feature. See “To autorun in a smart object” on page 58.

On the other hand, you may want to use a smart object as a seed layer to:

• Create a pattern from multiple source layers (and be able to independently
edit each layer and rebuild the pattern).

• Create all-over,  tossed,  composite,  and other repeats. See “Implementing
other repeat systems” on page 69.

• Use one SymmetryShop pattern as a source for another.

• Use a SymmetryWorks pattern as a source for a SymmetryShop pattern.
See an example on page 40.
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• Use the autorun feature. See “To autorun in the main document” on page
60.

You can use all the standard Photoshop techniques to put your SymmetryShop pattern inside
a smart object. See “Create Smart Objects” in Photoshop’s User Guide.

To create a SymmetryShop pattern in a smart object:

Do one of the following:

• If you are making a new SymmetryShop pattern, do it in a smart object.
For example, select your seed layer in the Layers panel and choose Layer >
Smart Objects > Convert to Smart Object. Then double-click the layer
thumbnail in the Layers panel (or choose Layer > Smart Objects > Edit
Contents) and proceed to create a SymmetryShop pattern as usual. See “To
create a SymmetryShop pattern” on page 46.

• If you have already created a SymmetryShop pattern, save the file and
choose File > Open as Smart Object (to open in a new document) or File >
Place (to place in an existing document), as you usually do in Photoshop.

Note: Highlighting both the seed layer and the SymmetryShop Layer in the Layers panel and
choosing Layer > Smart Objects > Convert to Smart Object may not properly transfer all
pattern components to the new smart object and is not generally recommended (although, in
some cases, it may give satisfactory results).

You can create a SymmetryShop pattern from a smart object just as you would
normally do from any other seed layer.

To use a smart object as a seed layer:

1 Optionally, if you do not have a smart object that you want to use as a seed,
create a new smart object (for example, by selecting one or several layers in the
Layers panel and choosing Layer > Smart Objects > Convert to Smart Object).

2 Select the smart object in the Layers panel and create a SymmetryShop pattern as
usual. See “To create a SymmetryShop pattern” on page 46.
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Changing SymmetryShop preferences

To open the Preferences dialog, choose SymmetryShop Options in the pop-up menu
in the SymmetryShop panel.

The Preferences dialog (the dialog may look slightly different on your computer).

Enable Autorun  You can choose to automatically re-run SymmetryShop after you
edit the pattern seed. To do so, you must create a SymmetryShop in a smart object or
use a smart object as a seed layer. See “Autorun” on page 57. To enable the autorun
feature, select the Enable Autorun check box.

Note: The Enable Autorun check box is available only in Photoshop CS3 and later versions.

Seed Layer Has Priority Over Pattern Layer  By default, when you launch
SymmetryShop with some area of the seed image selected, the plug-in considers your
active layer (the layer highlighted in the Layers panel) to be the seed layer, see
“Creating patterns” on page 45. You can change that convention and tell
SymmetryShop to rebuild the pattern from the old seed layer, even if there is a
selection and the pattern layer (the SymmetryShop Layer) is currently the active
layer. To do so, select the Seed Layer Has Priority Over Pattern Layer check box. You
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will find this option convenient when you want to quickly re-apply the plug-in after
making edits that do not require making the old seed layer active, for example,
changing the contours of the selection.

Symmetry Icon Tips  SymmetryShop lets you switch between long and shorthand
(mathematical) tool tips for the symmetry controls. You may prefer the mathematical
notation for its brevity, even if it seems obscure.

Selection  SymmetryShop may need a temporary copy of your seed image while
building a pattern. The copy is created and removed automatically when no longer
needed. Using the Stray Pixel Cleanup controls, you can choose to either expand the
selection by a certain number of pixels or grow the selection within a certain
tolerance to delete any stray pixels that might remain in the temporary copy. The
Refine Automatic Selections check box lets you apply the same method when
selecting non-transparent pixels of your seed image. See “Using selection” on page
14.

Distance to Work Area  The Distance to Work Area text box lets you change the
distance from the original seed image to the temporary work area.

Finally, the Reset All Warning Dialogs button lets you reset all dialogs that you may
have disabled by selecting the Don’t Show Again check box. After you click the
button, all the dialogs will be re-enabled and displayed again when the need arises.

Using SymmetryShop pattern components

The techniques described in this section involve editing SymmetryShop pattern
components. See “Components of a SymmetryShop pattern” on page 17. Some of the
techniques can be considered “advanced topics,” which you may need rarely, if ever.
Still, these are powerful techniques that add convenience and save time.

Most frequently, you will edit the seed layer and re-run the plug-in to update the
pattern.

Editing the seed layer allows you to work on your seed image and fine-tune it after the
pattern has been created.
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Applying Photoshop’s Underpainting filter, and further the Liquify filter, to the seed image and re-
running SymmetryShop morphs the original pattern (left). The seed image is the same as in the pattern

on page 33. Symmetry settings: Simple shift  (Vertical & horizontal gradation layout), tiling 2 × 2.

To edit the seed layer:

1 If the seed layer is inactive and hidden (which is normally the case after
SymmetryShop finishes), do one of the following:

• Activate the seed layer by clicking the Target Seed/Pattern Layer button .
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• Click the seed layer in the Layers panel and click the eye icon to make the
seed layer active and visible. Optionally, click the eye icon of the pattern
layer (the SymmetryShop Layer) to hide it.

To apply the SymmetryShop Selection while switching to the seed layer, hold down the Ctrl
key (Windows) or the Command key (Mac OS) and click the Target Seed/Pattern Layer
button .

2 Edit the seed layer as you would normally edit an image in Photoshop (for
example, use any painting technique, apply a filter or layer style, edit the layer and
vector masks, etc.) .

3 Re-run SymmetryShop by clicking the Update button in the SymmetryShop
panel.

Note: You do not have to re-apply your selection every time you run SymmetryShop. The
plug-in will automatically use your previous selection (the SymmetryShop Selection), if any,
as long as your document contains the SymmetryShop Layer, even if it is hidden.

If you used a selection to create a pattern, the
plug-in saves your selection in the Symmetry
Selection alpha channel (see “The
SymmetryShop Selection” on page 18). You
can then edit that selection in a later session
using the usual means available in
Photoshop. For example, you can contract or
expand the selection, add or subtract areas,
change the feather radius, and so on. You can
then re-apply SymmetryShop using the
modified selection.

Applying the Edit > Stroke command to the
SymmetryShop Selection of the pattern on page 27
and rebuilding the pattern.
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To edit the SymmetryShop Selection:

1 Do one of the following:

• Activate the seed layer and apply the SymmetryShop Selection by clicking
the Target Seed/Pattern Layer button  while holding down the Ctrl key
(Windows) or the Command key (Mac OS).

• Click the seed layer in the Layers panel and click the eye icon to make the
seed layer active and visible. Optionally, click the eye icon of the pattern
layer (the SymmetryShop Layer) to hide it. In the Channels panel, Ctrl-
click (Windows) or Command-click (Mac OS) the SymmetryShop Selection
thumbnail to load the saved selection. Optionally, in the Layers panel, click
the eye icon for the SymmetryShop Layer to hide the pattern layer.

2 Use the selection tools, the Select menu items (for example, Select > Modify), or
any other technique available in Photoshop to edit the selection as needed.

3 Optionally, edit the seed layer. See “To edit the seed layer” on page 52.

4 Re-run SymmetryShop by clicking the Update button in the SymmetryShop
panel.

You can use layer and vector masks instead of (or in addition to) a selection. See “Layer and
vector masks” on page 15.

If the image size value in the SymmetryShop panel is less than 100%, the plug-in
does not save your selection in the SymmetryShop Selection channel, but rather
automatically applies the selection as a layer mask before converting your seed layer
to smart object. This preserves the quality of both the selection and the seed layer. See
“Reducing the image size” on page 37. You can edit your selection as you would edit
any other layer mask in Photoshop.

To edit the selection applied as a layer mask in a smart object:

1 Double-click the seed layer thumbnail in the Layers panel (or click the seed layer
in the Layers panel and choose Layer > Smart Objects > Edit Contents).

2 Edit the layer mask as usual. See “Edit a layer mask” in Photoshop’s User Guide.
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You can edit the control path using sliders and other controls in the Control Path
section of the SymmetryShop panel or using your favorite Photoshop techniques for
editing vector paths.

Depending on speed of your computer system, you may need to wait a moment after pressing
a control path slider thumb until the control path appears. You will then be able to drag the
slider as usual and see the control path interactively updated. The pattern will be rebuilt
when you release the slider.

To edit the control path using Photoshop tools:

1 Do one of the following:

• Click the Select/Deselect Control Path button.

• In the Paths panel, click Work Path.

2 Edit the work path as needed. You can use the Path Selection tool or the Direct
Selection tool in the Photoshop toolbox or Photoshop commands, notably the Edit >
Free Transform Path command or the Edit > Transform Path command.

3 Re-run SymmetryShop by clicking the Update button in the SymmetryShop
panel. Your edited work path becomes a prototype control path and will be adjusted
by the plug-in to obey the symmetry laws (see “Prototype control path” on page 26).

When using the Transform Path command, SymmetryShop will update your pattern
automatically as soon as you commit a transformation.
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Finally, you will also find it useful to work
with the SymmetryShop Tile channel in the
Channels panel. This channel is provided
solely for your convenience; the plug-in does
not use it in any way, and changing it will
not affect the plug-in’s behavior. Creating
complex repeats by colorizing a pattern is
one example of using the SymmetryShop Tile
channel (see a pattern on page 19). As
another example, you can use the channel to
define a pattern preset, for instance, after
applying small edits within the tile selection.
For more on using the SymmetryShop tile to
define a pattern, see “SymmetryShop
patterns and Photoshop patterns” on page 40.

Defining a pattern based on the SymmetryShop Tile
selection after adding a background. Symmetry

setting: Pinwheel , tiling 2 × 2.

Automating the workflow

Running as an action  In versions prior to Photoshop CS4, you can run
SymmetryShop from the Actions panel or by pressing a keyboard shortcut, which is
often more convenient than running from the File > Automate submenu. You can
record an action that runs the plug-in just as you would any other Photoshop action.
See “To use the Actions panel” in Photoshop’s User Guide for detailed instructions.

Note: In Photoshop CS4 and later versions, the SymmetryShop panel provides a much better
way to run SymmetryShop. However, the support for running the plug-in as an action is still
available.

To create an action that runs SymmetryShop:

1 Open any existing RGB or CMYK file or create a new file and paint something in
the file.
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2 If the Actions panel is not open, open it by choosing Window > Actions.

3 In the Actions panel, click the action set where you want to store your new
action, or create a new set, and click the New Action button at the bottom of the
panel.

4 In the New Action dialog, choose a name for your new action, and optionally a
function key (for example, F12), and check the modifier box, for example, Control (on
Windows) or Command (on Mac OS).

5 Click the Record button in the Actions panel to start recording.

6 Launch SymmetryShop by choosing File > Automate > Artlandia SymmetryShop.

7  In the SymmetryShop panel, select the Preview check box (to let the recorded
action launch the plug-in with preview on) or deselect the check box (to run without
preview). Then click OK.

Note: In Photoshop CS4 and later versions, choosing File > Automate > Artlandia
SymmetryShop brings up an advisory dialog (rather than the SymmetryShop dialog). Click
OK in the dialog to proceed.

8 Click the Stop button in the Actions panel.

To play the recorded action, select it in the Actions panel and click the Play button or
press the corresponding keyboard shortcut. The latter is especially useful when you
wish to quickly re-apply the plug-in after editing pattern components. As with any
other Photoshop actions, you can run your SymmetryShop action silently, without
opening the SymmetryShop panel. Click the modal control in the Actions panel to
toggle the dialog on or off.

Note: In Photoshop CS4 and later versions, you must turn the dialog off in the Actions panel
to run SymmetryShop as an action.

Autorun  Using smart objects, you can edit SymmetryShop pattern components and
run the plug-in automatically (autorun) every time your smart object is updated, even
without pressing any button in the SymmetryShop panel (or explicitly playing a
recorded action). There are two ways to update a smart object: while editing it in a
separate file and after closing the smart object file and returning to the main document
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that contains the smart object. Accordingly, there are two ways to autorun
SymmetryShop, inside a smart object and in the main document that contains the
smart object.

Note: The autorun feature is available only in Photoshop CS3 and later versions.

Select the Enable Autorun check box in the SymmetryShop Preferences dialog to use the
autorun feature. See “Enable Autorun” on page 50.

Inside a smart object, autorun lets you interactively work on your seed image and see the
pattern updated in the main document window.

If you use a vector smart object as the seed of your SymmetryShop pattern, SymmetryShop
will run automatically every time you return to Photoshop after editing the seed layer in
Adobe Illustrator (or your other vector art editor). See “To autorun in the main document”
on page 60.

To use the first method, your SymmetryShop pattern must be created inside a smart
object. See “To create a SymmetryShop pattern in a smart object” on page 49.

To autorun in a smart object:

1 Open a document that has a SymmetryShop pattern contained within a smart
object (the “main” document).

2 In the Layers panel, double-click the thumbnail of the smart object or select the
smart object and choose Layer > Smart Objects > Edit Contents.

You will usually want to move your smart object window to the side (and make it smaller if
necessary) so that you can observe the pattern in the main document window while editing
the smart object in another window.

3 If the seed layer of the SymmetryShop pattern is inactive, click the seed layer in
the Layers panel to make the seed layer active.

Note: SymmetryShop will run automatically only if the seed layer is selected in the Layers
panel.
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4 Optionally, toggle the visibility of the seed layer and the SymmetryShop layer as
necessary (click the eye icon of the layer you want to show or hide).

5 Edit the seed layer, its layer and vector masks, the SymmetryShop Selection,
and/or the control path.

6 Choose File > Save or type Ctrl-S (Windows) or Command-S (Mac OS) to save
the smart object and trigger its update in the main (parent document) window. This
starts an autorun.

When SymmetryShop finishes an autorun, it restores the active layer and the
visibility of the seed layer and the SymmetryShop layer to let you continue your edits
with minimal interruption.

SymmetryShop always saves the smart object file after rebuilding a pattern during an
autorun, but restoring the visibility of layers to the pre-autorun state may turn the file back
to an unsaved state. You will usually discard the visibility changes when closing the smart
object’s window and returning to the main document. That is, you should choose not to save
changes if you want the main document to keep the last pattern you saved.

Note:  If you do choose to save changes when closing the smart object file after an autorun,
Photoshop will save the smart object normally, in the state in which it appears on the screen.
This may overwrite the pattern saved in the parent file during the last autorun.

To save a smart object file without triggering an autorun, select any layer other than the seed
layer in the Layers panel and choose File > Save or type Ctrl-S (Windows) or Command-S
(Mac OS).

If you wish to save a smart object with the seed layer selected in the Layers panel, make
changes to your smart object, close the smart object file, and choose to save changes when
prompted by Photoshop. Alternatively, you can disable autorun in the SymmetryShop
Preferences dialog. See “Enable Autorun” on page 50.
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Running SymmetryShop automatically. The pattern shows in the main document window while the
seed element is being edited in a separate window.

If a seed layer of your SymmetryShop pattern is a smart object, you can run
SymmetryShop automatically in the main document.

To autorun in the main document:

1 Double-click the seed layer thumbnail in the Layers panel to edit your smart
object or select the layer and choose Layer > Smart Objects > Edit Contents. Your
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smart object will open in a separate window or in another application, such as Adobe
Illustrator, if your smart object is an Illustrator artwork.

2 Do one of the following:

• If you are editing your smart object file outside Photoshop, do your edits,
save the smart object file, and return to Photoshop. SymmetryShop will
rebuild your pattern as soon as you return to Photoshop.

• If you are editing your smart object file in Photoshop, do your edits, but do
not save the final version of your smart object file. Instead, close that file
by choosing File > Close or typing Ctrl-W (Windows) or Command-W
(Mac OS). Photoshop will ask if you want to save changes to the file.
Answer Yes. Your smart object file will be saved at that point and
SymmetryShop will rebuild your pattern using the final (saved) version of
your smart object.

While editing your smart object, you can save any temporary state normally, as you usually
do, but to trigger an autorun, your smart object must have an unsaved change before you
close the file. One way to quickly make a saved document unsaved is to toggle the visibility of
some layer twice. Your document will be identical to the one you saved, and yet it will be in
the unsaved state.

Note:  Working with reduced-size images is not fully supported when running
SymmetryShop as an action or in the autorun mode.
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Chapter 3
Layouts and Repeat Systems

With SymmetryShop, you can easily produce predefined repeat systems and create
new ones based on smart objects.

The built-in layouts

The Layout list in the SymmetryShop panel lets you create many predefined repeat
systems with a single click. The Layouts folder in your SymmetryShop folder
contains samples of most built-in layouts. The samples were created by applying the
chosen layout and then possibly scaling the control path.

Note: Scaling the control path may change the layout selection in the Layout list to the
Normal layout.

Built-in layouts give you much more than a single sample available from the Layout list. By
changing the symmetry type, you can quickly redeploy the replicas in a supplemental layout.
This immediately expands the repertoire of available pattern types. See “Replicas” on
page 22.

Stripe  Stripes often appear in the brick and drop layouts, especially ones created
using smaller values of the Constrain Shift option (see “Constrain Shift” on page 29).
One possible variation of the brick layout, with the Constrain Shift set to 1/3, is
provided in the SymmetryShop panel as the Stripe layout.

Diamond  A rich variety of patterns whose elements are arranged along diagonal
(diamond) lines comes from use of the Simple shift , Glide reflection , Half-turn

, and other symmetry types. The Diamond layout in the SymmetryShop panel
constructs a glide-reflection pattern with a 1:2 ratio between the sides of the control
path.
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A selected area in the Stripe layout. The control path is a parallelogram. Symmetry

setting: Simple shift , tiling 7 × 4.

A selected element in the Diamond layout. The control path is a rectangle.

Symmetry setting: Glide reflection , tiling 3 × 5.
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A selected element in the Brick layout. The control path is a parallelogram.

Symmetry setting: Simple shift , tiling 5 × 6.

Brick and Half-drop  You can create brick
and drop layouts using the Simple shift
symmetry and then applying (respectively)
the horizontal or vertical skew to the control
path. The Constrain Shift option in the
SymmetryShop panel lets you choose the
amount of shift (see “Constrain Shift” on
page 29). The Half-drop and Brick layouts in
the Layout list provide you with a quick way
to create two representative samples of these
layout types.

A selected element in the Half-drop layout. The
control path is a parallelogram. Symmetry setting:

Simple shift , tiling 5 × 6.
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Vertical gradation  Several replicas, scaled in different proportions along the vertical
direction produce a vertical gradation. Suitable symmetry types for such patterns
include Simple shift , Glide reflection , Mirror , Half-turn , and Double
glide . In the Vertical gradation layout in the SymmetryShop panel, the pattern
uses the Simple shift symmetry  and has three replicas.

This and the following gradation layouts easily make optical illusions and other optical
patterns.

A selected element in the Vertical gradation layout. The pattern has a rectangular

control path and three replicas. Symmetry setting: Simple shift , tiling 3 × 9.
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Horizontal gradation  Horizontal gradations
are very similar to vertical ones, except
scaling takes place in the horizontal direction.
One of the possible layouts of this type is
provided in the SymmetryShop panel as the
Horizontal gradation layout.

Vertical and horizontal gradation  You can
combine vertical and horizontal gradation in
one pattern. One of the possible layouts is
provided in the SymmetryShop panel as the
Vertical and horizontal gradation layout.

A selected element in the Horizontal gradation
layout. The pattern has a rectangular control path
and three replicas. Symmetry setting: Simple shift

, tiling 3 × 2.

A selected element in the Vertical and horizontal gradation layout. The pattern has a

rectangular control path and fifteen replicas. Symmetry setting: Simple shift , tiling 2
× 3.

After creating a straight pattern with vertical, horizontal, and vertical and horizontal
gradations, you can choose another symmetry type with a rectangular control path, for
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example, Half-turn  or Double glide . This is a quick way to generate many more
interesting gradations.

Gradation and scale  The Gradation and scale layout in the SymmetryShop panel is
similar to the Vertical gradation layout in the sense that the scale of replicas varies in
the vertical direction and remains constant in the horizontal direction. However, in
the Gradation and scale layout, replicas are produced by scaling the original seed
image by the same factor in both horizontal and vertical directions.

A selected element in the Gradation and scale layout. The pattern has a rectangular

control path and 47 replicas in five rows. Symmetry setting: Simple shift , tiling 2 ×
2 (a fragment shown).

Spot repeats  The SymmetryShop panel gives you the 3-spot, 4-spot, 5-spot, and 6-
spot layouts (also called sateen repeats or sateens). Spot repeats feature replicas
arranged on a rectangular grid in such a way that each row and column in the
repeated unit contains only one replica. Typically, the replicas are rotated and
possibly reflected. Spot repeats could be used to create diagonal lines in the pattern
or a random scattered appearance. For an example of a spot repeat, see the butterfly
pattern on page 14.
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A selected element in the 3 × 3 layout. The control path coincides with the outer
bounds of the grid. All objects on the grid are replicas, except for the lower-left

(selected) one, which is the seed. Symmetry setting: Simple shift , tiling 2 × 2.

Grid repeats  Similarly to spot repeats, grid
repeats are arranged on a grid, but unlike
spot repeats, all squares in the grid are
populated. The SymmetryShop panel
provides representative straight 3 × 3 and 4 ×
4 grid repeats. For each of them, the panel
also gives two similar repeats, in which every
other row or column is shifted halfway in the
horizontal or vertical direction. You can find
detailed instructions for creating a sample
pattern with a grid repeat in the Tutorial part
of this guide. See “The Random Weave:
Blending Units of Repetition” on page 74.

A selected element in the 3 × 3 layout. The feather
effect with the 5 pixel radius is applied to the
selection to create smooth transitions. Symmetry

setting: Simple shift , tiling 2 × 2.
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Implementing other repeat systems

Using a smart object as a pattern seed, you can easily create an even greater variety of
patterns. Smart objects can include one or several ordinary layers or other smart
objects, possibly linked to each other, or even other SymmetryShop patterns,
allowing you to quickly create arbitrary complex patterns. See “Using smart objects”
on page 48.

All-over repeats and tossed repeats  All-over and tossed designs are especially
easy to create with SymmetryShop. Simply make as many linked copies of your
design elements as necessary and scatter them over the desired repeat area.
Optionally, rotate, reflect, and scale the copies to achieve a more organic look. Then
combine them in a smart object and use that object as the seed of your
SymmetryShop pattern. You can always edit the design elements, reposition the
linked copies, and rebuild your SymmetryShop pattern.

To create an all-over or tossed design:

1 Choose File > New to open a new file. Fill in the width and height that are
somewhat greater than the desired repeat size.

2 Choose File > Place to place the first design element saved as a separate file. The
element will be placed as a smart object. Repeat as many times as there are design
elements.

3 Optionally, duplicate the first smart object. In most cases you will want to create
linked objects to be able to edit only one instance when the design element needs to
be modified. See “Duplicate a Smart Object” in Photoshop’s User Guide.

One convenient way to create a linked smart object in Photoshop is to select the Move Tool in
the toolbox, hold down the Alt key (Windows) or the Option key (Mac OS), click the object
you want to duplicate, and drag it in the artwork.

4 Type Ctrl-T (Windows) or Command-T (Mac OS) to place free-transform handles
around the object and move, rotate, scale, and/or flip the object as usual. Type Enter
to accept the changes.
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5 Repeat steps 3 and 4 as many times as necessary. You do not have to be precise in
positioning copies of the elements at this stage. You will be able to adjust the
positioning later (as well as add or remove copies of the design elements).

6 Select all layers in the Layers panel (for example, click the first layer and then
Shift-click the last layer).

7 Choose Layer > Smart Objects > Convert to Smart Object.

8 Create a SymmetryShop pattern as usual. See “To create a SymmetryShop
pattern” on page 46. Most frequently, you will use the Half-drop or Brick layout in
the Layout list or create a full-drop pattern using the Simple shift  symmetry. You
do not have to worry about possible gaps in the pattern at this stage.

You will usually want to interactively edit your seed object (rearrange design
elements, add/or remove copies, etc.) and then rebuild the pattern.

To edit an all-over or tossed design:

1 Double-click the seed layer thumbnail in the Layers panel (or choose Layer >
Smart Objects > Edit Contents) to open the smart object in a separate window.
Arrange the smart object window and the main document window side-by-side so
that it will be convenient for you to go back and forth between the two windows.

2 In the main document window, click the SymmetryShop Layer in the Layers
panel.

3 Select the Move tool in the toolbox.

4 In the smart object window, Ctrl-click (Windows) or Command-click (Mac OS)
the object that you want to reposition. This selects the proper layer in the Layers
panel.

5 Type Ctrl-T (Windows) or Command-T (Mac OS) to place free-transform handles
around the object and move, rotate, scale, and/or flip the object as usual. Type Enter
to accept the changes.

6 Repeat steps 4 and 5 for other design elements.
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7 Save the document to update the smart object in the main document window and
return to the main document window.

8 Optionally, if you want to change the repeat size, click the Select/Deselect
Control Path button  (or click Work Path in the Paths panel). Type Ctrl-T
(Windows) or Command-T (Mac OS) to place free-transform handles around the
control path, and drag the handles to increase or decrease the repeat size in the
horizontal and/or vertical directions. Type Enter to accept the changes. See “To edit
the control path using Photoshop tools” on page 55 and “The Tulips: Editing the
Control Path” on page 80.

9 Click Update in the SymmetryShop panel to rebuild the pattern.

10 Repeat steps 4 through 9 until you are satisfied with the pattern.

A tossed design created from two floral elements (top left). The seed consists of seven
linked copies of the first element and two copies of the second element, combined in a

smart object (bottom left). Symmetry setting: Simple shift , tiling 3 × 3
(fragment).

Composite repeats  Composite repeats combine elements of two or more symmetry
types. You can create them by nesting SymmetryShop patterns using smart objects.
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To create a composite repeat:

1 Create a SymmetryShop pattern in a smart object. See “To create a
SymmetryShop pattern in a smart object” on page 49. Typically, this pattern will
consist of a few tiles or just a single tile.

2 Optionally, add other design elements to the smart object. To add elements,
double-click the smart object thumbnail in the Layers panel to open the smart object
in a separate window (or choose Layer > Smart Objects > Edit Contents). Then add
elements, save the file, and return to the main document window.

3 Use the smart object as a seed of another SymmetryShop pattern. See “To use a
smart object as a seed layer” on page 49.

 
A composite repeat created from a floral element (top left). The seed consists of one

tile of the Pinwheel  symmetry created in a smart object (bottom left), which was

slightly rotated and put into a brick repeat. Symmetry setting: Simple shift ,
tiling 3 × 4 (fragment).



Part II
Tutorials

These step-by-step tutorials take you through all the stages of
creating several pattern designs with SymmetryShop, from start to
finish. The tutorials have extensive references to other material in
this guide and could be used as a starting point for learning and
mastering the plug-in.

Contents

Chapter 4
The Random Weave: Blending Units of Repetition

Chapter 5
The Wild Flowers: Using Multiple Source Layers

Chapter 6
The Tulips: Editing the Control Path

Chapter 7
The Spools: Creating Complex Repeats
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Chapter 4
The Random Weave: Blending Units of
Repetition

This tutorial walks your through the basic steps of creating a SymmetryShop pattern.

1 Choose File > New to open a new image
file. In the New dialog, let both Width and
Height be at least 400 pixels, Color Mode be
RGB Color, and Background Contents be
White.

If the Layers panel is not open, choose
Window > Layers to display the panel. Click
the New button in the Layers panel to create
a new layer. This will be your seed layer.
Paint a ball in the lower-left corner. You
may want to allow more room between the
ball and the bottom and left boundaries of
the image. See “Position of the seed” on
page 16 for advice on positioning your seed
image.

Alternatively, you can open the file ball.psd in the Tutorial folder in your
SymmetryShop folder.

You can paint the ball in the background layer instead (that is, skip the step of creating a new
layer), but having a white background gives a better appearance on the screen for this pattern.
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2 Very often you will select a part of your
image to use in the pattern—or isolate
(mask)  parts that you do not want. For this
pattern, use a vector mask. Right-click
(Windows) or Control-click (Mac OS) the
vector mask thumbnail for the ball layer in
the Layers panel and choose Enable Vector
Mask from the pop-up menu, or use the
Rectangle Tool from the Photoshop toolbox
to create a new vector mask for your own
seed image.

3 In the SymmetryShop panel, choose the 3 × 3 layout and deselect the Clip at Control
Path option (if it is selected). Then click the Make button.

Click the Select/Deselect Control Path button  to visualize the control path. Notice that
the area within the control path contains the original seed image and its eight copies
(replicas), as appropriate for the 3 × 3 layout. See “Layouts” on page 21 and “Replicas”
on page 22.

Also, notice narrow stripes of the white background that show through the grid of
image rectangles. You will eliminate the stripes using the control path.
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4 The control path determines the repeat
size and orientation of your pattern. See
“The control path” on page 23. You will
now slightly adjust the size of the control
path and get the units of repetition closer to
each other so that the background will not
show through in the pattern area. Click the
Link button  in the Control Path section to
change the width and height of the control
path simultaneously and decrease the size of
the control path by two points (or as
necessary) using the W text box.

5 You will now apply a selection to the
original ball image to develop the previous
pattern into one with blended units of
repetition. Click the Target Seed/Pattern
Layer button  to hide the SymmetryShop
Layer and activate the seed layer. Then
right-click (Windows) or Control-click (Mac
OS) the vector mask thumbnail of the seed
layer and choose Disable Vector Mask from
the pop-up menu. Now Ctrl-click
(Windows) or Command-click (Mac OS) the
vector mask thumbnail to load the mask as
the selection. Finally, choose Select >
Feather, set the feather radius to 5 pixels,
and click OK.
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6 Click Update in the SymmetryShop
panel. This should give you a pattern similar
to the one on page 68. As a bonus, you can
quickly create variants of this design by
choosing other values from the Layout list,
such as 3 × 3 vertical shift, 3 × 3 horizontal
shift, 4 × 4, 4 × 4 vertical shift, and 4 × 4
horizontal shift.

You can find the final pattern for the 3 × 3
layout in the file ball_RandomWeave.psd in
the Tutorial folder in your SymmetryShop
folder.
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Chapter 5
The Wild Flowers: Using Multiple Source
Layers

Very often you will want to create a pattern from a combination of multiple source
images. One way to do this is to simply flatten the layers that contain your seed
elements. However, it is much better to keep the sources in separate layers. You will
then be able to quickly rearrange elements in the seed, replace elements, combine
elements with different resolutions, and so on. In Photoshop CS2 and later versions,
this can be easily accomplished by combining multiple layers in one smart object and
using that object as a seed layer for your SymmetryShop pattern. In this tutorial, you
will learn the process. You can safely skip this tutorial if you are comfortable
working with Photoshop smart objects—there is nothing specific to SymmetryShop
to learn in this regard.

1 Open an image on a transparent
background, for example, the file
wflowers.psd in the Tutorial folder in your
SymmetryShop folder.

2 If the canvas is big enough to accommodate additional elements, skip this step and
go to the next. If not, add some extra space by choosing Image > Canvas Size or using
the Crop tool. For example, select the Crop tool in the toolbox and drag diagonally
across the entire canvas. Then drag the middle handle on the right side to the right
(beyond the boundary of the artwork), so that you will about double the size of the
artwork. Press the Enter key to accept the change. If necessary, repeat to add more
space.

3 You will now add another layer to the artwork. Select the Custom Shape tool in the
toolbox (the tool is in the Rectangle tool group). In the options bar, select the Grass 2
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shape in the Custom Shape pop-up panel.
Click the Shape Layer button. Also in the
options bar, choose some green color in the
Color panel. Click and drag the shape tool
in the area to the right of the flowers. This
creates a shape layer. If you wish, add a
layer effect (for example, Gradient Overlay
and Satin) by clicking the Layer Style button at the bottom of the Layers panel—or add
more layers with other elements.

4 In the Layers panel, select all the layers that you want to be a part of your seed
object (Shift-click or Ctrl-click (Windows) or Command-click (Mac OS) the layer to add
it to the selection). Then choose Layer > Smart Objects > Convert to Smart Object.

5 In the SymmetryShop panel, click the
Double glide symmetry  and then the
Make button. You may also adjust the size
and position of the control path using the
sliders in the Control Path section or with
Photoshop tools, as described in the next
tutorial. See “The Tulips: Editing the
Control Path” on page 80.

Now that your source layers are separately kept inside the smart seed layer, you can
double-click the seed layer thumbnail in the Layers panel (or choose Layer > Smart
Objects > Edit Contents) to open the smart object in a new window and edit your
source layers as you normally do in Photoshop. You can even have SymmetryShop
run automatically (autorun) when you are done with your edits of the seed layer. See
“To autorun in the main document” on page 60.
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Chapter 6
The Tulips: Editing the Control Path

In this tutorial you will create a simple all-
over design and learn to interactively edit
the control using Photoshop tools.

1 Use your own image on a transparent
background or open the file tulips.psd in the
Tutorial folder in your SymmetryShop
folder. Make sure that the tulips layer is
selected in the Layers panel.
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2 In the SymmetryShop panel, choose the
Double glide symmetry  and deselect the
Clip at Control Path check box (if it is
selected). Then click Make.

At this point, you can use the sliders in the
Control Path section of the SymmetryShop
panel to move or scale the control path.
However, it is often more convenient to use
usual Photoshop tools instead. See “To
rebuild a SymmetryShop pattern from the
old seed layer” on page 46. The plug-in will
take your edited path as a prototype control
path (see “Prototype control path” on page
26) and restore its rectangular shape if you
incidentally distort it during your edits.

3 Click the Select/Deselect Control Path
button  in the SymmetryShop panel to
select the control path (or click Work Path in
the Paths panel). Then select the Direct
Selection tool in the toolbox and drag the
upper side of the control path down to
decrease the height of the rectangle.

When ready, click Update in the
SymmetryShop panel to rebuild the pattern.
Notice that the vertical repeat size has
become smaller as the neighboring units
now overlap.
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4 Make a few more adjustments to the
control path: move it as a whole to the left
(this will shift every other row of tulips to
the left and make the tulip distribution more
uniform) and decrease the height of the
control path some more (this will make your
pattern even more compact).

It is very convenient to use the Transform Path commands to edit the control path.
With the control path selected, choose Edit > Free Transform Path or press Ctrl-T
(Windows) or Command-T (Mac OS). Then edit the control path by moving free-
transform anchors or using the text boxes or sliders in the options bar. When ready,
press Enter (Windows) or Return (Mac OS) or click the Commit button.
SymmetryShop will run automatically to update your pattern.

To move the path as a whole, you can also use the Path Selection tool. Then click
Update to rebuild the pattern.

When you are satisfied with your pattern, set the tiling size to 3 × 3. This creates a
slightly bigger pattern fragment, a piece of which is shown here. You can also click
the Preview Pattern button  to build the preview in the SymmetryShop Layer (or
hold down the Ctrl key (Windows) or the Command key (Mac OS) and click the
Preview Pattern button  to preview in a separate layer).
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Chapter 7
The Spools: Creating Complex Repeats

This tutorial starts from creating a simple geometric design and then demonstrates
the use of the SymmetryShop Tile, one of the components produced by
SymmetryShop. See “Components of a SymmetryShop pattern” on page 17. Even
though the use of SymmetryShop in this tutorial is simple, the steps you will take to
create a complex repeat require some deeper understanding of symmetry, so this is
an advanced tutorial. In the end, you will re-create a pattern on page 19.

1 The spools pattern is created from a
simple circle. Open a new artwork and
choose the elliptical marquee tool in the
toolbox. Hold down the Shift key and drag
the pointer diagonally somewhere in the
lower-left corner of the artwork to select a
circle. Then choose Edit > Stroke. In the
resulting dialog, set Width to 1 pixel, choose
the black color for the stroke, and click OK.
Deselect the circle when done (choose Select
> Deselect).

For this pattern, you can simply paint the
circle in the background layer. However,
creating a new seed layer (as in step 1 in a
previous tutorial, “The Random Weave: Blending Units of Repetition” on page 74)
gives you a slight advantage because SymmetryShop will locate your circle and
create the control path in its vicinity.

2 In the SymmetryShop panel, click the symmetry type Quarter-turns & rotated
mirrors , select the Clip at Control Path check box, and set 0% overlap and 0 pixels
for the feather radius. Then click Make.
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3 Click the Target Seed/Pattern Layer
button  and the Select/Deselect Control
Path button . Then press Ctrl-T (Windows)
or Command-T (Mac OS) to place free-
transform handles around the control path.
Adjust the horizontal and vertical positions
of the control path so that the left edge of
the control path is aligned with the left edge
of the circle, and the bottom of the control
path is located somewhat below the center
of the circle. Also, make the width of the
control path about as big as shown in the
picture on the right (the diagonal of the
control path will go through the center of
the circle). Type Enter to accept the changes
and automatically rebuild the pattern.

4 Depending on how you position the
control path relative to the circle, the net
created by the circle pieces may have gaps,
which are undesirable (they may not let you
color the “spools” in the next step). You can
eliminate the gaps by fine-tuning the
position of the control path and its width
and by increasing the overlap value. In the
end, your pattern should resemble the one
on the right. Click the Select/Deselect
Control Path button  again to deselect the
control path. You can find the pattern
created at this stage in the file spools.psd in
the Tutorial folder in your SymmetryShop
folder.
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5 After building a pattern, the plug-in
adds an alpha channel called the
SymmetryShop Tile, which contains the
precise rectangle that you can use to define a
pattern preset (see “The SymmetryShop
Tile” on page 19). You will now transform
that channel to define a more complex
pattern. Ctrl-click (Windows) or Command-
click (Mac OS) the Show/Hide
SymmetryShop Tile button  (or open the
Channels panel and Ctrl-click (Windows) or
Command-click (Mac OS) the
SymmetryShop Tile channel thumbnail) to
load the channel as the selection.

6 Choose Select > Transform Selection. In
the options bar, click the Link icon to
maintain the aspect ratio, and enter 200% in
the W (horizontal scale) text box. Then click
somewhere in the free-transform area and
drag the selection rectangle diagonally so
that the free-transform anchors fall inside
the spool areas (leaving the anchors in the
small squares between spools is less
convenient). Press the Enter key to accept
the transformation.
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7 Now you will colorize spools inside the
selected area, starting from the ones that are
intersected by the selection boundaries. As
the selected rectangle seamlessly tiles the
plane, a spool that is intersected at the
bottom will continue on the top. You will
paint these matching parts using the same
color.

Choose some light green color using
Photoshop’s Color panel. Then select the
Paint Bucket tool in the toolbox and make
sure that the Contiguous check box in the
options bar is selected. Click somewhere in
the left spool that is intersected by the lower
boundary of the selection to assign the color to that area. Finally, click the area directly
above that is intersected by the upper boundary. This will assign the same color to the
two matching areas.

8 Repeat step 6 one more time with a
darker green color. This time there will be a
smaller part of the spool at the bottom and a
bigger part at the top of the selected area.

Then continue to color the matching parts at
the left and right boundaries using two
more colors.
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9 Notice that the spool adjacent to the
upper-left corner is cut into three parts by
the selection boundaries. Therefore, there
will be three matching parts for this spool in
the selected region. Use a purple color for
these parts.

10 The spool in the upper-left corner is cut
into four parts. You can see these parts
clearly if you draw continuations of the
selection lines. The matching parts for this
spool are in all four corners of the selected
area. Use a light yellow color for these
corner parts.

1 2
34
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11 You have only two easy (contiguous)
spools left. Use a darker yellow color and a
light blue color for them. Finally, apply the
burgundy color to the remaining six small
squares between spoons.

Your new tile is ready. Choose Edit > Define
Pattern, enter a name for your pattern in the
resulting dialog, and click OK. You can now
use the new pattern as a fill with many
Photoshop tools, for example, the Paint
Bucket tool. As expected, the repeat size of
the pattern is twice as big as the repeat size
of the original (spools of the same color
appear in every other row and column).
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Index

A
actions

defining for SymmetryShop, 56
running SymmetryShop automatically, 56, 57

all-over designs, 48, 69, 80
Amount, Skew Amount text box, 24
Anti-aliased check box, 34
Artlandia Collection, 3
Artlandia software, 4
Artlandia web site, 2
automating SymmetryShop, 56
autorun, 44, 57

and smart objects, 48
enabling, 50
in main document, 60
in smart object, 58

B
blended units, 34
block repeats, 33, 35
bounding box

and control path, 23
and exporting patterns, 42
for pattern presets, 28, 40

Brick layout, 64
brick repeats, 64

and constrain shift settings, 29
and stripes, 62
creating manually, 29
creating with layouts, 29
creating with skew controls, 25, 28
SymmetryShop Tile of, 31

C
canvas extension

automatic, 16
avoiding, 47

canvas size
and preparing seed images, 16
and rebuilding patterns, 47

Clip at Control Path check box, 33, 81
clip options, 34
Clipping section, 10, 33, 34
components, of SymmetryShop patterns, 17,

51
composite repeats, 48, 71
Constrain Shift pop-up menu, 25, 28, 29, 62,

64
control path, 8, 23

and bounding box, 23
and changing image size, 47
and control points, 25
and interlocking patterns, 31, 32
and repeat directions, 28
and repeat size, 23, 76
and self-contained units of repetition, 33
and work path, 20
area of, 69
clipping, 33, 34, 38
editing, 24, 25, 26, 28, 57, 80
editing with SymmetryShop panel, 9
in brick repeats, 29, 64
in Diamond layout, 63
in drop repeats, 29, 64
in Gradation and scale layout, 67
in gradation layouts, 65, 66
in grid layouts, 68
in Stripe layout, 63
prototype of, 26



90 Index

rectangular, 66
shape of, 23

control path editing
new in SymmetryShop 3, 5

Control Path Position text boxes, 24
Control Path Rotation text box, 25
Control Path Scale text boxes, 24
Control Path section, 10, 28, 55, 76, 79, 81
Control Path Skew items, 24
control points, 25, 28

order in control path, 27
cropping

and rebuilding patterns, 48
SymmetryShop Tile, 42

D
Delete Replicas button, 9, 22
demo version, 1
Diamond layout, 14, 62, 63
Distance to Work Area, 51
Don’t Show Again check box, resetting, 51
Double glide symmetry, 13, 15, 21, 23, 32,

38, 40, 65, 66, 79, 81
Double mirror symmetry, 13, 35
drop repeats, 64

and stripes, 62
creating manually, 29
creating with layouts, 29
creating with skew controls, 28
SymmetryShop Tile of, 31

E
Enable Autorun check box, 50
Export button, 9, 10, 19, 21, 31, 40, 41
exporting SymmetryShop patterns, 42

F
FAQ about SymmetryShop, 2
feather

blending overlapping units, 34
in selection, 35

radius, 35, 53
Feather text box, 34, 75
fill layers

using in patterns, 38
full version, unlocking, 1
full-drop repeat, 29
fused units, 34

G
Glide reflection symmetry, 34, 62, 63, 65
Gradation and scale layout, 14, 67
gradation layouts, 65, 66
grid layouts, 68
grid repeats, 68

H
H, Height text box, 24
Half-drop layout, 14, 64
half-drop repeat, 29, 30, 31

and constrain shift settings, 29
Half-turn symmetry, 29, 62, 65, 66
Height text box, 24
Help button, 2
Horizontal gradation layout, 66
Horizontal Position text box, 24

I
image size. See also reducing image size

and rebuilding patterns, 47
Image Size text box, 9, 37, 46
images of the seed, 12
installation, 1
Insufficient canvas size warning icon, 16
interlocking patterns, 31

K
Kaleidoscope symmetry, 13, 27, 43
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L
large images

new in SymmetryShop 3, 5
layer masks

and autorun, 59
and default control path, 24
using in patterns, 8, 15, 19, 38, 46, 54

Layout list, 21
and repeat systems, 14, 62
and symmetry settings, 10, 22

Layout section, 9, 21, 22
layouts

built-in, 62
implementing your own, 69

Link button, 24, 76, 85
locking seed layer, 39
Long, symmetry icon tips, 51

M
Make button, 11, 21, 37, 75, 79
Mirror & glide symmetry, 13, 29
Mirror symmetry, 65
motif. See seed

N
Normal layout, 22

and replicas, 22

O
optical illusions, 65
optical patterns, 65
Overlap text box, 34, 83

P
painting order, 31
Parallel mirrors & glide symmetry, 13
pattern design resources, 2

pattern presets
creating from SymmetryShop patterns, 17, 19,

28, 40, 41, 42, 56, 85
exporting from SymmetryShop, 10
rectangular selection for, 8

Pattern Sampler, 2
Perpendicular mirrors & glide symmetry, 27,

29
Photoshop patterns

and SymmetryShop patterns, 40
creating from SymmetryShop patterns, 17

Pinwheel symmetry, 34, 44, 56, 72
preferences. See SymmetryShop Options
preset layouts, 12, 21
preset styles

in SymmetryShop patterns, 42
Preview Pattern button, 9, 10, 28, 41, 82

new in SymmetryShop 3, 6
previewing

components, in different windows, 44
exported tile, 40

prototype control path, 24, 26, 27, 46, 55

Q
quarter-drop repeat, 29, 30, 31
Quarter-turns & mirrors symmetry, 13
Quarter-turns & rotated mirrors symmetry,

11, 19, 33, 83
Quick Reference card, 2
Quick Start dialog, 2

R
rebuilding SymmetryShop patterns, 17, 26,

46, 52
and SymmetryShop Selection, 18, 47
at reduced size, 47
by running an action, 56
settings for, 45
with selection, 50

rectangular tile, 42
reduced image size

new in SymmetryShop 3, 5
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reducing image size, 37
Refine Automatic Selections check box, 51
Refresh Panel button, 9, 10, 11, 45
repeat size, 23
repeat systems

implementing your own, 69
replicas, 22, 29, 67

and paint order, 31
in Gradation and scale layout, 67
in gradation layouts, 65, 66
in grid layouts, 68
in spot layouts, 67

Reset All Warning Dialogs button, 51
Rotation Angle text box, 25, 28
royalty-free designs, in Artlandia Collection,

3

S
sateen repeats, 67
sateens, 67
seed, 11

applying filters to, 52
clipping, 33
editing, 17
in block repeats, 35
motif, 11
position of, 16
selecting, 14

seed layer, 17, 45, 46, 74, 83
editing, 52
targeting, 8

Seed Layer Has Priority Over Pattern Layer
check box, 36, 46, 50

Select/Deselect Control Path button, 9, 10,
20, 23, 55, 71, 75, 81, 84
new in SymmetryShop 3, 5

selection
in seed layer, 14

Selection
in preferences, 51

shape layers
using in patterns, 38
using in smart objects, 78

Shorthand, symmetry icon tips, 51

Show/Hide SymmetryShop Tile button, 9,
10, 20, 31, 40, 41, 85

Simple shift symmetry, 13, 29, 30, 36, 37,
39, 43, 52, 62, 63, 64, 65, 66, 67, 68, 70,
71, 72

Six rotations symmetry, 32, 33
Skew Amount text box, 24, 28, 29, 30
Skew Direction pop-up menu, 24, 28, 29, 30
smart objects

adding canvas space in, 16
and all-over repeats, 69
and autorun, 50, 57
and composite repeats, 71
and multiple layers, 45, 48, 78
and tossed repeats, 69
and using SymmetryWorks patterns, 40
creating patterns in, 49
editing, 44
implementing repeat systems with, 69
support for, 38
using as seed, 49
using with SymmetryShop, 48

Snap to Rectangular Grid check box, 25, 28,
29

spot layouts, 14, 67
spot repeats, 67, 68
Stray Pixel Cleanup controls, 51
Stripe layout, 62, 63
supported objects, 38
symmetry controls, 9
Symmetry Icon Tips

in preferences, 51
SymmetryShop channels, 18
SymmetryShop Layer, 8, 17, 47, 50, 59

as a new seed layer, 47, 49
SymmetryShop Options, 11, 50
SymmetryShop panel, 8

new in SymmetryShop 3, 5
SymmetryShop patterns, 12

and Photoshop patterns, 40
components of, 17
making, 11, 45

SymmetryShop Selection, 8, 17, 18, 47, 53
automatically applied, 53
editing, 54
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SymmetryShop Tile, 8, 17, 18, 19, 28, 41, 56
and pattern preset, 41
arbitrary changes within, 42
cropping, 42
exporting, 42
moving in the artwork, 42
using for complex repeats, 83

SymmetryWorks patterns
using with SymmetryShop, 40, 48

SymmetryWorks plug-in, 3
system requirements, 1

T
Target Seed/Pattern Layer button, 6, 9, 10,

17, 18, 46, 52, 53, 54, 76, 84
new in SymmetryShop 3, 5

textile CAD programs, export to, 42
Three mirrors symmetry, 13
Three rotations & mirrors symmetry, 13
Three rotations symmetry, 21
tile, 12
tile size

for drop and brick repeats, 31
Tiling controls, 10, 20
Tiling size controls, 9
Toggle Image Size button, 9, 37, 46
tool tips, 11, 51
tossed repeats, 48, 69
Transform Path command

and editing control path, 5, 20, 24, 55, 82
tutorials, 73
type layers

using in patterns, 38

U
units of repeat, 12

unlocking full version, 1
Update button, 11, 18, 20, 46, 47, 48, 53,

54, 55, 71, 77, 81, 82
usage hints, 11

V
vector masks

and autorun, 59
and default control path, 24
using in patterns, 8, 15, 19, 38, 46, 54, 75

Vertical and horizontal gradation layout, 66
Vertical gradation layout, 37, 43, 52, 65, 67
Vertical Position text box, 24

W
W, Width text box, 24, 76, 84
web page backgrounds, 42
web resources, 2
Width text box, 24
work path

and control path, 8, 17, 20, 23
and prototype control path, 24, 26, 46
editing, 54, 55
renaming to preserve, 24

X
X, Horizontal Position text box, 24, 76

Y
Y, Vertical Position text box, 24, 76
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