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Getting Started

Artlandia® SymmetryShop® is all you need to create professional-quality pattern
designs in Adobe® Photoshop®.

Installation

SymmetryShop requires Adobe Photoshop 7.0 or later. To install the plug-in, quit the
Photoshop program if it is running. Then locate the folder or the file named
Artlandia SymmetryShop (depending on your system) and drag it to the Adobe
Photoshop Only folder located in the Plug-ins folder inside your Adobe Photoshop
folder. The plug-in will be available the next time you start Photoshop. The file
Installation.txt that came with your plug-in contains more specific instructions for
your computer system.

Demo version

The newly installed plug-in works in the demo mode, which may not have all the
features of the full version. The limitations are described in a separate document (see
the file Demo.txt in your SymmetryShop folder).

Unlocking the full version

To unlock the full version, you need the serial number, which has been provided
with your purchase. If you are using a demo version and wish to purchase the full
version, please contact Artlandia.

1
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Getting Started

To enter the serial number:
1 Open an existing Photoshop file or create a new file.

2 If the color mode of the document is not RGB Color or CMYK Color, choose
either one of these modes in the Image > Mode menu.

3 Launch SymmetryShop by choosing File > Automate > Artlandia
SymmetryShop....

4 Click the Register button.

5 Fill in the serial number, and click OK.

About this guide

This guide assumes that you have a basic knowledge of Photoshop, including how to
operate Photoshop menus, choose tools, select the desired part of your artwork, and
use the Layers, Channels, Paths, and Actions palettes. For help with any of these
techniques, please refer to your Photoshop documentation.

An electronic version of this guide is available as a PDF file located in the
SymmetryShop folder.

Supplementary materials

* The Quick Start dialog walks you through SymmetryShop basics. To access the
dialog, click the Help button P/ in the SymmetryShop palette.

* The plug-in comes with the Quick Reference card, available as a PDF document,
and the Sampler files, available as Photoshop files.

® Also available with the plug-in are Photoshop files that accompany the tutorial
part of this guide. The files can be found in the Tutorial folder in the SymmetryShop
folder.
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Web resources

Additional pattern design resources, answers to frequently asked questions, and the
latest information about Artlandia products are always available on the Artlandia
web site at www.artlandia.com. To access the web site from Photoshop, click the icon
at the top of the SymmetryShop palette (you must have an Internet connection and a
web browser installed).

Artlandia Symmethhap

Among the available resources is Artlandia Wonderland, a collection of tips,
interactive tutorials, and books on symmetry, pattern design, and their applications,
located at www.artlandia.com/wonderland. Many pattern design terms are defined
and illustrated in the Artlandia Glossary of Pattern Design at
www.artlandia.com/wonderland/glossary.

Tl di
\"."/ A\ PATTERN
*DESIGN

Customer support

You may be entitled to technical support. For more information, refer to the
Artlandia web site and/or the technical support card that came with this guide.
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Other products from Artlandia

Also available from Artlandia is Artlandia® SymmetryWorks®, a powerful,
interactive pattern editor for Adobe Illustrator. You may find this complementary
plug-in useful for creating repeat patterns from vector art objects and for combining
vector and raster elements in your pattern designs. SymmetryShop and
SymmetryWorks are similar in many respects, yet they work quite differently and
have their own uses. For a detailed comparison, visit

www.artlandia.com/SymmetryWorks

Supplementing SymmetryWorks is the Artlandia Collection, a library of unique,
royalty-free pattern designs that let you interactively explore the ready-made
patterns and quickly produce a wealth of similar—or dissimilar—designs. Visit

www.artlandia.com/collection

for a list of currently available volumes and sample art.

For designers familiar with computer programming, Artlandia also offers its
namesake software, Artlandia. If you wish to create your artworks by a set of
commands in a computer language, you may want to explore that program.

More information about Artlandia products is available on the Artlandia web site,
www.artlandia.com
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What’s New in SymmetryShop 2

SymmetryShop 2 further automates and simplifies the creation of pattern designs in
Photoshop by letting you use smart objects as well as fill, shape, and text layers as a
source of your patterns. SymmetryShop 2 supports both layer and vector masks and
makes it easier to select a part of the artwork as a motif. In Photoshop CS3, the plug-
in introduces the new autorun feature that streamlines the editing and adjustment of
your patterns. SymmetryShop 2 also eliminates preparatory steps that were
necessary for successful plug-in operation in the past and contains other productivity
enhancements.

Support for smart objects Smart objects are supported in all Photoshop versions
where they are available (starting from Photoshop CS2). Create patterns from smart
objects based on vector or raster layers, apply nondestructive transformations or
filters, even create a SymmetryWorks pattern in Illustrator and use it as a motif for
your SymmetryShop patterns. See “Supported objects” on page 38 and “Using smart
objects” on page 47. The use of SymmetryWorks patterns requires the Artlandia
SymmetryWorks plug-in for Illustrator, see “Other products from Artlandia” on

page 4.

Multiple source layers In particular, smart objects allow you to create a pattern
from multiple layers. Keep important parts of your pattern separate. Edit them,
apply transformations, or rearrange them within the seed and quickly rebuild the
pattern. See “The Wild Flowers: Using Multiple Source Layers” on page 78.

All-over and tossed designs Use smart objects to easily create a pattern from
design elements that are arbitrary scattered over the repeat area. Keep similar
elements linked to each other. Edit one element and instantly apply the changes to all
linked copies. Then rebuild the pattern with a click. See “All-over repeats and tossed
repeats” on page 68.

Composite repeats Nest SymmetryShop patterns in smart objects and create
sophisticated designs from seed objects that are themselves patterns of a different
symmetry type. See “Composite repeats” on page 71.
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Fill and shape layers Use a part of a layer filled with a solid color, a gradient, or a
pattern—or a vector shape—as a motif. SymmetryShop 2 keeps your motif in its
original form. See “Supported objects” on page 38.

Editable text Create a pattern from a text and edit the text at any time, change the
font or formatting, warp it, or apply any other Photoshop editing technique. Then
rebuild with a click. See “Supported objects” on page 38.

Layer and vector masks SymmetryShop has always allowed you to select a part of
a layer for use in pattern. With SymmetryShop 2, you can also use Photoshop's layer
and vector masks to isolate your motif. Conveniently edit your masks to adjust your
motif selection—or select a different part of your seed layer and rebuild it. See
“Layer and vector masks” on page 16.

Autorun When interactively working on your pattern, you often want to edit the
seed layer, the selection, the layer and vector masks, or the control path. Keep editing
pattern components in one window and run SymmetryShop automatically (autorun)
to see the pattern updated in another window. Autorun is based on the smart object
feature and is available in Photoshop CS3. See “Autorun” on page 56.

Automatic canvas extension In the past, you had to select a relatively small part of
your artwork before launching SymmetryShop —or alternatively increase the canvas
size so that the plug-in would have enough space to build your pattern. This is no
longer necessary. SymmetryShop 2 automatically increases the canvas size as
needed. See “Automatic canvas extension” on page 17.

Other productivity enhancements It is no longer necessary to select all non-
transparent pixels in the layer before launching the plug-in—SymmetryShop 2 will
do that automatically. Paint your seed objects on a transparent background and
launch the plug-in. There is no need to re-select after each edit. See “Using selection”
on page 15.

SymmetryShop 2 also allows you to lock the image or transparent pixels and/or
position of your seed before launching the plug-in, which also makes editing easier.
See “Locking the seed layer” on page 38.
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The plug-in now has zoom buttons to further increase your productivity. Choose a
comfortable magnification without returning to Photoshop. See “The SymmetryShop
palette” on page 10.

What’s changed If you launched the previous versions of SymmetryShop without
selecting anything in the artwork, the plug-in selected a small part of your seed
image and did not allow you to uncheck the Clip at Control Path option.
SymmetryShop 2 instead assumes that your entire seed image is your desired
source—as if you have selected all non-transparent and unmasked parts of the seed
layer. Build the pattern from your entire image and switch the Clip at Control Path
option normally. See “Using selection” on page 15 and “The Tulips: Automating
SymmetryShop” on page 80.
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This part gives you an overview of key features of the Artlandia
SymmetryShop plug-in and introduces basic techniques you will
find useful in your work.
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Chapter 1
An Overview of Artlandia SymmetryShop

Artlandia SymmetryShop automates pattern design in Photoshop. The plug-in
creates a pattern in a new layer, called the SymmetryShop Layer. Your original
(“seed”) layer is left intact and can be accessed through the Layers palette after you
exit SymmetryShop. You can use raster (image) or vector (shape) layers, as well as
smart objects, as the seed layer. If you select a part of the original layer as a source
(motif) of the pattern before launching SymmetryShop, the plug-in will save your
selection in an alpha channel called the SymmetryShop Selection. The channel can be
found later in the Channels palette. You can also use layer and vector masks to limit
your motif to a part of the seed layer. The plug-in adds one more channel to your
artwork. It is called the SymmetryShop Tile and contains the exact rectangle that you
can use to create a Photoshop pattern preset. Finally, the plug-in adds a work path
(or modifies the existing work path) to include the control path that defines the repeat
size and orientation of your pattern.

Taken together, these features allow you to continue working on your pattern design
for a long time after it has been created, throughout many invocations of the plug-in
in multiple Photoshop sessions. The basics of SymmetryShop are introduced in this
chapter.

The SymmetryShop palette

As all other Photoshop plug-ins that automate your work, SymmetryShop is
accessible through the File > Automate menu. For the plug-in to be available, you
must open a file with the image mode set to either RGB Color or CMYK Color.

Note: SymmetryShop is not a filter and therefore cannot be found under the Filter menu.

To launch SymmetryShop, choose File > Automate > Artlandia SymmetryShop....
You can move the palette on your screen just as you do with other Photoshop
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palettes. To exit SymmetryShop and return to Photoshop click either the OK or
Cancel button in the SymmetryShop palette.

Artlandia SymmetryShop

- B Vo e o
B = "_ Cancel )
- 0 —
A - | R e B RS o
i
[ i 5.~ . *
| _ E gﬂ Ll | 78T @ ™ preview
Layout:
B Normal i |
m oo m " Undo A f Preferences Yy
Diamond . o _
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E Half-drop — Control Fath
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L | B8 vertical gradation v ¥ | ]_ G
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L @Selection : Tile : Mone EE ContraliHIT 172 Fe—— |_

‘ Maowe the control path horizontally or vertically. M

The SymmetryShop palette (on your computer the palette may be slightly different).

A. Symmetry controls B. Layouts C. Delete replicas button D. Clip controls E. Tiling size controls

FE. Show/hide the control path and the original and tile selections G. Set the horizontal and vertical
positions of the control path H. Set the width and height of the control path I. Click to change the width
and height simultaneously J. Set the control path skew K. Rotate the control path L. Menu to choose
half-drop, quarter-drop, etc., shift M. Usage hints

The SymmetryShop palette lets you make a pattern and set or adjust its basic
properties. There are seventeen types of planar symmetry available through the
symmetry controls. Additionally, by selecting a layout from the Layout list, you can
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quickly create predefined variations within some symmetry types. For an example of
a pattern of each symmetry type and layout, see files in the Sampler folder inside
your SymmetryShop folder.

The SymmetryShop palette also allows you to instantly switch between overlapping
and self-confined units of repetition by selecting the Clip at Control Path check box.
The boxes and pop-up sliders in the Control Path area let you adjust the repeat size
and orientation of the pattern. The Tiling controls change the number of rows and
columns that the plug-in displays for your pattern.

You can undo most of the changes by clicking the Undo button or typing Ctrl-Z
(Windows) or Command-Z (Mac OS). If you hold down the Alt key (Windows) or
the Option key (Mac OS), the Cancel button becomes the Reset button. Clicking the
Reset button allows you to restore the pattern in the state it was in when
SymmetryShop was launched.

By selecting the Preview check box, you can apply all changes interactively as you
make them. You can export intermediate stages of you work as pattern presets using
the Export button and preview the exported area by clicking the Show: Tile button.
Deselecting the Control Path check box and selecting the None button lets you see
the pattern fragment without any auxiliary elements.

If the space around the seed appears insufficient for constructing the pattern, the
plug-in may automatically add some canvas space. This changes the magnification of
your artwork. You can increase or decrease the magnification by clicking the Zoom
In @ or Zoom Out @ button, or fit the document on screen by clicking the Fit All
button . These buttons are located in the Zoom area and have the keyboard
shortcuts Ctrl-+, Ctrl--, and Ctrl-0 (Windows), and Command-+, Command--, and
Command-0 (Mac OS).

Finally, you can change your SymmetryShop preferences in the Preferences dialog,
which you can open by clicking the Preferences button.

Tool tips and usage hints To provide a quick help, usage hints for the main
SymmetryShop controls appear at the bottom of the palette when you move the
mouse pointer over the controls. The controls also have tool tips to provide some
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further assistance. Tool tips for symmetry controls give you an idea of what

operations the plug-in performs to build the pattern. In the Preferences dialog, you

can toggle between the long and shorthand (mathematical) versions of tool tips.

Key features at a glance

Making a SymmetryShop pattern To make your first pattern, open an existing
RGB or CMYK image file, or create a new file and paint something in it, and choose
File > Automate > SymmetryShop.... This brings up the SymmetryShop palette and

builds a pattern (provided the Preview check
box is selected). The created pattern will
remain in the artwork after you close the
SymmetryShop palette by clicking the OK
button.

About patterns Notice that a part of the
original image was used as a “seed” (motif)
of the pattern. The plug-in replicates the seed
and transforms it as necessary to produce a
pattern according to symmetry laws.

A pattern typically consists of a number of
“tiles.” Each tile consists of one or more
smaller units of repetition. Each smaller unit
is identical to the seed and called an “image”
of the seed. How the images are stacked
together depends on the chosen symmetry
type. Changing the symmetry in the
SymmetryShop palette lets you quickly
generate a variety of visual effects from the
same seed. Preset layouts give you even
greater flexibility by allowing you to create
different-looking variations within the same
symmetry type.

Creating a SymmetryShop pattern (right) from an
image (left). Symmetry setting: Quarter-turns &

rotated mirrors ﬁ; tiling 2 x2.

A SymmetryShop pattern.
A. Seed B. Tile
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Sample patterns produced from the same seed using different symmetry settings.

A. The seed B. Simple Shlft m C. Double mirror * D. Mirror & glide ﬂ E. Parallel mirrors &
glide »& F. Double glide Il G. Three rotations & mirrors ! H. Quarter-turns & mirrors ﬁ

I Kaleidoscope * J. Three mirrors %5
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A butterfly in different layouts chosen from the Layout list.
A. Half-drop B. Diamond C. 5 spot D. Gradation and scale

Using selection As with many other Photoshop plug-ins, you can select a part of
your artwork before launching SymmetryShop. The plug-in will then use only the
selected part of the seed layer to build a pattern. If you do not select anything, the
plug-in will build a pattern from your entire image. This is especially useful when
you have removed all extraneous areas of the image, such as the background.

SymmetryShop can also automatically select a geometric region appropriate for your

15
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symmetry type. The automatic selection is based on the control path. See “The
control path” on page 24 and “Clip at Control Path” on page 34. The automatic
selection often brings about patterns that appear “mechanical” or kaleidoscopic. In
contrast, by using your own selection—or removing irrelevant parts of the image—
you can typically create a more organic look.

Patterns produced from the same seed with selection (left) and without selection (right). Symmetry

2aE
setting: Double glide I!I; tiling 2 x2 (fragment).

Layer and vector masks You can also = ok

apply layer and vector masks to isolate ((Normal B oraci: (1004 |8

(mask) parts of your seed layer that you tock: [F] (@] il (100 [&)
. 1 :

do not want to use in a pattern. = Elﬂ- Layer 1

SymmetryShop will then build a pattern

from the remaining (unmasked) areas.

For more about creating masks, see [s=lADfelafa]# -
“Masking layers” in Photoshop’s User A seed with a layer mask applied.
Guide.
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Position of the seed One important
distinction between SymmetryShop and
Photoshop filters is that filters modify the
selected part of the artwork in place while
SymmetryShop copies the selected part to a ——— e — -
new layer where it then creates a pattern by
rotating, reflecting, and/or otherwise ‘z
transforming the selection according to
symmetry laws. Therefore, SymmetryShop
generally needs more space around the
selection. If you select a relatively small part
of your artwork in the lower-left quadrant,
not too close to either the bottom or the left boundary, then the plug-in will typically
have enough room to build a pattern without gaps and other defects.

Typical position of a selection in the lower-left
quadrant of the artwork.

Automatic canvas extension If SymmetryShop determines that the available
canvas space is insufficient, it will try to automatically extend the canvas by adding
space around your seed image (the selection). It is possible that the added space will
still be insufficient. In that case, the plug-in alerts you with a beep and displays the
control path warning icon &. To further increase the canvas size, click the icon and
follow the instructions.

Note: SymmetryShop adds the same amount of canvas space to the left and right of your
image (or at the top and bottom of the image) so that if the change takes place inside a smart
object, the object will retain its relative position in the enclosing document.

Q If you do not wish to rely on the automatic canvas extension, increase the work area of your
document by choosing Image > Canvas Size..., before launching SymmetryShop.

Q If you do not want to see the added extra space, move your SymmetryShop pattern inside a
smart object. You will then be able to crop the smart object to any size you want and still be
able to rebuild the pattern. See “To create a SymmetryShop pattern in a smart object” on
page 48.

Components of a SymmetryShop pattern SymmetryShop reorganizes your
artwork to make it easy for you to rebuild the pattern after editing the seed or
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resume your work in another Photoshop session, after the pattern file was closed and
then re-opened.

As mentioned in the beginning of this chapter, the plug-in creates a pattern in a new
layer, called the SymmetryShop Layer. The new layer appears on top of your original
seed layer, which becomes invisible, but otherwise remains intact. The plug-in also
adds a work path that contains the control path that determines the repeat size and
orientation of your pattern. If you have selected a part of your artwork before
launching SymmetryShop, the plug-in also adds an alpha channel that remembers
your selection. That channel is called the SymmetryShop Selection. Finally, the plug-in
typically adds another channel, called the SymmetryShop Tile, which contains the
exact rectangle that you can use to define a usual Photoshop pattern (a preset
pattern). During its operation, the plug-in may modify any of these components (that
is, the SymmetryShop Layer, the SymmetryShop Selection, the SymmetryShop Tile,
and the work path) so, when you launch the plug-in, you should not presume that
these components will remain unchanged.

If you wish to preserve some pattern components, duplicate and rename them before
launching SymmetryShop.

While working with the plug-in, you can show or hide the pattern components using
the Show controls in the SymmetryShop palette. Also, by selecting the Preview check
box, you can show the pattern layer, and by deselecting the check box you can hide it
and show the original seed layer instead.

The SymmetryShop Layer The plug-in

Layers

builds the pattern layer (the SymmetryShop (Normsi ) opseiy:[100% é
Layer) on top of your original seed layer. Lock: [E[ [ [@| ri:[100% |8

This gives you the opportunity to come back E symmetrshop aver 3
and edit the original seed at any time after :EI.LM”

the pattern is built. To edit the seed, click the = —TA
seed layer in the Layers palette and make the [=le/Oe[a]s#]/

seed layer visible. In most cases, you will also Layers of a SymmetryShop pattern.
want to toggle the VlSlblhty of the A. The seed layer (invisible) B. The
SymmetryShop Layer (make it invisible). SymmetryShop Layer

After edits, simply launch SymmetryShop
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again and the plug-in will rebuild the pattern to incorporate your edits in the seed.
See “To rebuild a SymmetryShop pattern from the old seed layer” on page 45 for
instructions on rebuilding a pattern.

Note: When rebuilding a pattern, SymmetryShop will look for the seed layer by its name. It
is therefore recommended not to rename the seed layer.

Q It is very useful to create an action that launches SymmetryShop. You may also want to
assign a keyboard shortcut to the action, for example, Ctrl-F12 (Windows) or Command-F12
(Mac OS). You will then be able to toggle the SymmetryShop dialog off and instantly run
SymmetryShop by performing the action. This lets you edit the seed and quickly rebuild the
pattern with a single click or a keyboard shortcut. See “Automating the workflow” on page
55.

Q In Photoshop CS3 and later, you can edit the seed layer in one window, run SymmetryShop
automatically, and observe pattern changes in another window. See “Autorun” on page 56.

The SymmetryShop Selection The S ——
SymmetryShop Selection saved with the sos[llcs T a
artwork allows you to re-apply the selection = I:l o ot

to your original seed layer if you wish to edit ——

your seed image after a SymmetryShop e __G'm -
pattern is created. You can also edit the = s -
selection itself. When rebuilding a pattern, = - ——— Y
the plug-in always checks for the presence of : - P——
the SymmetryShop Selection, so you do not L FETO T Ta]
have to apply the selection to the seed layer if SymmetryShop channels.

you simply want to continue working with A. The SymmetryShop Tile B. The
the previous selection. By convention, the SymmetryShop Selection

plug-in applies the SymmetryShop Selection

to your seed layer automatically, as long as you launch the plug-in without selecting
anything in the artwork. Launching SymmetryShop with another selection overrides
the old selection channel. See “To rebuild a SymmetryShop pattern from the old seed
layer” on page 45 for details
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Note: The plug-in does not create the SymmetryShop Selection channel if you call it without
selecting anything in the artwork.

You can use layer and vector masks as alternatives to selecting something in the seed layer.
See “Layer and vector masks” on page 16.

Q You can also use layer and vector masks in combination with the selection.

The SymmetryShop Tile The SymmetryShop Tile alpha channel that the plug-in
saves with the artwork allows you to create a pattern preset from your
SymmetryShop pattern after you exit SymmetryShop (inside SymmetryShop, you
can save a pattern preset simply by clicking the Export button); see “To save a
pattern preset” on page 55. Knowing the exact repeat rectangle is also useful for
creating more complex repeats by joining several repeat rectangles; see “The Spools:
Creating Complex Repeats” on page 83 for step-by-step instructions.

Producing more complex repeats by colorizing a pattern.

A. The original pattern; symmetry setting: Quarter-turns & rotated mirrors % B. Repeat size defined
by the SymmetryShop Tile C. Repeat size increased two times in the horizontal direction D. Repeat
size increased two times in both the horizontal and vertical directions

Note: The plug-in does not save the SymmetryShop Tile if you deselect the Snap to
Rectangular Grid check box or if you select None from the Constrain Shift pop-up menu.
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Paths

Work path SymmetryShop saves the control

path as a work path in your document. The _._ Work ath
control path defines the repeat size and '
orientation of your pattern. See “The control
path” on page 24. In the beginning, you will SEEEEi-Siaid S

edit the control path using the sliders in the Worl path contains the control path.
SymmetryShop palette. However, as you

gain experience, you will often find it more convenient to access the control path through
the Paths palette after you return to Photoshop. This lets you interactively edit the path
using the usual Photoshop tools, such as the Path Selection tool, the Direct Selection tool,
or the free-transform handles that you can activate by choosing Edit > Transform Path.
You will then re-run the plug-in by performing the SymmetryShop action. See
“Automating the workflow” on page 55.

=
=

The symmetry controls and the tiling size controls

The symmetry controls determine how SymmetryShop patterns are organized and the
tiling size controls determine how many “rows” and “columns” of tiles are displayed.
For the default pattern orientation, the first and second tiling controls set the number of
tiles in the vertical and horizontal directions, respectively. Together, the symmetry and
the tiling size controls determine the shape of a pattern fragment produced by the plug-
in. In most cases, the fragment will not be rectangular. However, you can easily export
the rectangular part that seamlessly tiles the plane by clicking the Export button,
provided that you have built a large enough fragment. See “SymmetryShop patterns and
Photoshop patterns” on page 40.

Even if you eventually need a bigger tiling, it is a good idea to work with a tiling of a smaller
size while making edits; then increase the tiling size in the final artwork. The tiling size 2 x 2
or 3 x3 is often a good choice for edits.
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BiEl
Changing the symmetry type from Double glide @18 (left) to Three rotations (right).
Tiling size 2 x3.

Layouts

Preset (built-in) layouts available in the SymmetryShop palette let you create some of
the most commonly used types of patterns with a single click. These include stripe,
brick, drop, diamond, gradation, spot, and grid repeats. See “Layouts and Repeat
Systems” on page 61. The Layouts folder inside your SymmetryShop folder contains
examples of the built-in layouts. To create a pattern with a particular layout, click a
layout of your choice in the Layout list. You can try different layouts in turn or apply
a different symmetry setting to the chosen layout.

Layout list and symmetry setting Notice the small symmetry icons to the left of
the layout names in the Layout list. Each layout is based on one of the seventeen
primary symmetry types. When you choose a layout, the corresponding symmetry
control is selected. The only exception to this rule is the Normal layout, which could
be based on any symmetry.



Artlandia SymmetryShop | 23

AN Eg\

Replicas A basic unit of repetition in many
preset layouts consists of several copies of
the seed objects that are rotated, reflected,
and/or scaled to produce the desired effect.
Additional copies of the seed that are
included in the basic unit are called replicas.
The number of replicas in each layout is
different as are the sizes and orientations of
replicas. By creating a pattern with a preset
layout and applying a different symmetry
type, you can capture the replicas and put
them in a different repeat. This lets you
create an even richer variety of patterns. To

delete replicas, click the Delete Replicas
button [©.,

An example of a 3 x 3 grid layout. The basic unit
of repetition consists of the selection and 8
replicas.
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00000000
00000000

Using the replicas created by the Vertical gradation layout in a pattern with the
QG
symmetry type Double glide @19,

The Normal layout and replicas Changing the symmetry (and in many cases the
size of the control path) switches the layout in the Layout list to the Normal layout. If
the Normal layout inherits replicas from a previous layout, the replica source is
indicated in the text of the Normal entry. The existence of extra replicas is also

highlighted by the Extra Replicas icon "L_l. By itself, switching to the Normal layout
changes neither the symmetry setting nor the number or position of replicas. The
Normal layout can correspond with any symmetry.

The control path

At the outset of building a pattern, SymmetryShop checks for the presence of a work
path in your document. If no work path exists, the plug-in will add one. The path
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object in the work path is called the control path and it serves the same purpose as the
bounding box in Photoshop’s patterns. You can use the control path to interactively
adjust the layout and the repeat size of your pattern. The shape of the control path is
different for different types of symmetry. To see the control path, select the Control
Path check box in the Show section of the SymmetryShop palette.

The rules for creating the control path are as follows:

1 If there is a work path in the document, the plug-in uses it as a starting point. See
“Prototype control path” on page 27.

2 In the absence of a work path, SymmetryShop checks whether there is a
selection. If a selection is present, the plug-in builds the control path based on
the bounding box of the selection.

3 If there is no selection, the plug-in selects (unmasked parts of) the artwork and
uses that region to create the control path.

Q In most cases, you will start by selecting an interesting part of your artwork and launching
SymmetryShop without any work path. The plug-in will create the control path for you and
let you edit it interactively using the sliders in the SymmetryShop palette.

Q If your artwork contains a work path that you do not wish to use as a control path, rename it
before launching the plug-in.

Editing the control path The SymmetryShop palette lets you move the control path
in the horizontal and vertical directions using the X and Y position text boxes *. You
can also change the width and height (if the selected symmetry allows) of the control
path using the W and H scale boxes Fli. For the default pattern orientation, the width
and height of the control path determine the repeat size of your pattern in the
horizontal and vertical directions respectively.

Not all symmetries allow you to change the width and height independently. If the
change is prohibited by the symmetry laws, the Height box is dimmed. If the change
is allowed, you can still change the width and height simultaneously by pressing the

Link button .



26

Chapter 1
An Overview of Artlandia SymmetryShop

Although text boxes in the SymmetryShop palette display values in whole units, you can
enter them with higher precision (for example, 2.25) to make precise alignments.

For some symmetries, you can also distort the control path using the skew controls
<7 : the skew menu, which lets you choose between the skew in the horizontal,
vertical, and arbitrary directions, and the Amount text box. The skew controls are
particularly useful for creating drop and brick repeats. See “To create a brick or drop
repeat manually” on page 30. Not all skew directions and amounts are allowed if
you want to keep your pattern repeating with a certain step in both horizontal and
vertical directions. SymmetryShop will automatically pick the correct amount that is
closest to your choice as long as the Snap to Rectangular Grid check box is selected
and the Constrain Shift is set to any value other than None. See “Snap to Rectangular
Grid” on page 29.

Finally, you can rotate the control path using the rotation angle box £ and thus
build the pattern in directions other than the default horizontal and vertical
directions. Rotation of the control path can make your pattern not repeat in the
horizontal and vertical directions (it would still repeat in some other directions).
When the Snap to Rectangular Grid check box is selected, SymmetryShop will
prevent you from making such choices. See “Snap to Rectangular Grid” on page 29.

Note: Some layouts are defined only on a rectangular grid. SymmetryShop disables the skew
< and rotation £ boxes in such cases. To enable them, choose the Normal layout from the
list.

Q You will often find it convenient to edit the control path outside the plug-in. In such cases,
you can let SymmetryShop create a pattern of the desired symmetry type and then return to
Photoshop, click Work Path in the Paths palette, and edit the control path using the usual
Photoshop tools and techniques. For example, you can select the work path in the Paths
palette and use Edit > Free Transform Path, Edit > Transform Path, or simply move the
anchors with the Direct Selection tool. You can then re-run SymmetryShop to apply your
edits. See “To edit the control path” on page 54 and “Control points” next. Also, see “The
Tulips: Automating SymmetryShop” on page 80 for step-by-step instructions.

Control points You will need to know a little more about the control path if you
wish to edit it outside SymmetryShop. Depending on the symmetry type, the control
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path can have three or four anchors, of which you can freely move two or three. The
rest are uniquely determined by symmetry laws. The free anchors are called the
control anchors or control points. If you move control anchors and rebuild the pattern,
your edits will result in pattern changes. If, however, you attempt to move a
dependent anchor, you will see that the anchor simply restores its position.

ONES

Dragging an anchor of the control path with the direct-selection tool and the result after
rebuilding the pattern.

Prototype control path Once you familiarize yourself with how the control paths
look, you will sometimes find it simpler to give the plug-in a recommendation for
constructing the control path, by creating a prototype. A prototype can be supplied
as a work path in your document. If the prototype is suitable (contains enough
control points), the plug-in will not add an extra path to your artwork, but rather
will modify the prototype in place as necessary to create the control path.

To create a work path, make sure that no paths are highlighted in the Paths palette,
select the Pen tool in the Photoshop toolbox, click the Paths button in the options bar,
and then click several times in the artwork with the Pen tool to create a path. For
more on creating and editing a work path, see Photoshop’s User Guide.
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Important: Do not leave any path that you want to preserve in your document as a work
path. To preserve a work path it is sufficient to rename it. Double-click the path in the Paths

palette to supply a new name.

Creating a pattern with a prototype control path. In the resulting pattern, points of the control path are

close to the points of the prototype. Symmetry setting: Perpendicular mirrors & glide % tiling 2 x2.

When constructing the control path
from a prototype, SymmetryShop takes
the first two control points directly from
the prototype, in the order in which they
appear in the prototype. Then the plug-
in builds the third (and, for some
symmetries, the fourth) point moving in
the counterclockwise direction. The new
points are placed as close to the
consecutive points in the prototype as
symmetry permits. The remaining
points in the prototype, if any, are
discarded.

| |\

= %
2 1
Clicking the same points 1 and 2 in the prototype

control path in a different order brings about
different patterns. Symmetry setting:
[FOA

Kaleidoscope i*i, tiling 1 x1.
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It is not necessary to figure out exactly where all the points in the prototype control path

Q should be to satisfy symmetry laws. To get started, it is usually sufficient to click two or
three times (depending on the symmetry type) in the seed area of the artwork with the Pen
tool. Then you launch SymmetryShop and adjust the control path interactively.

Repeat directions

By skewing and rotating the control path, you can create the brick and drop repeats
and change the pattern orientation. Typically, you will do so using the Skew
Direction pop-up menu, the Skew Amount box, and (less frequently) the Rotation
Angle box in the Control Path area of the SymmetryShop palette. The Horizontal and
Vertical choices in the Skew menu let you create brick repeats and drop repeats,
respectively, and by rotating the control path and using the Arbitrary skew, you can
create intermediate cases.

By default, SymmetryShop makes patterns that repeat both horizontally and
vertically. This is achieved by (a) restricting orientation of certain control points
relative to the artboard, and (b) limiting incremental changes in the position of other
control point(s). You can lessen, or lift these restrictions altogether, using two
separate controls that are available at the bottom of the Control Path area of the
SymmetryShop palette.

Snap to Rectangular Grid When the Snap -
to Rectangular Grid check box is selected, the cﬁ:::ﬂms: ;m"g:':' Gnld_
pattern repeats in either the horizontal or R REEEEEEEEEEEEr et B
. . . . . Controls for restricting pattern orientation in the
vertical direction, for all possible symmetries.
SymmetryShop palette.

If, in addition, you choose any value other
than None from the Constrain Shift pop-up menu, the pattern will repeat in both
directions. To ensure alignment, the plug-in makes the anchors of the control path
snap into appropriate positions. Deselecting the Snap to Rectangular Grid check box
also disables the Constrain Shift pop-up menu and gives you complete freedom in
choosing the pattern orientation. However, it also disables the Export button and the
related Tile selection choice in the Show section of the SymmetryShop palette (see
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“SymmetryShop patterns and Photoshop patterns” on page 40). The plug-in does not
create the SymmetryShop Tile in that case.

Q Even if you deselect the Snap to Rectangular Grid check box, you can still make patterns that
repeat in horizontal and vertical directions and later create a proper bounding box and define
a preset pattern in Photoshop. However, this usually requires a considerable amount of
manual work.

Constrain Shift The default setting of the Constrain Shift pop-up menu, 1/2, allows
you to easily create the brick and half-drop repeats, in which the repeating units in

the next row (column) of the pattern are shifted halfway relative to the previous row
(column). You can also choose 1/3, 1/4, and smaller shifts from the list, down to 1/12.

Q Using smaller shifts, you can make a richer line of repeats. For example, with the 1/6 shift,
you can create a 1/6, 1/3 (2 x1/6), half-drop (3 x1/6), 2/3 (4 x1/6), 5/6, and the full-drop or
straight repeat (0 x1/6 or 6 x1/6).

Q As long as Constrain Shift is set to a numeric value, you do not have to figure out which
skew amount is appropriate for your desired type of repeat. You can simply drag the Skew
Amount pop-up slider and the plug-in will automatically choose the closest allowed amount
as soon as you release the mouse button.

You can make the simple brick and half-drop repeats by selecting the Brick or Half-
drop layouts from the Layout list. However, it is also useful to learn to make these
repeats manually, which enables you to create many variations, for instance, smaller
drop repeats, drop repeats with replicas, and others.

To create a brick or drop repeat manually:

1 Create a SymmetryShop pattern of the desired symmetry type, typically, Simple
shift & For special effects, you may choose the Mirror & glide %, Perpendicular
mirrors & glide %, or Half-turn R symmetries.
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Creating the brick repeat (left) and the half-drop repeat (right) by choosing the Horizontal and Vertical

settings (respectively) from the Skew Direction pop-up menu. Symmetry setting: Simple shifl
tiling 4 x4, constrain shift V2, skew amount 50%.

2 Make sure that the Snap to Rectangular Grid check box is selected and choose
the desired value in the Constrain Shift pop-up menu (1/2 for half-drop, 1/4 for
quarter-drop, and so on).

3 Choose Horizontal from the Skew Direction pop-up menu for the brick repeat or
Vertical for the half-drop repeat.

4 Drag the Skew Amount slider to a value close to 50% (for the brick and half-drop
repeats). As soon as you release the mouse button, the value snaps to exactly 50%.

Tile size The smaller the shift in brick and drop repeats, the more lines of repeat you
need before the pattern rights itself in the vertical (for brick repeats) or horizontal
(for drop repeats) direction. You must keep this in mind if you plan to export your
pattern for use as a pattern preset (see “SymmetryShop patterns and Photoshop
patterns” on page 40). For half-drop, the pattern repeats after two lines, for quarter-
drop, after four lines, and so on. The Tile selection in the Show area of the
SymmetryShop palette lets you see the exact rectangle that is used by the Export
button.
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The SymmetryShop Tile selection for the half-drop repeat, created with the constrain-shift setting 1/2
(left) and the quarter-drop repeat, created with the constrain-shift setting 1/4 (right). Symmetry setting:

Simple shift m, tiling 4 x4.

If the pattern fragment created by SymmetryShop does not completely cover the
SymmetryShop Tile selection, increase the tiling size as necessary to avoid gaps in the
exported pattern.

Interlocking and self-contained units of repetition

By letting the seed objects extend beyond the boundaries of the control path, you can
create interconnected (interlocking) patterns or achieve special effects when the
objects overlap with their own images in the neighboring units. In such cases, you
need to be aware of the order in which SymmetryShop builds patterns.

Painting order SymmetryShop always starts by copying the seed image from the
seed layer to the pattern layer (the SymmetryShop Layer). Then the plug-in creates
replicas, if any. The seed and replicas form a unit of repetition. The plug-in then
duplicates that unit and transforms it as necessary to create the first tile. Then it
duplicates the tile to create the first row. Finally, the plug-in copies the row to finish
the pattern fragment. The tiling size controls in the SymmetryShop palette determine
the number of tiles in a row and number of rows in the pattern fragment.



Artlandia SymmetryShop
User Guide

Creating an interlocking pattern from an object that extends beyond the boundaries of the

control path. Symmetry setting: Six rotations E tiling 2 x2. The tutorial “The Tulips:
Automating SymmetryShop” on page 80 gives another example.

\A’f-\”

L0 n

Special effects produced by overlapping images of the seed (left). Symmetry setting:
Double glide @18, tiling 2 x2.
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Self-contained units of repetition produced by clipping a “brush” seed image (left) at

the boundaries of the control path. Symmetry setting: Six rotations , tiling 2 x2.

Clip at Control Path To clip (the selected
part of) the seed layer at the boundaries of
the control path, check the Clip at Control
Path box in the SymmetryShop palette.
This option allows you to build a pattern
from self-contained units of repetition and
is especially useful for creating block
repeats (see “Block repeats” on page 36).

NS

Selecting the Clip at Control Path check box in the
SymmetryShop palette. Symmetry setting: Quarter-

turns & rotated mirrors ﬁ, tiling 1 x3.



Clip options The options in the Clip at
Control Path area in the SymmetryShop
palette let you choose between separate
and fused units of repetition and further
specify how fused units should be
blended. With the Overlap and Feather
boxes, you choose an appropriate amount
of overlap between neighboring units and
the feather radius to ensure a smooth
transition between units. To have crisp,
separate units, set both the overlap and
feather values to zero (and possibly
deselect the Anti-aliased check box).

Artlandia SymmetryShop
User Guide

NN N

I NXENLN,

Separate (top) and fused (bottom) units of repetition.

The fused units extend beyond the boundaries of the
control path by the amount of overlap. Symmetry

setting: Pinwheel é, tiling 1 x3.

Using the feather effect to blend overlapping uni

ts clipped at the boundaries of the

control path. Symmetry setting: Glide reflection 3‘3’, tiling 1 x2.

35
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Block repeats Block repeats can be instantly created from rectangular images or by
letting the plug-in pick up a rectangular seed element based on the control path. You
can use symmetry types that involve reflection, glide reflection, or 180° rotation, such

as Double mirror *, Double glide E, or Half-turn S — or even Simple Shift @ —to
quickly produce a block pattern or a border. For block repeats, you will typically use
a very small or no overlap and a small or no feather radius.

Creating a block repeat from the selected rectangle. Symmetry setting: Double mirror *, tiling 1 x2.

Feathered selection edges Just as you use the feather effect to blend units clipped
by the control path, you can apply the usual Photoshop feather effect to edges of
your selection before launching SymmetryShop. Choose Select > Feather... to apply
the feather effect to the selection. Then launch SymmetryShop and let the units of



Artlandia SymmetryShop | 37
User Guide

repeat overlap by using the control path sliders. The plug-in will blend overlapping
units.

applied to edges of the selection. Symmetry setting: Simple shift m, tiling 4 x4 (fragment).

Q When editing the contour of the selected region to achieve a suitable blending, you will find it
convenient to re-apply SymmetryShop multiple times without bringing up the
SymmetryShop dialog (see ”Automating the workflow” on page 55).

Q The option Seed Layer Has Priority Over Pattern Layer, which you can set in the Preferences
dialog, makes interactive editing of the selection contour easier. See “Seed Layer Has Priority
Over Pattern Layer” on page 50.
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Supported objects

Besides the usual raster images, you can use fill and shape layers (filled with a solid
color, a gradient, or a pattern), type layers, as well as smart objects, as the source of
your SymmetryShop patterns. Smart objects are especially useful because they give
you essentially unlimited flexibility by letting you use any Photoshop or Illustrator
object, and any combination of such objects, as the pattern seed. See "Using smart
objects” on page 47.

. s s N
| Layers X | =

Narmal [5%) opacity: [ 100 |~_f
Leck: [0 @] Fill: 100 [wl

|
| SymmatryShop Layer

maE
An optical pattern created from a pattern fill. Symmetry setting: Double glide 81,
tiling 2 x2.

Q You can use vector and layer masks in combination with all layer types. See “Layer and
vector masks” on page 16.

Q In your seed layer, all vector elements (shape and type layers, vector masks, etc.) remain in
their original vector form so you can edit them and rebuild the pattern at any time.

Locking the seed layer When working on your patterns, you may find it
convenient to lock the seed layer fully or partially to prevent further changes to the
entire seed layer, its non-transparent contents, or the positioning of the seed objects.
SymmetryShop does not modify your seed layer and allows you to use all types of
locks that are appropriate for your task.
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can be interactively edited with SymmetryWorks in Illustrator. Symmetry setting: Double glide I!,

tiling 2 x2 (fragment).
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SymmetryShop patterns and Photoshop patterns

While working with the SymmetryShop palette, you can save (export) a snapshot of
your pattern as a pattern preset. To save a pattern preset, click the Export button. To
specify a non-default name for your preset, hold down the Alt key (Windows) or the
Option key (Mac OS) and click the Export As... button (the Export button becomes
the Export As... button when you press the Alt or Option key).

The exported pattern is based on a rectangular tile that is selected in the middle of
the pattern fragment produced by the plug-in. The fragment must have enough rows
and columns to completely cover the tile. This ensures a seamless exported pattern,
without gaps or other defects. You can preview the exported area by clicking the Tile
button in the Show section. Typically, 2 x 2 or 3 x 3 tilings are sufficient to cover the
tile area. However, you may need a bigger tiling to make brick or drop repeats or in
cases where parts of the seed image extend far beyond the boundaries of the control
path.

Note: The Export button is not available when the Preview or Snap to Rectangular Grid
check boxes are deselected or the Constrain Shift pop-up menu is set to None.

After you click the OK button in the SymmetryShop palette and return to Photoshop,
the plug-in saves the rectangular tile selection for your pattern in the alpha channel
called SymmetryShop Tile. You can load that channel as the selection at any time and
define a pattern preset exactly as you would define any other pattern preset (see “To
define an image as a preset pattern” in Photoshop’s User Guide).

To define a pattern preset for your SymmetryShop pattern:
1 Open a file with a SymmetryShop pattern (if it is not open).
2 Click the Channels tab (or choose Window > Channels to open the palette).

3 In the Channels palette, Ctrl-click (Windows) or Command-click (Mac OS) the
SymmetryShop Tile channel thumbnail.

4 Choose Edit > Define Pattern..., fill in the pattern name, and click OK.
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Pattern presets defined this way are available for all usual Photoshop uses with the
Paint Bucket, Pattern Stamp, Healing Brush, and Patch tools, or with the Layer Style
dialog box. See Photoshop’s User Guide for details.

Exporting to web browsers and textile CAD programs

To make a background for a web page or to use a pattern in a textile CAD program,
you need to create and export a rectangular tile that seamlessly covers the surface.
The SymmetryShop Tile channel saved with your pattern lets you easily export one
such tile. To export a rectangular tile, load the selection defined by the
SymmetryShop Tile (follow the first three steps in the preceding section), then
choose Image > Crop, and save the file.

Applying preset styles

As the SymmetryShop pattern layer is a usual Photoshop layer, you can treat it as
one once the pattern is made. In particular, you can apply various Photoshop preset
styles to quickly enhance a pattern created with the plug-in. You will also find it
useful to apply a preset style to the seed layer before launching SymmetryShop. In
this case, the plug-in will copy the style to the pattern layer and apply it
automatically while you interactively edit your pattern with the SymmetryShop
palette. This lets you easily find parameters that are suitable for the pattern you are
developing.

A

Applying preset Photoshop styles to a SymmetryShop pattern (left). Symmetry setting: Pinwheel ﬁ,
tiling 2 x2.
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Layer styles copied from the seed layer and applied automatically while patterns are
being edited. The two patterns are produced from the same seed using different layer

styles. Symmetry settings: Kaleidoscope m, tiling 2 x 3 (top) and Simple shift o6
(Vertical gradation layout), tiling 3 X7.
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Multiple windows

When working with complicated patterns, you may find it helpful to open a second
(third, and so on) window before launching SymmetryShop and zoom in on different
areas in different windows while keeping an overall pattern preview in your main
window. This lets you see different areas of the pattern while working with the
SymmetryShop palette. To open a second window, choose Window > Arrange >
New Window for your file, as described in Photoshop’s User Guide.

In Photoshop CS3 and later, you can run SymmetryShop automatically inside a smart object.
This lets you edit the seed in one window and observe the pattern in another window. See
“To autorun in a smart object” on page 57.
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Chapter 2
Working with SymmetryShop Patterns

SymmetryShop creates patterns from either RGB or CMYK images. If your image is
neither of these, you must convert it before SymmetryShop can be applied. Choose
either Image > Mode > RGB Color or Image > Mode > CMYK Color to convert.
Further, you must have only one layer selected in the Layers palette when launching
SymmetryShop.

If you wish to build a pattern from multiple layers, either combine them in a smart object (in
Photoshop CS2 and later versions) or merge the layers, as instructed in Photoshop’s User
Guide.

SymmetryShop remembers its numerous settings and automatically applies them
every time you launch the plug-in. When rebuilding a previously made
SymmetryShop pattern, the settings are the ones that you used to create the pattern.
For a new pattern, the palette opens with settings from the last created pattern.

Creating patterns

SymmetryShop builds a pattern based on your selection, if you supply one when you
create a pattern. It is not necessary to re-apply that selection every time the pattern is
rebuilt. If there is no selection, the plug-in automatically loads the selection that you
used the first time, if any. This makes it easy to re-create a SymmetryShop pattern in
another session. You also have the flexibility either to continue editing the pattern
using your old seed layer or to use the pattern layer (the SymmetryShop Layer) as a
new seed layer.

If you select something in the artwork before launching SymmetryShop, the plug-in
will treat your active layer (the layer highlighted in the Layers palette) as a seed
layer. By default, this rule applies even if your active layer is the SymmetryShop
Layer. This lets you use the pattern layer as a new seed layer. However, you can also
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choose to apply the selection to your old seed layer even when the SymmetryShop
Layer is active. To do so, select the check box Seed Layer Has Priority Over Pattern
Layer in the Preferences dialog box (see “Seed Layer Has Priority Over Pattern
Layer” on page 50).

To create a SymmetryShop pattern:

1 Select a seed layer in the Layers palette. The layer must be visible (click the eye
icon to make the layer visible).

2 Optionally, apply a layer and/or vector mask to isolate (mask) areas that you do
not want to use in your pattern. See “Layer and vector masks” on page 16.

3 Optionally, select a part of the image that you want to use as a seed with one of
Photoshop’s selection tools (for example, the Lasso tool).

4 Optionally, to control the initial appearance of the pattern, draw a prototype
control path (a work path). See “Prototype control path” on page 27.

5 Choose File > Automate > Artlandia SymmetryShop....
6 In the SymmetryShop palette, select the desired parameters and click OK.

The plug-in keeps your selection applied in a new pattern layer (the SymmetryShop
Layer) after you return to Photoshop. If you immediately launch the plug-in again, it
will use the SymmetryShop Layer as a new seed layer. However, you can also
rebuild the pattern from the old seed layer.

To rebuild a SymmetryShop pattern from the old seed layer:
1 Do one of the following:

*  While your previous selection is still applied, click the old seed layer in the
Layers palette and make it visible (click the eye icon to make the layer
visible).

*  Deselect the artwork (for example, using Select > Deselect) and leave the
SymmetryShop Layer selected in the Layers palette.



46

Chapter 2
Working with SymmetryShop Patterns

2 Choose File > Automate > Artlandia SymmetryShop....

Note: If an artwork contains a layer named the SymmetryShop Layer, the plug-in will apply
a selection channel named the SymmetryShop Selection (if there is one) if you launch the
plug-in without selecting anything in the artwork.

To discard the previously used selection, either delete (or rename) the SymmetryShop Layer
or delete (or rename) the SymmetryShop Selection.

To create a pattern using the SymmetryShop Layer as a new seed layer:
1 Select the SymmetryShop Layer in the Layers palette (if it is not yet selected).

2 Make sure that the SymmetryShop Layer is visible (click the eye icon to make the
layer visible).

3 Select a part of the SymmetryShop Layer using any of Photoshop’s selection
tools (for example, the Lasso tool).

4 Choose File > Automate > Artlandia SymmetryShop....

To use the SymmetryShop Layer as a seed layer without selecting anything in the artwork,
rename the SymmetryShop Layer. To rename, double-click the name of the layer in the
Layers palette and type in a new name.

You will often want to add space around your seed elements to give the plug-in
more room to build your pattern. This is necessary, for example, when the document
is not sufficiently large to fit enough rows and columns of the pattern or when you
wish to add the exact amount of canvas space yourself rather then relying on the
plug-in to extend canvas for you. In such cases, you will simply increase the canvas
size and rebuild the pattern.

Note: All SymmetryShop components, including the SymmetryShop Selection and the work
path are automatically repositioned when you change the canvas size or the image size of your
document. Therefore, in most cases, you will not need to change (or re-apply) your selection
or move the control path to the new location.
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To rebuild the pattern when changing the document size:

1 Choose Image > Canvas Size.... Fill in the necessary fields in the dialog, and click
OK.

2 Re-run SymmetryShop using a keyboard shortcut, action menu, or by choosing
File > Automate > Artlandia SymmetryShop....

Similarly, you can use the Crop tool (or Image > Crop) when you need to decrease
the size of your document. As long as you leave enough space for the plug-in to
rebuild your pattern, you do not need to reposition your selection and the control
path.

Using smart objects

Smart objects (available in Photoshop CS2 and later versions) provide a powerful
and convenient way to build a wide variety of patterns. You can use a smart object as
a seed layer or build a SymmetryShop pattern inside a smart object. These two uses
have their own advantages and they can be combined. That is, with smart objects,
you can nest SymmetryShop patterns.

For example, you will find it convenient to build a pattern inside smart objects to:
*  Create several SymmetryShop patterns in one artwork.

*  Crop a SymmetryShop pattern (and still be able to rebuild the pattern
inside).

*  Use the autorun feature. See “To autorun in a smart object” on page 57.
On the other hand, you may want to use a smart object as a seed layer to:

*  Create a pattern from multiple source layers (and be able to independently
edit each layer and rebuild the pattern).

*  Create all-over, tossed, composite, and other repeats. See “Implementing
other repeat systems” on page 68.
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Use one SymmetryShop pattern as a source for another.

Use a SymmetryWorks pattern as a source for a SymmetryShop pattern.
See “Supported objects” on page 38.

Use the autorun feature. See “To autorun in the main document” on page
59.

You can use all the standard Photoshop techniques to put your SymmetryShop pattern inside
a smart object. See “Create Smart Objects” in Photoshop’s User Guide.

To create a SymmetryShop pattern in a smart object:

Do one of the following:

If you are making a new SymmetryShop pattern, do it in a smart object.
For example, select your seed layer in the Layers palette and choose
Layer > Smart Objects > Convert to Smart Object. Then double-click the
layer thumbnail in the Layers palette (or choose Layer > Smart Objects >
Edit Contents) and proceed to create a SymmetryShop pattern as usual.
See “To create a SymmetryShop pattern” on page 45.

If you have already created a SymmetryShop pattern, save the file and
choose File > Open as Smart Object (to open in a new document) or File >
Place (to place in an existing document), as you usually do in Photoshop.

Note: Highlighting both the seed layer and the SymmetryShop Layer in the Layers palette
and choosing Layer > Smart Objects > Convert to Smart Object may not properly transfer all
pattern components to the new smart object and is not generally recommended (although, in
some cases, it may give satisfactory results).

To use a smart object as a seed layer:

You can create a SymmetryShop pattern from a smart object just as you would
normally do from any other seed layer.
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1 Optionally, if you do not have a smart object that you want to use as a seed,
create a new smart object (for example, by selecting one or several layers in the
Layers palette and choosing Layer > Smart Objects > Convert to Smart Object).

2 Select the smart object in the Layers palette and create a SymmetryShop pattern
as usual. See “To create a SymmetryShop pattern” on page 45.

Changing SymmetryShop preferences

To open the Preferences dialog, click the Preferences button in the SymmetryShop
palette.

SymmetryShop Preferences

o)

¥ Enable Autorun

( Cancel )

Seed Layer Has Priority Over Pattern Layer

( Default )

Symmetry lcon Tips
@ Long
") Shorthand

— Selection
Stray Pixel Cleanup: | Expand by _:| 0.2 |px

@ Refine Automatic Selections

Distance to Work Area: i x tile size

1) Changes will take effect the next time you create a
' pattern.

" Reset All Warning Dialogs

The Preferences dialog (the dialog may look slightly different on your computer).

Enable Autorun You can choose to automatically re-run SymmetryShop after you
edit the pattern seed. To do so, you must create a SymmetryShop in a smart object or
use a smart object as a seed layer. See “Autorun” on page 56. To enable the autorun
feature, select the Enable Autorun check box.

Note: The Enable Autorun check box is available only in Photoshop CS3 and later versions.
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Seed Layer Has Priority Over Pattern Layer By default, when you launch
SymmetryShop with some area of the seed image selected, the plug-in considers
your active layer (the layer highlighted in the Layers palette) to be the seed layer, see
“Creating patterns” on page 44. You can change that convention and tell
SymmetryShop to rebuild the pattern from the old seed layer, even if there is a
selection and the pattern layer (the SymmetryShop Layer) is currently the active
layer. To do so, select the Seed Layer Has Priority Over Pattern Layer check box. You
will find this option convenient when you want to quickly re-apply the plug-in after
making edits that do not require making the old seed layer active, for example,
changing the contours of the selection.

Symmetry Icon Tips SymmetryShop lets you switch between long and shorthand
(mathematical) tool tips for the symmetry controls. You may prefer the mathematical
notation for its brevity, even if it seems obscure.

Selection SymmetryShop may need a temporary copy of your seed image while
building a pattern. The copy is created automatically and removed when no longer
needed. Using the Stray Pixel Cleanup controls, you can choose to either expand the
selection by a certain number of pixels or grow the selection within a certain
tolerance to delete any stray pixels that might remain in the temporary copy. The
Refine Automatic Selections check box lets you apply the same method when
selecting non-transparent pixels of your seed image. See “Using selection” on page
15.

Distance to Work Area The Distance to Work Area text box lets you change the
distance from the original seed image to the temporary work area.

Finally, the Reset All Warning Dialogs button lets you reset all dialogs that you may
have disabled by selecting the Don’t Show Again check box. After you click the
button, all the dialogs will be re-enabled and displayed again when the need arises.

Using SymmetryShop pattern components in Photoshop

Many of the techniques described in this section can be considered “advanced
topics.” You may rarely, if ever, need to use them in your normal work. 5till, these
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are powerful techniques that add convenience and save time. They involve editing
components of the SymmetryShop pattern outside the plug-in (see “Components of a
SymmetryShop pattern” on page 17) and are especially useful when combined with
the automated application of SymmetryShop with a keyboard shortcut (see
“Automating the workflow” on page 55).
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Applying Photoshop’s Underpainting filter, and further the Liquify filter, to the seed image and re-
running SymmetryShop morphs the original pattern (left). The seed image is the same as in the pattern

on page 34. Symmetry settings: Simple shift m (Vertical & horizontal gradation layout), tiling 2 x 2.
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Most frequently, you will edit the seed layer and re-run the plug-in to update the
pattern.

Editing the seed layer allows you to work on your seed image and fine-tune it after the
pattern has been created.

To edit the seed layer:

1 If the seed layer is inactive and hidden (which is normally the case after
SymmetryShop finishes), click the seed layer in the Layers palette and click the eye
icon to make the seed layer active and visible.

2 Optionally, click the eye icon of the pattern layer (the SymmetryShop Layer) to
hide it.

3 Optionally, apply and/or edit the previous selection (see “To edit the
SymmetryShop Selection” on page 53).

4 Edit the seed layer as you would normally edit an image in Photoshop (for
example, use any painting technique, apply a filter or layer style, edit the layer and
vector masks, etc.) .

5 Re-run SymmetryShop using a keyboard shortcut, action menu, or by choosing
File > Automate > Artlandia SymmetryShop....

Note: You do not have to re-apply your selection every time you run SymmetryShop. The
plug-in will automatically use your previous selection (the SymmetryShop Selection), if any,
as long as your document contains the SymmetryShop Layer, even if it is hidden.

In Photoshop CS3 and later versions, you can run these steps automatically. See “Autorun”
on page 56.
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If you used a selection to create a pattern, the
plug-in saves your selection in the Symmetry
Selection alpha channel (see “The :
SymmetryShop Selection” on page 19). You (
can then edit that selection in a later session
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Applying the Edit > Stroke... command to the
SymmetryShop Selection of the pattern on page 28
and rebuilding the pattern.

H
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using the usual means available in 4D
Photoshop. For example, you can contract or \ —
expand the selection, add or subtract areas, ( N

i

change the feather radius, and so on. You can
then re-apply SymmetryShop using the
modified selection.

( )

To edit the SymmetryShop Selection:

1 In the Channels palette, Ctrl-click (Windows) or Command-click (Mac OS) the
SymmetryShop Selection thumbnail to load the saved selection.

2 Optionally, in the Layers palette, click the eye icon for the SymmetryShop Layer
to hide the pattern layer.

3 Optionally, click the seed layer in the Layers palette and click its eye icon to
make the layer visible.

4  Use the selection tools, the Select menu items (for example, Select > Modify), or
any other technique available in Photoshop to edit the selection as needed.

5 Optionally, edit the seed layer, see “To edit the seed layer” on page 52.

6 Re-run SymmetryShop using a keyboard shortcut, action menu, or by choosing
File > Automate > Artlandia SymmetryShop....

You can use layer and vector masks instead of (or in addition to) a selection. See “Layer and
vector masks” on page 16.
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Editing the control path using familiar Photoshop techniques outside the plug-in is
often more convenient than editing the control path using the sliders in the
SymmetryShop palette. You can access the control path through the Paths palette.
Then edit using the path tools in the Photoshop toolbox or by choosing Edit > Free
Transform Path or Edit > Transform Path.

To edit the control path:
1 In the Paths palette, click Work Path.
2 Edit the work path as needed.

3 Re-run SymmetryShop using a keyboard shortcut, action menu, or by choosing
File > Automate > Artlandia SymmetryShop.... Your edited work path becomes a
prototype control path and will be adjusted by the plug-in to obey the symmetry
laws (see “Prototype control path” on page 27).

Finally, you will also find it useful to work
with the SymmetryShop Tile channel in the
Channels palette. This channel is provided
solely for your convenience; the plug-in does
not use it in any way and changing it will not
effect the plug-in’s behavior. Creating
complex repeats by colorizing a pattern is
one example of using the SymmetryShop Tile
channel (see a pattern on page 20). As
another example, you can use the channel to
define a pattern preset outside
SymmetryShop, for instance, after applying a
small edit within the tile selection (inside
SymmetryShop, you can save a pattern
preset by clicking the Export button).

" N N 4 .V

Defining a pattern based on the SymmetryShop Tile
selection after adding a background. Symmetry
setting: Pinwheel ﬁ, tiling 2 x2.
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To save a pattern preset:

1 In the Channels palette, Ctrl-click (Windows) or Command-click (Mac OS) the
SymmetryShop Tile thumbnail to load the tile as a selection.

2 Optionally, use Photoshop’s tools to move the selection to some other position in
the artwork. For example, you can move it so the area that you wish to edit is
entirely inside the selection (as in the pattern based on the SymmetryShop Tile on
page 54). The tutorial “The Spools: Creating Complex Repeats” on page 83 gives
another example where you make your work easier by moving the tile selection.

Q When moving the SymmetryShop Tile selection, you do not need to take any special
precautions to position the selection relative to any symmetry axes or other elements of the
pattern. As long as you move the selection around without changing its size, and the
selection remains within the repeating part of the SymmetryShop pattern fragment, the
pattern preset based on the selection will repeat seamlessly.

3 Optionally, make edits inside the selected area.

When using the SymmetryShop Tile selection, you can make arbitrary changes inside the
selected region. The pattern preset that you define based on that region will repeat as long as
your edits do not touch the boundaries of the selection.

4 Choose Edit > Define Pattern.... Fill in the pattern name and click OK.

Automating the workflow

Running as an action By creating an action, you can run SymmetryShop from the
Actions palette or by pressing a keyboard shortcut, which is often more convenient
than running from the File > Automate submenu. You can record an action that runs
the plug-in just as you would any other Photoshop action. See “To use the Actions
palette” in Photoshop’s User Guide for detailed instructions.

To create an action that runs SymmetryShop:

1 Open any existing RGB or CMYK file or create a new file and paint something in
the file.
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2 If the Actions palette is not open, open it by choosing Window > Actions.

3 Inthe Actions palette, click the action set where you want to store your new
action, or create a new set, and click the New Action button at the bottom of the
palette.

4 In the New Action dialog, choose a name for your new action, and optionally a
function key (for example, F12), and check the modifier box, for example, Control
(on Windows) or Command (on Mac OS).

5 Click the Record button in the Actions palette to start recording.

6 Launch SymmetryShop by choosing File > Automate > Artlandia
SymmetryShop....

7  In the SymmetryShop palette, select the Preview check box (to let the recorded
action launch the plug-in with preview on) or deselect the check box (to run without
preview). Then click OK.

8  Click the Stop button in the Actions palette.

To play the recorded action, select it in the Actions palette and click the Play button
or press the corresponding keyboard shortcut. The latter is especially useful when
you wish to quickly re-apply the plug-in after editing pattern components. As with
any other Photoshop actions, you can run your SymmetryShop action silently,
without opening the SymmetryShop palette. Click the modal control in the Actions
palette to toggle the dialog on or off.

You may find it convenient to record the same SymmetryShop action twice, assign different
keyboard shortcuts, and toggle the dialog off for one of the actions. Then use one action to
launch the plug-in interactively and the other to quickly re-apply the plug-in without
opening the dialog.

Autorun Using smart objects, you can edit SymmetryShop pattern components and
run the plug-in automatically (autorun), every time your smart object is updated,
even without explicitly playing a recorded action. There are two ways to update a
smart object, while editing it in a separate file and after closing the smart object file and
returning to the main document that contains the smart object. Accordingly, there
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are two ways to autorun SymmetryShop, inside a smart object and in the main
document that contains the smart object.

Note: The autorun feature is available only in Photoshop CS3 and later versions.

Q Select the Enable Autorun check box in the SymmetryShop Preferences dialog to use the
autorun feature. See “Enable Autorun” on page 49.

Q Inside a smart object, autorun lets you interactively work on your seed image and see the
pattern updated in the main document window.

Q If you use a vector smart object as the seed of your SymmetryShop pattern, SymmetryShop
will run automatically every time you return to Photoshop after editing the seed layer in
Adobe lllustrator (or your other vector art editor). See “To autorun in the main document”
on page 59.

To use the first method, your SymmetryShop pattern must be created inside a smart
object. See “To create a SymmetryShop pattern in a smart object” on page 48.

To autorun in a smart object:

1 Open a document that has a SymmetryShop pattern created inside a smart object
(the “main” document).

2 In the Layers palette, double-click the thumbnail of the smart object or select the
smart object and choose Layer > Smart Objects > Edit Contents.

You will usually want to move your smart object window to the side (and make it smaller if
necessary) so that you can observe the pattern in the main document window while editing
the smart object in another window.

3  If the seed layer is inactive, click the seed layer in the Layers palette to make the
seed layer active.

Note: SymmetryShop will run automatically only if the seed layer is selected in the Layers
palette.

4 Optionally, toggle the visibility of the seed layer and the SymmetryShop layer as
necessary (click the eye icon of the layer you want to show or hide).
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5

Edit the seed layer, its layer and vector masks, the SymmetryShop Selection,

and/or the control path.

6 Choose File > Save or type Ctrl-S (Windows) or Command-S (Mac OS) to save
the smart object and trigger its update in the main (parent document) window. This

starts an autorun.

When SymmetryShop finishes an autorun, it restores the active layer and the
visibility of the seed layer and the SymmetryShop layer to let you continue your
edits with minimal interruption.

V

SymmetryShop always saves the smart object file after rebuilding a pattern during an
autorun, but restoring the visibility of layers to the pre-autorun state may turn the file back
to an unsaved state. You will usually discard the visibility changes when closing the smart
object’s window and returning to the main document. That is, you should choose not to save
changes if you want the main document to keep the last pattern you saved.

Note: If you do choose to save changes when closing the smart object file after an autorun,
Photoshop will save the smart object normally, in the state in which it appears on the screen.
This may overwrite the pattern saved in the parent file during the last autorun.

To save a smart object file without triggering an autorun, select any layer other than the seed
layer in the Layers palette and choose File > Save or type Ctrl-S (Windows) or Command-S
(Mac OS).

If you wish to save a smart object with the seed layer selected in the Layers palette, make
changes to your smart object, close the smart object file, and choose to save changes when
prompted by Photoshop. Alternatively, you can disable autorun in the SymmetryShop
Preferences dialog. See “Enable Autorun” on page 49.
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Running SymmetryShop automatically. The pattern shows in the main document window while the
seed element is being edited in a separate window.

If a seed layer of your SymmetryShop pattern is a smart object, you can run
SymmetryShop automatically in the main document.

To autorun in the main document:

1 Double-click the seed layer thumbnail in the Layers palette to edit your smart
object or select the layer and choose Layer > Smart Objects > Edit Contents. Your
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smart object will open in a separate window or in another application, such as Adobe
Mlustrator, if your smart object is an Illustrator artwork.

2 Do one of the following:

* If you are editing your smart object file outside Photoshop, do your edits,
save the smart object file, and return to Photoshop. SymmetryShop will
rebuild your pattern as soon as you return to Photoshop.

* If you are editing your smart object file in Photoshop, do your edits, but do
not save the final version of your smart object file. Instead, close that file
by choosing File > Close or typing Ctrl-W (Windows) or Command-W
(Mac OS). Photoshop will ask if you want to save changes to the file.
Answer Yes. Your smart object file will be saved at that point and
SymmetryShop will rebuild your pattern using the final (saved) version of
your smart object.

Q While editing your smart object, you can save any temporary state normally, as you usually
do, but to trigger an autorun, your smart object must have an unsaved change before you
close the file. One way to quickly make a saved document unsaved is to toggle the visibility of
some layer twice. Your document will be identical to the one you saved, and yet it will be in
the unsaved state.



Artlandia SymmetryShop | 61
User Guide

Chapter 3
Layouts and Repeat Systems

With SymmetryShop, you can easily produce predefined repeat systems and create
new ones based on smart objects.

The built-in layouts

The Layout list in the SymmetryShop palette lets you create many predefined repeat
systems with a single click. The Layouts folder in your SymmetryShop folder
contains samples of most built-in layouts. The samples were created by applying the
chosen layout and then possibly scaling the control path.

Note: Scaling the control path may change the layout selection in the Layout list to the
Normal layout.

Q Keep in mind that built-in layouts give you much more than a single sample available from
the Layout list. By changing the symmetry type, you can quickly redeploy the replicas in a
supplemental layout. This immediately expands the repertoire of available pattern types. See
“Replicas” on page 23.

Stripe Stripes often appear in the brick and drop layouts, especially ones created
using smaller values of the Constrain Shift option (see “Constrain Shift” on page 30).
One possible variation of the brick layout, with the Constrain Shift set to 1/3, is
provided in the SymmetryShop palette as the Stripe layout.

Diamond A rich variety of patterns whose elements are arranged along diagonal
(diamond) lines comes from use of the Simple shift %, Glide reflection 3‘3’, Half-turn
%, and other symmetry types. The Diamond layout in the SymmetryShop palette
constructs a glide-reflection pattern with a 1:2 ratio between the sides of the control
path.
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%

A selected area in the Strlpe layout. The control path is a parallelogram. Symmetry

setting: Simple shzft , tiling 7 x4.
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A selected element in the Diamond layout. The control path is a rectangle.

Symmetry setting: Glide reflection 3‘3‘, tiling 3 x5.
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A selected element in the Brick layout. The control path is a parallelogram.

Symmetry setting: Simple shift m, tiling 5 x6.

Brick and Half-drop You can create brick
and drop layouts using the Simple shift
symmetry and applying (respectively) the
horizontal or vertical skew to the control
path. The Constrain Shift option in the
SymmetryShop palette lets you choose the
amount of shift (see “Constrain Shift” on
page 30). The Half-drop and Brick layouts in
the Layout list provide you with a quick way
to create two representative samples of these

layout types.

A selected element in the Half-drop layout. The
control path is a parallelogram. Symmetry setting:

Simple shift m, tiling 5 x6.
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Vertical gradation Several replicas, scaled in different proportions along the
vertical direction produce a vertical gradation. Suitable symmetry types for such

patterns 1nclude Simple shift @ Glide reflection 3’3’ Mirror Eﬁ Half-turn @ and
Double glide 5. In the Vertical gradation layout in the SymmetryShop palette, the
pattern uses the Simple shift symmetry & and has three replicas.

This and the following gradation layouts easily make optical illusions and other optical
patterns.
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A selected element in the Vertical gradation layout. The pattern has a rectangular

control path and three replicas. Symmetry setting: Simple shift &, tiling 3 x9.



Horizontal gradation Horizontal gradations
are very similar to vertical ones, except
scaling takes place in the horizontal
direction. One of the possible layouts of this
type is provided in the SymmetryShop
palette as the Horizontal gradation layout.

Vertical and horizontal gradation You can
combine vertical and horizontal gradation in
one pattern. One of the possible layouts is
provided in the SymmetryShop palette as the
Vertical and horizontal gradation layout.
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A selected element in the Horizontal gradation
layout. The pattern has a rectangular control path
and three replicas. Symmetry setting: Simple shift

&0, tiling 3 x2.
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A selected element in the Vertical and horizontal gradation layout. The pattern has a

rectangular control path and fifteen replicas. Symmetry setting: Simple shift m, tiling 2

x3.

After creating a straight pattern with vertical, horizontal, and vertical and horizontal
gradations, you can choose another symmetry type with a rectangular control path, for

65
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0 ., mE . .
example, Half-turn XX or Double glide @8, This is a quick way to generate many more
interesting gradations.

Gradation and scale The Gradation and scale layout in the SymmetryShop palette
is similar to the Vertical gradation layout in the sense that the scale of replicas varies
in the vertical direction and remains constant in the horizontal direction. However,
in the Gradation and scale layout, replicas are produced by scaling the original seed
image by the same factor in both horizontal and vertical directions.
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A selected element in the Gradation and scale layout. The pattern has a rectangular

control path and 47 replicas in five rows. Symmetry setting: Simple shift a, tiling 2 x
2 (a fragment shown).

Spot repeats The SymmetryShop palette gives you the 3-spot, 4-spot, 5-spot, and 6-
spot layouts (also called sateen repeats or sateens). Spot repeats feature replicas
arranged on a rectangular grid in such a way that each row and column in the
repeated unit contains only one replica. Typically, the replicas are rotated and
possibly reflected. Spot repeats could be used to create diagonal lines in the pattern
or a random scattered appearance. For an example of a spot repeat, see the butterfly
pattern on page 15.
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A selected element in the 3 x 3 layout. The control path coincides with the outer
bounds of the grid. All objects on the grid are replicas, except for the lower-left

(selected) one, which is the seed. Symmetry setting: Simple shift a, tiling 2 x2.

Grid repeats Similarly to spot repeats, grid
repeats are arranged on a grid, but unlike
spot repeats, all squares in the grid are
populated. The SymmetryShop palette
provides representative straight 3 x 3 and 4 x
4 grid repeats. For each of them, the palette
also gives two similar repeats, in which every
other row or column is shifted halfway in the
horizontal or vertical direction. You can find
detailed instructions for creating a sample
pattern with a grid repeat in the Tutorial part
of this guide. See “The Random Weave:
Blending Units of Repetition” on page 74.

A selected element in the 3 x 3 layout. The feather
effect with the 5 pixel radius is applied to the
selection to create smooth transitions. Symmetry

setting: Simple shift m, tiling 2 x2.
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Implementing other repeat systems

Using a smart object as a pattern seed, you can easily create an even greater variety
of patterns. Smart objects can include one or several ordinary layers or other smart
objects, possibly linked to each other, or even other SymmetryShop patterns,
allowing you to quickly create arbitrary complex patterns. See “Using smart objects”
on page 47.

All-over repeats and tossed repeats All-over and tossed designs are especially
easy to create with SymmetryShop. Simply make as many linked copies of your
design elements as necessary and scatter them over the desired repeat area.
Optionally, rotate, reflect, and scale the copies to achieve a more organic look. Then
combine them in a smart object and use that object as the seed of your
SymmetryShop pattern. You can always edit the design elements, reposition the
linked copies, and rebuild your SymmetryShop pattern.

To create an all-over or tossed design:

1 Choose File > New... to open a new file. Fill in the width and height that are
somewhat greater than the desired repeat size.

2 Choose File > Place... to place the first design element saved as a separate file.
The element will be placed as a smart object. Repeat as many times as there are
design elements.

3 Optionally, duplicate the first smart object. In most cases you will want to create
linked objects to be able to edit only one instance if the design element needs to be
modified. See “Duplicate a Smart Object” in Photoshop’s User Guide.

One convenient way to create a linked smart object in Photoshop is to select the Move Tool in
the toolbox, hold down the Alt key (Windows) or the Option key (Mac OS), click the object
you want to duplicate, and drag it in the artwork.

4 Type Ctrl-T (Windows) or Command-T (Mac OS) to place free-transform handles
around the object and move, rotate, scale, and/or flip the object as usual. Type Enter
to accept the changes.
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5 Repeat steps 3 and 4 as many times as necessary. You do not have to be precise
in positioning copies of the elements at this stage. You will be able to adjust the
positioning later (as well as add or remove copies of the design elements).

6 Select all layers in the Layers palette (for example, click the first layer and then
Shift-click the last layer).

7  Choose Layer > Smart Objects > Convert to Smart Object.

8 Create a SymmetryShop pattern as usual. See “To create a SymmetryShop
pattern” on page 45. Most frequently, you will use the Half-drop or Brick layout in

the Layout list or create a full-drop pattern using the Simple shift % symmetry. You
do not have to worry about possible gaps in the pattern at this stage. Click OK to
return to Photoshop.

Most frequently, you will want to interactively edit your seed object (rearrange
design elements, add/or remove copies, etc.) and then rebuild the pattern. It is most
convenient to do so by running an action, for example by pressing a keyboard
shortcut, without displaying the SymmetryShop palette. See “Automating the
workflow” on page 55.

To edit an all-over or tossed design:

1 Double-click the seed layer thumbnail in the Layers palette (or choose Layer >
Smart Objects > Edit Contents) to open the smart object in a separate window.
Arrange the smart object window and the main document window side-by-side so
that it will be convenient for you to go back and forth between the two windows.

2  In the main document window, click the SymmetryShop Layer in the Layers
palette.

3 Select the Move tool in the toolbox.

4 In the smart object window, Ctrl-click (Windows) or Command-click (Mac OS)
the object that you want to reposition. This selects the proper layer in the Layers
palette.
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5 Type Ctrl-T (Windows) or Command-T (Mac OS) to place free-transform handles
around the object and move, rotate, scale, and/or flip the object as usual. Type Enter
to accept the changes.

6 Repeat steps 4 and 5 for other design elements.

7  Save the document to update the smart object in the main document window
and return to the main document window.

8 Optionally, if you want to change the repeat size, click Work Path in the Paths
palette. Type Ctrl-T (Windows) or Command-T (Mac OS) to place free-transform
handles around the control path, and drag the handles to increase or decrease the
repeat size in the horizontal and/or vertical directions. Type Enter to accept the
changes. See “To edit the control path” on page 54 and “The Tulips: Automating
SymmetryShop” on page 80.

9 Run the SymmetryShop action to rebuild the pattern.

10 Repeat steps 4 through 9 until you are satisfied with the pattern.

Gl
T

A tossed design created from two floral elements (top left). The seed consists of seven
linked copies of the first element and two copies of the second element, combined in a

smart object (bottom left). Symmetry setting: Simple shift
(fragment).

tiling 3 x3
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Composite repeats Composite repeats combine elements of two or more symmetry
types. You can create them by nesting SymmetryShop patterns using smart objects.

To create a composite repeat:

1 Create a SymmetryShop pattern in a smart object. See “To create a
SymmetryShop pattern in a smart object” on page 48. Typically, this pattern will
consist of a few tiles or just a single tile.

2 Optionally, add other design elements to the smart object. To add elements,
double-click the smart object thumbnail in the Layers palette (or choose Layer >
Smart Objects > Edit Contents) to open the smart object in a separate window. Then
add elements, save the file, and return to the main document window.

3  Use the smart object as a seed of another SymmetryShop pattern. See “To use a
smart object as a seed layer” on page 48.

Gl e e e

A composite repeat created from a floral element (top left). The seed consists of one

tile of the Pinwheel ﬁ symmetry created in a smart object (bottom left), which was

slightly rotated and put into a brick repeat. Symmetry setting: Simple shift
tiling 3 x4 (fragment).
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These step-by-step tutorials take you through all the stages of
creating several pattern designs with SymmetryShop, from start to
finish. The tutorials have extensive references to other material in
this guide and could be used as a starting point for learning and
mastering the plug-in.
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Chapter 4
The Random Weave: Blending Units of
Repetition

This tutorial walks your through the basic steps of creating a SymmetryShop pattern.

1 Choose File > New to open a new image
file. In the New dialog, let both Width and
Height be at least 400 pixels, Color Mode be
RGB Color, and Background Contents be
White.

If the Layers palette is not open, choose
Window > Layers to display the palette.
Click the New button in the Layers palette
to create a new layer. This will be your seed
layer. Paint a ball in the lower-left corner.
You may want to allow more room between

the ball and the bottom and left boundaries ( '
of the image. See “Position of the seed” on

page 17 for advice on positioning your seed
image.

Alternatively, you can open the file ball.psd
in the Tutorial folder in your
SymmetryShop folder.

You can paint the ball in the background layer instead (that is, skip the step of creating a new
layer), but having a white background gives a better appearance on the screen for this
pattern.
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2 Very often you will select a part of your
image to use in the pattern or isolate (mask)
parts that you do not want. For this pattern,
use a vector mask. Right-click (Windows) or
Control-click (Mac OS) the vector mask e

1
11}

. . Narmal ['#) opacity: [ 100x E‘
thumbnail for the ball layer in the Layers Ot e i [roox 9
palette and choose Enable Vector Mask from B e W
the pop-up menu, or use the Rectangle Tool =L e

from the Photoshop toolbox to create a new = @ D Backgraund Fill

vector mask for your own seed image.

3  With the seed layer selected in the Layers palette and no selection in the artwork,
launch the plug-in by choosing File > Automate > Artlandia SymmetryShop....

== |0 ®. 0|6

In the SymmetryShop palette, choose the 3 x 3 layout and deselect the Clip at Control
Path option (if it is selected). See “Layouts” on page 22 about the Layout list. Be sure to
select the Show: Control Path check box and click the Selection button to see the control
path and the selection. Notice that the area within the control path contains the original
seed image and its eight copies (replicas), as appropriate for the 3 x 3 layout, see
“Replicas” on page 23.
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4  The control path determines the repeat
size and orientation of your pattern. See
“The control path” on page 24. You will
now slightly adjust the size of the control
path and get the units of repetition closer to
each other so that the background will not
show through in the pattern area. Click the

Link button ¥! to change the width and
height of the control path simultaneously
and decrease the size of the control path by
two points or as necessary. To change the
width, use the W slider. Then click OK to
return to Photoshop.

I
/g
/[ =

)

Q As with other Photoshop boxes, you can change values in the boxes in the SymmetryShop
palette by clicking in the box and then using the up and down arrows on the keyboard to
increase or decrease the value in the box by one unit. This is convenient for making small
incremental adjustments. If you hold down the Shift key and press the up or down arrow, the
value changes by several units.



5 SymmetryShop lets you continue
working on your pattern in another session.
You will now apply a selection to the
original ball image to develop the previous
pattern into one with blended units of
repetition. While in Photoshop, toggle the
eye icon to hide the SymmetryShop Layer,
Then toggle the eye icon of the seed layer to
show it instead. Right-click (Windows) or
Control-click (Mac OS) the vector mask
thumbnail of the seed layer and choose
Disable Vector Mask from the pop-up
menu. Now Ctrl-click (Windows) or
Command-click (Mac OS) the vector mask
thumbnail to load the mask as the selection.
Finally, choose Select > Feather, set the
feather radius to 5 pixels, and click OK.

6 At this point, the seed layer should be
selected in the Layers palette and the
feathered selection applied to the artwork.
Launch SymmetryShop again. This should
give you a pattern similar to the one on
page 67. As a bonus, you can quickly create
variants of this design by choosing other
values from the Layout list, such as 3 x 3
vertical shift, 3 x 3 horizontal shift, 4 x 4,

4 x 4 vertical shift, and 4 x 4 horizontal shift.

You can find the final pattern for the 3 x 3
layout in the file ball_RandomWeave.psd in
the Tutorial folder in your SymmetryShop
folder.
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Chapter 5
The Wild Flowers: Using Multiple Source
Layers

Very often you will want to create a pattern from a combination of multiple source
images. One way to do this is to simply flatten the layers that contain your seed
elements. However, it is much better to keep the sources in separate layers. You will
then be able to quickly rearrange elements in the seed, replace elements, combine
elements with different resolutions, and so on. In Photoshop CS2 and later versions,
this can be easily accomplished by combining multiple layers in one smart object and
using that object as a seed layer for your SymmetryShop pattern. In this tutorial, you
will learn the process. You can safely skip this tutorial if you are comfortable
working with Photoshop smart objects—there is nothing specific to SymmetryShop
to learn in this regard.

1 Open an image on a transparent

background, for example, the file *
wflowers.psd in the Tutorial folder in your & .‘- ¢
SymmetryShop folder. S

2 If the canvas is big enough to accommodate additional elements, skip this step and
go to the next. If not, add some extra space by choosing Image > Canvas Size... or using
the Crop tool. For example, select the Crop tool in the toolbox and drag diagonally
across the entire canvas. Then drag the middle handle on the right side to the right
(beyond the boundary of the artwork), so that you will about double the size of the
artwork. Press the Enter key to accept the change. If necessary, repeat to add more
space.

3  You will now add another layer to the artwork. Select the Custom Shape tool in the
toolbox (the tool is in the Rectangle tool group). In the options bar, select the Grass 2
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shape in the Custom Shape pop-up palette.
Click the Shape Layer button. Also in the
options bar, choose some green color in the
Color palette. Click and drag the shape tool
in the area to the right of the flowers. This
creates a shape layer. If you wish, add a
layer effect (for example, Gradient Overlay
and Satin) by clicking the Layer Style button at the bottom of the Layers palette—or add
more layers with other elements.

4 In the Layers palette, select all the layers that you want to be a part of your seed
object (Shift-click or Ctrl-click (Windows) or Command-click (Mac OS) the layer to add
it to the selection). Then choose Layer > Smart Objects > Convert to Smart Object.

5 With the new smart object selected in
the Layers palette, launch the plug-in by
choosing File > Automate > Artlandia
SymmetryShop.... You can choose the

Double glide symmetry B8 in the
SymmetryShop palette, and optionally
adjust the size and position of the control
path. If you prefer to edit the control path
with Photoshop tools, click OK in the
SymmetryShop palette to return to
Photoshop and then adjust the control path
as described in the next tutorial. See “The
Tulips: Automating SymmetryShop” on
page 80.

Now that your source layers are separately kept inside the smart seed layer, you can
double-click the seed layer thumbnail in the Layers palette (or choose Layer > Smart
Objects > Edit Contents) to open the smart object in a new window and edit your
source layers as you normally do in Photoshop. You can even have SymmetryShop
run automatically (autorun) when you are done with your edits of the seed layer. See
“To autorun in the main document” on page 59.
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Chapter 6
The Tulips: Automating SymmetryShop

In this tutorial you will create a simple all-over design and learn to interactively
apply the plug-in using Photoshop actions.

1 Use your own image on a transparent
background or open the file tulips.psd in the
Tutorial folder in your SymmetryShop
folder. Make sure that the tulips layer is
selected in the Layers palette and launch the
plug-in by choosing File > Automate >
Artlandia SymmetryShop....

Note: In SymmetryShop 1, you needed to
select non-transparent areas of the seed layer &
before launching the plug-in. Starting from
SymmetryShop 2, this is no longer
necessary (but you can still select the tulips
if you wish).

&
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2 In the SymmetryShop palette, choose

the Double glide symmetry 88 and deselect
the Clip at Control Path check box (if it is
selected).

At this point, you can use the sliders in the
Control Path area to move or scale the
control path. However, you will instead
learn to edit the control path outside the
plug-in. Do not worry if the control path
and the pattern do not look exactly as in the
picture on the right (they may look different
if you started from another symmetry). Just
click OK and return to Photoshop.

3 Now you will edit the control path and re-run the plug-in to rebuild the pattern.
Editing will change the appearance of the pattern and its repeat size. See “To rebuild a
SymmetryShop pattern from the old seed layer” on page 45.

4 Itis convenient to run SymmetryShop using a keyboard shortcut, for example, Ctrl-
F12 (on Windows) or Command-F12 (on Mac OS), or by selecting an action in the
Actions palette and clicking the Play button. If you have not yet recorded an action that
runs the plug-in, do it now. You can record it just as you would any other Photoshop
action, or by following the instructions in this guide. See “To create an action that runs
SymmetryShop” on page 55. When you launch the plug-in to record an action,
SymmetryShop will rebuild the pattern and you will end up with exactly the same
pattern.

As you will not need to change any setting in the SymmetryShop palette, click the
dialog icon for your SymmetryShop action to toggle the dialog off and let the plug-in
run automatically, without bringing up the palette.
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5 You have set up everything that you
need to run SymmetryShop interactively.
Now you can edit the work path (that holds
your control path) and re-run the plug-in to
rebuild the pattern. The plug-in will take
your edited path as a prototype control path
(see “Prototype control path” on page 27)
and restore its rectangular shape if you
incidentally distort it during your edits.

In the Paths palette, click Work Path and
select the Direct Selection tool in the
toolbox. Drag the upper side of the control
path down to decrease the height of the
rectangle. Then run your SymmetryShop
action to rebuild the pattern. Notice that the
vertical repeat size has become smaller as

the neighboring units now overlap.

6 Make a few more adjustments to the
control path: move it as a whole to the left
(this will shift every other row of tulips to
the left and make the tulip distribution more
uniform) and decrease the height of the
control path some more (this will make your
pattern even more compact). To move the
path as a whole, you can use the Path
Selection tool.

When you are satisfied with your pattern, toggle the dialog for your SymmetryShop
action back on and run the plug-in one more time to set the tiling size to 3 x 3. This
creates a slightly bigger pattern fragment, a piece of which is shown here.
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The Spools: Creating Complex Repeats

This tutorial starts from creating a simple geometric design and then demonstrates
the use of the SymmetryShop Tile, one of the components produced by
SymmetryShop. See “Components of a SymmetryShop pattern” on page 17. Even
though the use of SymmetryShop in this tutorial is simple, the steps you will take to
create a complex repeat require some deeper understanding of symmetry, so this is
an advanced tutorial. In the end, you will re-create a pattern on page 20.

1 The spools pattern is created from a
simple circle. Open a new artwork and
choose the elliptical marquee tool in the
toolbox. Hold down the Shift key and drag
the pointer diagonally somewhere in the
lower-left corner of the artwork to select a
circle. Then choose Edit > Stroke.... In the
resulting dialog, set Width to 1 pixel, choose
the black color for the stroke, and click OK.

For this pattern, you can simply paint the
circle in the background layer. However,
creating a new seed layer (as in step 1 in a
previous tutorial, “The Random Weave:
Blending Units of Repetition” on page 74)
gives you a slight advantage because
SymmetryShop will locate your circle and
create the control path in its vicinity.

2 Deselect the circle (choose Select > Deselect) and launch SymmetryShop (choose
File > Automate > Artlandia SymmetryShop...). In the SymmetryShop palette, click the

symmetry type Quarter-turns & rotated mirrors & check the Clip at Control Path
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option, and set 0% overlap and 0 pixels for the feather radius. Make sure that the Show:
Control Path check box is selected.

Now deselect the Preview check box to see
both your circle and the control path that
the plug-in created for you. Using the X and
Y sliders, adjust the horizontal and vertical
positions of the control path so that the left
edge of the control path is aligned with the
left edge of the circle, and the bottom of the
control path is located somewhat below the
center of the circle. Using the W slider, make
the width of the control path about as big as
shown in the picture on the right (the

diagonal of the control path will go through &
the center of the circle).

3  Select the Preview check box to build
the pattern. Depending on how you position
the control path relative to the circle, the net
created by the circle pieces may have gaps,
which are undesirable (they may not let you
color the “spools” in the next step). You can
eliminate the gaps by fine-tuning the
position of the control path and its width
and by increasing the overlap value. When
your pattern resembles the one on right,
click OK. You can find the pattern created at
this stage in the file spools.psd in the
Tutorial folder in your SymmetryShop
folder.

|
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4 On exit, the plug-in adds an alpha
channel called the SymmetryShop Tile, which
contains the precise rectangle that you can
use to define a pattern preset (see “The
SymmetryShop Tile” on page 20). You will
now transform that channel to define a more e v <7
complex pattern. Open the Channels palette
and Ctrl-click (Windows) or Command-click
(Mac OS) the SymmetryShop Tile channel S~ S N,
thumbnail, to load the channel as the ' '
selection.

5 Choose Select > Transform Selection. In
the options bar, click the Link icon to
maintain the aspect ratio, and enter 200% in
the W (horizontal scale) text box. Then click
somewhere in the free-transform area and
drag the selection rectangle diagonally so
that the free-transform anchors fall inside
the spool areas (leaving the anchors in the

small squares between spools is less

convenient). Press the Enter key to accept
the transformation.
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6 Now you will colorize spools inside the
selected area, starting from the ones that are
intersected by the selection boundaries. As
the selected rectangle seamlessly tiles the
plane, a spool that is intersected at the
bottom will continue on the top. You will
paint these matching parts using the same
color.

Choose some light green color using
Photoshop’s Color palette. Then select the
Paint Bucket tool in the toolbox and make
sure that the Contiguous check box in the
options bar is selected. Click somewhere in

the left spool that is intersected by the lower
boundary of the selection to assign the color to that area. Finally, click the area directly
above that is intersected by the upper boundary. This will assign the same color to the
two matching areas.

7 Repeat step 6 one more time with a
darker green color. This time there will be a
smaller part of the spool at the bottom and a
bigger part at the top of the selected area.

1

i

1

Then continue to color the matching parts at !
the left and right boundaries using two 4
more colors. !
L}

i




8 Notice that the spool adjacent to the
upper-left corner is cut into three parts by
the selection boundaries. Therefore, there
will be three matching parts for this spool in
the selected region. Use a purple color for
these parts.

9 The spool in the upper-left corner is cut
into four parts. You can see these parts
clearly if you draw continuations of the
selection lines. The matching parts for this
spool are in all four corners of the selected
area. Use a light yellow color for these
corner parts.

Artlandia SymmetryShop | 87
User Guide




88 | Chapter 7
The Spools: Creating Complex Repeats

10 You have only two easy (contiguous)
spools left. Use a darker yellow color and a
light blue color for them. Finally, apply the
burgundy color to the remaining six small
squares between spoons.

Your new tile is ready. Choose Edit > Define
Pattern..., enter a name for your pattern in
the resulting dialog, and click OK. You can
now use the new pattern as a fill with many
Photoshop tools, for example, the Paint
Bucket tool. As expected, the repeat size of
the pattern is twice as big as the repeat size
of the original (spools of the same color
appear in every other row and column).
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automatic, 6, 17
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and preparing seed images, 17
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launching SymmetryShop, 44
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optical patterns, 64
Overlap text box, 34, 84

P
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Preferences button, 12, 49
preset layouts, 13, 22
preset styles
in SymmetryShop patterns, 41
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Preview check box, 12, 13, 18, 40, 84
previewing
exported tile, 40
in different windows, 43
prototype control path, 24, 26, 27, 28, 45, 54,
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Q

quarter-drop repeat, 30, 31

Quarter-turns & mirrors symmetry, 14

Quarter-turns & rotated mirrors symmetry,
13, 20, 34, 83

Quick Reference card, 2

Quick Start dialog, 2

R

rebuilding SymmetryShop patterns, 18, 26,
45, 52
and image size, 46
and selection, 49
and SymmetryShop Selection, 19, 46
by running an action, 19, 20, 55, 80
settings for, 44
rectangular tile, 41
Refine Automatic Selections check box, 50
Register button, 2
repeat size, 24
repeat systems

implementing your own, 68
replicas, 23, 30, 66
and paint order, 32
in Gradation and scale layout, 66
in grid layouts, 67
in Horizontal gradation layout, 65
in spot layouts, 66
in Vertical and horizontal gradation layout, 65
in Vertical gradation layout, 64
Reset All Warning Dialogs button, 50
Rotation Angle text box, 25, 28
royalty-free designs, in Artlandia Collection, 4
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Seed Layer Has Priority Over Pattern Layer
check box, 37, 45, 49
selection, 15
new in SymmetryShop 2, 6
Selection
button, 75
preferences, 50
serial number, 1
shape layers
using in patterns, 6, 10, 37
using in smart objects, 78
Shorthand, symmetry icon tips, 50
Show controls, 24
Simple shift symmetry, 14, 30, 31, 37, 39,
42,51, 61, 62, 63, 64, 65, 66, 67, 69, 70,
7
Six rotations symmetry, 32, 33
Skew Amount text box, 25, 28, 29, 30, 31
Skew Direction pop-up menu, 25, 28, 30
smart objects
adding canvas space in, 17
and all-over repeats, 68
and autorun, 49, 56
and composite repeats, 71
and implementing repeat systems, 68
and multiple layers, 5, 44, 47, 78
and tossed repeats, 68
and using Symmetry Works patterns, 39

creating patterns in, 48
editing, 43
new in SymmetryShop 2, 5
support for, 37
using as seed, 48
using with SymmetryShop, 47
Snap to Rectangular Grid check box, 25, 29,
30
spot layouts, 15, 66
spot repeats, 66, 67
starting SymmetryShop, 44
Stray Pixel Cleanup controls, 50
Stripe layout, 61, 62
supported objects, 37
Symmetry Icon Tips buttons, 50
SymmetryShop channels, 19
SymmetryShop Layer, 10, 18, 44, 45, 46, 49,
52, 57
as a new seed layer, 44, 46, 48
hiding, 53
SymmetryShop palette, 10
SymmetryShop patterns, 13
and Photoshop patterns, 40
components of, 17
making, 13, 44
SymmetryShop Selection, 10, 18, 19, 46, 53
automatically applied, 52
editing, 53
SymmetryShop Tile, 10, 18, 19, 20, 29, 31,
40, 54
and pattern preset, 40, 55
arbitrary changes within, 55
cropping, 41
exporting, 41
moving in the artwork, 55
using for complex repeats, 83
SymmetryWorks patterns
using with SymmetryShop, 5, 39, 47
SymmetryWorks plug-in, 4
system requirements, 1

T

textile CAD programs, export to, 41



Three mirrors symmetry, 14
Three rotations & mirrors symmetry, 14
Three rotations symmetry, 22
tile, 13
Tile button, 12, 40
tile size

for drop and brick repeats, 31
Tiling controls, 12, 21
tool tips, 12, 50
tossed repeats, 5, 47, 68
tutorials, 73
type layers

using in patterns, 6, 37

U

units of repeat, 13
unlocking full version, 1
usage hints, 12

\"

vector masks

and autorun, 58

and default control path, 24

using in patterns, 6, 10, 16, 20, 38, 45, 53, 75
Vertical and horizontal gradation layout, 65
Vertical gradation layout, 42, 51, 64, 66
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Vertical Position text box, 25

W

W, Width text box, 25, 76, 84

web page backgrounds, 41

web resources, 3

Width text box, 25

work path
and control path, 10, 18, 21, 24, 26
and prototype control path, 24, 26, 45
editing, 54, 82
renaming to preserve, 24

X

X, Horizontal Position text box, 25, 76, 84

Y

Y, Vertical Position text box, 25, 76, 84

y 4

Zoom In button, 12
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