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Getting Started

Artlandia® LivePresets™ is an Adobe® Illustrator® plug-in that lets you
interactively edit the “static” Illustrator objects (presets), such as pattern swatches
and symbols, and immediately apply your changes to all instances of the presets in
your artwork.

Installation
LivePresets requires Adobe Illustrator 10 or later (Illustrator CS2 or later
recommended). To install the plug-in, quit the Illustrator program if it is running.
Then locate the Artlandia LivePresets.aip plug-in file and drag it to the Plug-ins
folder located inside the Adobe Illustrator folder. The plug-in will be available the
next time you start Illustrator. The file Installation.txt that came with your plug-in
may contain more specific instructions for your computer system.

Note: On your computer system, the file extension can be different or the file name may not
have an extension at all.

Demo mode
The newly installed plug-in works in the demo mode, which may not have all the
features of the full version. The limitations are described in a separate document (see
the file Demo.txt in the LivePresets folder).

Unlocking the full version
To unlock the full version, you need the serial number, which has been provided
with your purchase. If you are using a demo version and wish to purchase the full
version, please visit the Artlandia web site or contact Artlandia.
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To enter the serial number, choose Object > LivePresets > Register.... Fill in the serial
number, and click OK.

About this guide
The guide assumes that you have a basic knowledge of Illustrator, including how to
operate Illustrator menus, choose tools, select all or part of the artwork, group and
ungroup objects, and use pattern swatches and symbolism tools. For help with any
of these tools and techniques, please refer to your Illustrator documentation.

An electronic version of this guide is available as a PDF file located in the
LivePresets folder.

Supplementary materials
•  The plug-in comes with the Quick Reference Card available as a PDF file.

•  Also available with the plug-in are Illustrator files that accompany the tutorial
part of this guide. They are located inside the Tutorial folder in the LivePresets
folder.

Web resources
Additional tutorials, pattern design resources, answers to frequently asked
questions, and the latest information about Artlandia products are always available
on the Artlandia web site at www.artlandia.com. To access the web site from
Illustrator, click the icon at the top of the LivePresets palette (you must have an
internet connection and a web browser installed).
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Among the available resources is Artlandia Wonderland, a collection of tips,
interactive tutorials, and books on symmetry, pattern design, and their applications,
located at www.artlandia.com/wonderland. Many pattern design terms are defined
and illustrated in the Artlandia Glossary of Pattern Design at
www.artlandia.com/wonderland/glossary.

Customer support
You may be entitled to technical support. For more information, refer to the
Artlandia web site and/or the technical support card that came with this guide.

Other products from Artlandia
Also available from Artlandia are the companion plug-ins Artlandia®
SymmetryWorks® and Artlandia® SymmetryShop®. You may find these plug-ins
useful for interactively creating sophisticated repeat patterns in Adobe Illustrator
and Adobe Photoshop, respectively. LivePresets, SymmetryWorks, and
SymmetryShop serve some similar purposes, but they work quite differently and
have their own uses. For a detailed comparison, visit

www.artlandia.com/SymmetryWorks

and

www.artlandia.com/SymmetryShop

Another supplemental product is the Artlandia Collection, a library of unique,
royalty-free pattern designs in repeat created with Artlandia software. The Artlandia
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Collection can be purchased with SymmetryWorks or separately. LivePresets
provides you with an alternative way to interactively edit and fine-tune the pattern
swatches in the Artlandia Collection. Visit

www.artlandia.com/collection

for a list of currently available volumes and sample art.

For designers familiar with computer programming, Artlandia offers its namesake
software, Artlandia. If you wish to create your artworks by a set of commands in a
computer language, you may want to explore this program. Artlandia complements
LivePresets and SymmetryWorks by providing the means to automatically generate
attractive patterns, prepare components for your Illustrator artwork, and apply
sophisticated algorithms to further enhance your Illustrator artwork.

More information about Artlandia products is available on the Artlandia web site,

www.artlandia.com
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Key Features at a Glance

LivePresets lets you create editable copies of Illustrator presets, such as pattern
swatches and symbols, and makes it easy to interactively modify the preset artwork.

Interactive pattern swatches and symbols  The plug-in produces a new Illustrator
object, a live copy of a pattern swatch or symbol. When you edit a live copy, the
corresponding swatch or symbol instantly changes. See “Creating LivePresets
objects” on page 9.

Live updates  Your edits also immediately apply to all Illustrator objects that use the
swatch or symbol you are editing, including regular and compound paths, plug-ins,
live effects, graphics styles, symbol sets, nested symbols, and symbols mapped on 3D
objects. See “Interactive editing” on page 11.

Instant creation and deletion  Create a live object with a click and start editing.
Revert to the initial state at any time. Delete it with a click when done. See “Initial
and Current swatches” on page 11.

Easy insertion of new artwork  Copy and paste any Illustrator object into the preset
you are editing. Also use the special Target with Drawing Tools mode to draw
freehand and automatically add new artwork to the swatch or symbol. See “Target
with Drawing Tools button” on page 14.

Unlimited snapshots  Save snapshots of your presets as you work. Snapshots are
automatically added to the Swatches or Symbols palette. See “New Symbol/New
Pattern Swatch button” on page 15.

Interactive changes of repeat size in patterns  LivePresets lets you select the
bounding box of your pattern swatch with a click (or create a new bounding box if
the swatch does not have one). You can then interactively move or scale the
bounding box to change the repeat size of your pattern. See “Pattern bounding box”
on page 15.

Support for editable objects in pattern swatches  Illustrator expands brushes,
blends, symbols, meshes, and other complex objects when inserting them in a swatch
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artwork. However, with LivePresets, you can keep such objects in their original, non-
expanded, editable form. See “Editable objects in pattern swatches” on page 19.

Linking and unlinking  Unlink your LivePresets objects from the rest of the artwork
at any time to suspend interactive updates. When ready, re-link with a click to apply
all updates at once. See “Link/Unlink button” on page 13.



Part I
Practical Introduction

This part gives you an overview of key features of the Artlandia
LivePresets plug-in and introduces basic techniques you will find
useful in your work.

Contents

Chapter 1
Working with Artlandia LivePresets



8 Chapter 1
Working with Artlandia LivePresets

Chapter 1
Working with Artlandia LivePresets

You can interact with LivePresets objects using familiar Illustrator tools and
commands, as well as new commands added by the plug-in. The new commands can
be found in the LivePresets palette as well as under the appropriate Illustrator
menus: the commands to make and release LivePresets objects are under the Object
menu, and the commands to display and hide the LivePresets palette are under the
Window menu. The commands in the Object menu become enabled together with
the corresponding elements of the LivePresets palette.

The LivePresets palette
To show the LivePresets palette, choose Window > LivePresets. You can move the
palette on your screen or combine it with the palettes of your choice, just as you do
with other Illustrator palettes. To hide the palette, choose Window > LivePresets
again.

Initial and Current
Swatches

Preset Type Icon

Palette menu

Target with Drawing Tools 

Link/Unlink with Preset

Preset Name
Select Bounding Box

New Pattern Swatch
(New Symbol)

The LivePresets palette. On your computer the palette may be slightly different. Consult the Quick
Reference card that came with your plug-in.

As with many other Illustrator palettes, components of the LivePresets palette do not
become active until you select a suitable object in your artwork:
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•  the Initial swatch, the Preset Type icon, the Preset Name item, and the Make
button become active when you select an artwork from which LivePresets
can create a new plug-in object; see “Creating LivePresets objects” next

•  the Initial and Current swatches and all other palette components, with the
exception of the Make button, become active when you select an existing
LivePresets object in your artwork

Tool tips  Palette components  may have tool tips, activated at an appropriate time.
If you do not see any tips, enable Illustrator’s tool tips. Choose Edit > Preferences >
General, then check the Show Tool Tips box and click OK.

Creating LivePresets objects
LivePresets creates an editable instance of
static Illustrator presets, such as pattern
swatches or symbols. This object is called
a LivePresets object. To get started, you need
to select one of the following objects in your
artwork: a symbol instance, a symbol set, or a
path whose fill or stroke is painted with a
pattern swatch. Once a suitable object is
selected, LivePresets shows the preset name
and type (  for a symbol or  for a pattern
swatch) and displays the icon for the
corresponding preset in the Initial swatch in
the LivePresets palette. The Make button
becomes enabled.

A

B
Supported preset types.
A. Pattern swatches B. Symbols

Note: LivePresets does not support live editing of Illustrator brushes.
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A B

Making a LivePresets object.
A. Selecting a path with a pattern fill  B. Inserting a LivePresets object (the Make button is clicked)

If you select more than one path object
painted with the same pattern (or multiple
instances of the same symbol and symbol
sets), the Make button will still be active as
long as your selection uniquely identifies the
editable preset. If your selection points to
more than one preset, LivePresets displays
the Mixed Items icon in the Initial swatch.

The Mixed Items icon.

LivePresets also displays the Mixed Items icon if you select a symbol set that includes
instances of more than one symbol. To enable LivePresets, select a symbol or symbol set that
consists of the same symbol. Alternatively, you can expand a composite symbol set (choose
Object > Expand…, leave only the Object checkbox selected, and click OK) and then select a
symbol that you want to edit.

To make a LivePresets object:

1 Select a path painted with a pattern swatch, a symbol, or a symbol set.
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2 Click the Make button in the LivePresets palette or choose Object > LivePresets >
Make.

The Make command inserts a LivePresets object in the center of the artboard. You
can then drag the object to any location of your choice with the Selection tool.

In Illustrator CS2 and later versions, LivePresets creates a new object in the Target
with Drawing Tools mode. See “Target with Drawing Tools button” on page 14.

To make a LivePresets object, it is not enough (and not necessary) to select a swatch in the
Swatches palette or a symbol in the Symbols palette. Rather you must select an object (for
example, a path or a symbol) in your Illustrator document.

If your artwork does not have any objects that use the preset that you want to edit, create
such an object first.

To practice, draw a rectangle and apply a pattern fill using one of the default Illustrator
pattern swatches or a swatch from some other library (for example, the Artlandia Collection;
see Other products from Artlandia on page 3).

A large collection of pattern swatches and symbols comes with your Illustrator. Choose
Window > Swatch Libraries or Window > Symbol Libraries to open a library of your choice.
See ”About patterns” and “About symbols” in Illustrator’s User Guide.

Interactive editing
Once a LivePresets object is created, any edit you apply to the object immediately
propagates to the corresponding preset and further to all objects in the artwork that
use that preset. This lets you interactively adjust pattern swatches and symbols while
observing how your edits affect Illustrator paths, plug-ins, live effects, graphics
styles, symbol instances, symbol sets, nested symbols, and other Illustrator objects.

Initial and Current swatches  As you edit a preset, the Initial swatch in the
LivePresets palette remains unchanged while the Current swatch changes to reflect
your edits (as long as your LivePresets object is linked to the preset; see
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“Link/Unlink button” next). Besides providing a visual cue, the swatches also let you
restore and reset the initial state of the preset.

B D

G
H

J I

C

F
E

A

Live updating of pattern swatches and symbols in some of the supported Illustrator objects.
A. Paths (fill)  B. Compound paths (fill)  C. Paths (stroke)  D. Plug-ins  E. Live effects  F. Graphic
styles  G. Symbols  H. Symbol sets  I. Symbols mapped on 3D objects  J.  Nested symbols
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Click the Initial swatch to abandon your edits and revert the preset to its initial state.
Double-click the Initial swatch to revert the preset and delete the LivePresets object.

Click the Current swatch to remember the current state as a new initial state. Double-click
the Current swatch to accept the current state as final and delete the LivePresets object.

It is often convenient to have several Live preset objects linked to the same pattern
swatch or symbol. This lets you quickly try different design ideas, see them applied
live to the target artwork, and continue to develop them in parallel. As you switch
between LivePresets objects (select any part of a LivePresets object to switch to that
object), you will notice that the Current swatch reflects the current state of the preset
you are editing, not necessarily the state of the selected LivePresets object.

Edit a LivePresets object to rebuild the preset from that object or click the Link button and
then the Broken Link button to unlink and then re-link to the preset.

Link/Unlink button  In complex artworks, interactive editing may become
inefficient. In such cases you can click the Link/Unlink button in the LivePresets
palette to suspend or resume interactive updates of Illustrator objects that use the
preset and the preset itself. The Link icon  indicates that your edits immediately
apply to the preset, whereas the Broken Link icon  indicates that you are only
editing the plug-in object. Click the button again to apply your edits to the preset.

Editing unlinked symbols with LivePresets is essentially equivalent to editing symbols in
Isolation mode in Illustrator CS3 and later versions. See “Edit or redefine a symbol” in
Illustrator’s User Guide.
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A B

Using the Link/Unlink button .
A. Live editing  B. Postponing changes

Target with Drawing Tools button  The
Target with Drawing Tools mode is similar to
the group isolation mode in Illustrator and
provides a convenient way to add objects to
the preset you are editing. (For other ways to
accomplish the same result, see “Adding
objects to a preset” on page 18.) To switch to
the Target mode, click the Target with
Drawing Tools button  in the LivePresets
palette. The button becomes available when
you select a LivePresets object. The button is
disabled in objects that are already in the
Target mode. The Target mode is indicated
by a gray border around a LivePresets object.
Drawing in the Target mode with, for
example, the Rectangle tool or the Pen tool,
places new objects inside the preset, on top of
other objects. To exit this mode, double-click

Drawing a rectangle in the Target with Drawing
Tools mode places it inside the LivePresets object,
on top of the artwork.

outside the gray border or simply click any object outside the gray border.
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Note: The Target with Drawing Tools mode is available only in Illustrator CS2 and later
versions of Illustrator.

New Symbol/New Pattern Swatch button  You can save a snapshot of the preset
you are developing at any time. To save a snapshot, click the New Symbol/New
Pattern Swatch button and fill in the snapshot name in the subsequent dialog.
LivePresets adds pattern snapshots to the Illustrator Swatches palette and symbols to
the Symbols palette. You can use the swatches and symbols that you save this way as
any other Illustrator swatches and symbols.

To bypass the New Name dialog, hold down the Alt key (Windows) or the Option key (Mac
OS), and click the New Symbol/New Pattern Swatch button.

Pattern bounding box
Illustrator creates fill patterns by tiling the pattern swatch artwork within its
bounding box, an unfilled and unstroked rectangle at the back of the artwork. The
bounding box, if present, acts as a mask, causing Illustrator to discard artwork
outside the bounding box. If the backmost artwork of a swatch is not an unfilled and
unstroked rectangle, Illustrator tiles the entire swatch. LivePresets provides a
convenient way to select the existing bounding rectangle in a pattern preset, or add a
new one, and preview a pattern swatch with or without the masking rectangle.

Select Bounding Box button  The Select Bounding Box button  is available for
pattern swatches that contain a bounding box. Click the button to select the
bounding box.

You can scale the bounding rectangle with Illustrator tools to change the horizontal and
vertical repeat size of your pattern.
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Selecting the pattern bounding box.

Make Bounding Box button  For pattern swatches that do not have a bounding box
rectangle, the Select Bounding Box button in the LivePresets palette changes into the
Make Bounding Box button . Click the button to add a bounding rectangle at the
bottom of the pattern swatch. Once the rectangle is added, the Make Bounding Box
button changes to the Select Bounding Box button . The new bounding rectangle
precisely fits the entire swatch artwork so adding the rectangle does not cause visual
changes to instances of the pattern in the artwork.

LivePresets selects the new rectangle so you can apply the usual Illustrator tools, for
example, the Free Transform tool, to change the repeat size of your pattern.

Show Clipped  The Show Clipped item in the LivePresets palette menu lets you hide
parts of the swatch artwork that are outside the pattern bounding box. Choose the
item in the popup palette menu to show the clipped artwork. The check mark to the
left of the menu item indicates that the clipping mode is active. Selecting or
deselecting the Show Clipped mode affects only the visual appearance of LivePresets
objects and has no bearing on patterns in the artwork.
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A
B

Using the Show Clipped item in the palette menu.
A. Displaying the entire swatch artwork  B. Displaying only the swatch artwork inside the pattern
bounding box

LivePresets bounding box versus Illustrator bounding box  The LivePresets
bounding box behaves very much as Illustrator own pattern bounding box. Just as
Illustrator itself, the plug-in recognizes the backmost path in the swatch artwork as
the bounding box only if the path is closed, has no fill or stroke, and has exactly four
anchor points. However, there is an important distinction: if such a path is not a
rectangle, or if it is a rectangle but its sides are not strictly vertical and horizontal,
Illustrator treats such a path as just another object in the swatch, whereas LivePresets
automatically reshapes the path to make it into a rectangle with horizontal and
vertical sides.

If you are familiar with Artlandia SymmetryWorks, you will see that the bounding box in
LivePresets is very similar to the control path in SymmetryWorks. However, in
SymmetryWorks, the pattern remains in repeat after the plug-in reshapes the control path,
whereas in LivePresets it is your responsibility to rearrange the swatch elements to ensure a
seamless repeat.
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Adding objects to a preset
You can add other objects to a LivePresets objects (and correspondingly to the preset
you are editing) using the usual Illustrator tools and techniques as well as a special
mode provided by the plug-in:

•  use Illustrator menu commands Edit > Paste in Front and Edit > Paste in
Back to add objects on top or behind a selected element of a LivePresets
pattern; see “To paste an object relative to other objects” in Illustrator’s User
Guide

•  use the Target with Drawing Tools mode to add an object on top of the
preset artwork; see “Target with Drawing Tools button” on page 14

•  use the Layers palette to insert an object into a LivePresets object; see “To
change the stacking order using the Layers palette” in Illustrator’s User
Guide

Note: The Paste in Front and Paste in Back commands and the Target with Drawing Tools
mode are available in Illustrator CS2 and later versions; reordering using the Layers palette
can be done in all supported versions of Illustrator.

As an example, use the following procedure to add objects to LivePresets using the
Paste in Front (Paste in Back) command.

To add an object to LivePresets using the Paste in Front (Paste in Back)
command:

1 Select the object(s) you want to add to the preset with the Selection tool and drag
the object(s) in front of the LivePresets object.

2 Choose Edit > Cut.

3 With the Direct Selection tool, select an object in the preset.

4 Choose either Edit > Paste in Front or Edit > Paste in Back.

You can find examples of adding other objects to a LivePresets object in the tutorial
“Designing a Pattern from Scratch” on page 27.
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Editable objects in pattern swatches
Illustrator automatically expands complex objects, such as brushes, blends, symbols,
meshes, and some other objects, before including them in a pattern swatch. This
ensures the best performance when you apply the swatch as a pattern fill.
LivePresets lets you keep that performance advantage and still use complex objects
in their original, non-expanded form for easy editing.

You can add complex objects to LivePresets swatches as you would add any other
object, see “Adding objects to a preset” on page 18. For example, you can easily paint
with brushes in the Target with Drawing Tools mode or use that mode to place an
instance of a symbol inside a pattern swatch. You can add other objects with cut and
paste. For step-by-step examples, see “Designing a Pattern from Scratch” on page 27.

A B

Using brush strokes in a pattern.
A. Editable brush objects in a LivePresets object  B. The same artwork expanded in the Swatches palette
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Disposing LivePresets objects
Once you are satisfied with the preset you are editing, you can delete your working
editable copy of the preset. Delete a LivePresets object as any other Illustrator plug-
in object, for example, by selecting the whole object and pressing the Delete key. You
can also delete an object by double-clicking the Current swatch in the LivePresets
palette.  See “Initial and Current swatches” on page 11.

Because Illustrator retains all the information about symbol components intact, there may be
little reason to keep a LivePresets object for symbols— when you need it, you can create a
new editable copy from an instance of the symbol just as well.

There may still be a good reason to keep a LivePresets object for pattern swatches, when the
swatch artwork contains complex objects that are normally expanded. See “Editable objects
in pattern swatches” on page 19.

Releasing LivePresets objects
Releasing a LivePresets object breaks its connection to the object’s preset and reduces
the object to the raw preset artwork. You may want to release an object, for example,
when you want to copy the preset artwork. To release a LivePresets object, choose
Object > LivePresets > Release. Visually, there may be no changes, but the
LivePresets palette becomes disabled and the selected LivePresets object disappears
from the Layers palette.   
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A B

Releasing a LivePresets object.
A. A LivePresets object  B. The same artwork after the object is released

You can re-create a released object by dragging the object to the Swatches or Symbols
palette (for pattern swatches and symbols respectively) and then creating a new
LivePresets object. See “Creating LivePresets objects” on page 9.





Part II
Tutorial

These tutorials take you step-by-step through typical stages of
using LivePresets. The tutorials have extensive references to other
material in this guide and could be used as a starting point to learn
about the plug-in.

Contents

Chapter 2
The Retro Flowers: Interactive Symbol Editing

Chapter 3
The Blends: Designing a Pattern from Scratch

Chapter 4
The Merry Border: Using Nested Symbols
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Chapter 2
The Retro Flowers: Interactive Symbol Editing
This tutorial introduces the basic steps of
working with LivePresets. Always start by
selecting an Illustrator object that uses a
preset that you want to edit. In this case,
you will create such an object first.

1 Choose File > New... and click OK in the
dialog box. Then choose Window > Symbol
Libraries > Retro and click the Ying Yang
Flower in the Retro palette. Check that the
symbol is selected in the Illustrator Symbols
palette and click the Symbol Sprayer tool in
the toolbox. Then draw a small scribble in
the artwork to create a symbol set with a
few retro flowers.

2 Notice that the Ying Yang Flower
symbol appears in the Initial Swatch of the
LivePresets palette, together with the
symbol icon  and the preset name, and the
Make button becomes enabled. This shows
that LivePresets recognizes the selected
object and is ready to make its live, editable
copy. See “Creating LivePresets objects” on
page 9.

3 Click the Make button in the LivePresets palette. This inserts an editable copy of the
Ying Yang Flower symbol in the center of the artboard. Choose the Selection tool in the
toolbox and drag the object to a convenient place to edit, for example, to the right of the
original Ying Yang Flower symbol set.
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Notice the gray border surrounding your
LivePresets object. The border indicates that
the Target with Drawing Tools mode is
active. You can use that mode to
interactively add other objects to the preset;
see “Target with Drawing Tools button” on
page 14.

Also notice that, as soon as the LivePresets
object is created, the Make button becomes
disabled and the Current swatch starts
displaying the current state of the preset
you are editing; see “Initial and Current
swatches” on page 11. The active Current
swatch is also an indication that a
LivePresets object is selected.

4 You now have an editable copy of the
Ying Yang Flower. Every edit you make to
the LivePresets object immediately changes
the symbol and applies to all instances of
the symbol in the artwork. Experiment and
see the flower set change interactively with
your edits.

For example, select the white-and-black
Ying Yang and apply the Twirl tool.

There may be times when you do not want all your edit to immediately apply to all
instances of the symbol in the artwork (for example, if there are thousands of flowers
in the artwork). You may prefer to make multiple edits and then apply them at once
when you are ready. You can do that by clicking the Link button . The link
indicates that the LivePresets object is linked to the preset and all its instances in the
artwork. When you click the button, the icon changes to the Broken Link , which
indicates that there is temporarily no link. Continue to edit the flower and click the
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button again when you are done. This updates all other flowers in the artwork. See
“Link/Unlink button” on page 13.

When finished, double-click the current swatch to keep your changes to the Ying
Yang Flower symbol and delete the LivePresets object. Or double-click the Initial
swatch to abandon your changes and delete the LivePresets object.

You may also try using LivePresets with a pattern swatch instead of a symbol. Create
a rectangle, apply a pattern swatch fill, and click the Make button in the LivePresets
palette. Then proceed with interactive edits of the swatch artwork and see your
changes apply to the filled rectangle.
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Chapter 3
The Blends: Designing a Pattern from Scratch

In the previous chapter, you learned how to edit an existing symbol or a pattern
swatch. But what if you want to create a new pattern swatch from scratch? This
advanced tutorial introduces one possible procedure. You will also learn how to use
other plug-in objects and symbols in your pattern swatches.

Another plug-in from Artlandia, Artlandia SymmetryWorks, lets you create much more
sophisticated pattern designs.

To launch LivePresets, you still need a pattern swatch with at least one object inside.
Start by creating a new swatch that contains just a single bounding box. In most
cases, you will want a bounding box for your pattern anyway. See “Pattern
bounding box” on page 15.

1 In a new artwork, choose the Rectangle
tool in the toolbox and set the fill and stroke
colors to None in the Color palette. Click
somewhere in a new artwork and fill in the
desired width and height in the subsequent
dialog. This rectangle will define the
horizontal and vertical repeat size of your
pattern.

2 Choose Edit > Define Pattern…, fill in a pattern name, and click OK (or drag the
rectangle to the Swatches palette with the Selection tool). Then delete the rectangle—it
has served its purpose.

Note the new (empty) swatch that you just created. You will use that swatch to “paint”
another rectangle (or any other path that you want). That rectangle (or path) will serve
as a projection screen for you to see the pattern in repeat as you develop it.
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3 With the Rectangle tool still selected in
the toolbox, drag somewhere in your
artwork to create a rectangle that is several
times bigger than the rectangle you have
just deleted. Set some stroke color (just to
see your rectangle clearly) and apply the
empty swatch you created in step 2 as a
pattern fill: in the Color palette, click the Fill
swatch to bring it forward; then click the
new empty swatch in the Swatches palette.
Your new rectangle will still look empty,
but now the Initial swatch in the LivePresets
palette becomes white and the Make button
becomes enabled.

4 Click the Make button in the LivePresets
palette. This inserts the swatch you created
in step 2, which consists of a single no-fill,
no-stroke rectangle, the bounding box
(which you created in step 1). The Current
swatch now also displays the empty (white)
square.

Your rectangle is surrounded by a gray
border, which is the indicator of the Target
with Drawing Tools mode. That mode lets
you draw freehand. It is a convenient way
to add artwork to the new swatch. You can
exit the Target mode by double-clicking
outside the gray border. To enter the mode
again, select the swatch artwork (for example, drag across the swatch rectangle with the
Selection tool) and click the Target with Drawing Tools button . See “Target with
Drawing Tools button” on page 14.
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5 With the Target mode still active,
choose Select > Deselect to deselect the
bounding rectangle. Then click the Pen tool
in the toolbox, choose a grayish fill color in
the Color palette, and draw a small path in
the lower-left quadrant of the bounding box.
Notice that the path appears repeated on the
“projection screen” rectangle as you draw.

If some part of the path gets cut off on the
projection screen, choose the Direct
Selection tool and drag the path inside the
bounding box rectangle. For easier
navigation, enable the Illustrator smart
guides (View > Smart Guides).

You can also see the cutoffs directly in the swatch you are editing. Click the popup
menu in the LivePresets palette and choose Show Clipped. Then move the path you
have just created around and observe that the part of the path that goes outside the
bounding box loses the color fill (that is, becomes visible only as an outline). Now if the
path is cut off on the projection screen, it is also cut off in the swatch. See “Show
Clipped” on page 16. To continue with the tutorial, undo theses changes (return the
path inside the bounding box).
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6 Next you will create a path that does
cross the boundary of the bounding box.

Make sure that the Target mode is still
active and draw a triangle in the upper-right
part of the swatch bounding box. Now you
want the upper part of the triangle to be
slightly outside so it will be cut off on the
projection screen. Let the triangle have an
orange stroke and no fill.

For the triangle on the upper border of the
bounding box to repeat seamlessly, you
must also have a copy of the triangle
crossing the lower border of the bounding
box.

7 Choose the Direct Selection tool in the
toolbox, hold down the Alt key (Windows)
or the Option key (Mac OS), click the
triangle once to select it all, and drag it
down toward the lower border. Press the
Shift key as you drag to ensure that the
copied rectangle will be aligned vertically
with the original one. Release the mouse
when the copied triangle is somewhere near
the lower border. By pressing the Up Arrow
key and the Down Arrow key adjust the
position of the second triangle so that it
flows seamlessly into the first one.

You can use many other ways to make a shifted copy of the triangle. For example, use
the Object > Transform > Move… dialog box (fill in the vertical repeat size and click
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Copy). This will let you to shift the copy by the exact amount and avoid later interactive
adjustments.

The Target with Drawing Tools mode is useful for adding regular paths and symbols to
your swatch, but it does not allow you to directly create some complex objects, such as
blends or mesh objects. You can still use such objects in your swatch, but you must
create them outside the LivePresets object and then move them in, for example, with the
Cut and Paste in Front commands. In the next step, you will do it for one such object (a
blend).

8 Double-click outside the gray border to
exit the Target with Drawing Tools mode.
Then select a shade of red fill color in the
Color palette and draw a small rectangle
path with the Pen tool, somewhere to the
right of the gray path. Then draw a smaller
orange oval with the Pencil tool, down and
further to the right.

Click the Blend tool in the toolbox and click
first the red rectangle and then the oval.
Double-click the Blend tool and, in the
Blend Options dialog, choose Specified
Steps for Spacing and type the number 3 in
the adjacent field. Click OK to close the
dialog. Your blend is ready to be inserted
into your swatch.

Choose Edit > Cut, then click the Direct Selection tool in the toolbox, and click the gray
path in your LivePresets object. Then choose Edit > Paste in Front. At this point, your
blend object gets insert into the swatch and comes up on the “projection screen” in
repeat.

Alternatively, you can use the Layers palette to insert the blend object into the swatch.
See “Adding objects to a preset” on page 18.
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9 With the blend object still selected, hold
down the Alt key (Windows) or the Option
key (Mac OS), and drag the object to the
right to create a copy. Note that your edits
get immediately reflected in the repeated
pattern on the “projection screen”.

Using the Rotation tool, rotate the copied
blend 180° and, if necessary, interactively
adjust the position of the blend with the
Direct Selection tool so that it will not
overlap other elements in the swatch.

You can now interactively edit the blend
object inside the LivePresets swatch. For
example, change the color of the red path to
a darker orange shade.

10 As a finishing touch for this pattern, you
can add a corner object. Just as you had to
add a second orange triangle at the bottom
of the swatch to ensure the vertical flow of
the pattern in step 7, you will have to add
four identical objects, at all four corners of
the swatch, when an object gets cut off by
two sides at a corner. This will ensure the
flow in both horizontal and vertical
directions.

Placing a corner object is a somewhat
advanced technique and you can master it
when you get more familiar with
LivePresets. To have four identical copies of
an object and still be able to interactively

Corner symbol
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edit them in one place, create a symbol and place four instances of that symbol in the
four corners of the swatch. You can then edit the symbol in a separate LivePresets object
and have it updated automatically in the LivePresets swatch and throughout the
artwork.

The finished pattern for this tutorial and the LivePresets object for the swatch are in the
file Blends.ai in the Tutorial folder inside your LivePresets folder.

Note that if you create a new LivePresets object for the same pattern, the new object will
contain expanded blends and symbols. For swatches like this, you should keep the
original LivePresets objects if you ever want to edit them as objects again (rather then
edit the expanded artwork). See “Editable objects in pattern swatches” on page 19 and
“Disposing LivePresets objects” on page 20.
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Chapter 4
The Merry Border: Using Nested Symbols

Interactive editing of patterns and symbols with LivePresets is especially useful for
working on complex artworks that include nested presets (when one preset is used
inside another), for example, when a pattern swatch is used to paint a path in a
symbol, which is in turn included in another symbol, and so on. This tutorial shows
you a simple way to do that.

1 Using the Rectangle tool or the Pen
tool, draw a red square in a new artwork.

2 Click the rectangle with the Selection
tool and drag it to the Symbols palette. In
the Symbol Options dialog, choose Type:
Graphics and accept the default symbol
name (or type in the name you want) and
click OK. The red square becomes a symbol
and activates the LivePresets palette.

Note: In Illustrator CS2, this does not happen
in one step. After you have created a symbol,
delete the original path and click Place Symbol
Instance in the Symbols palette.
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3 You do not need to make an editable copy of the symbol right away, but you will
need it at some point so you can just as well do it now. Click the Make button in the
LivePresets palette, create a LivePresets object for the red square, and move the object
somewhere in the artwork to keep it until a later time.

4 Now create a new symbol that includes
three copies of the red square symbol
arranged in a line. For example, click the
Selection tool in the toolbox, hold down the
Alt key (Windows) or the Option key (Mac
OS), and drag the red square symbol to the
right. Repeat to make a third copy. Then
select all three symbols and drag them to
the symbol palette to make a new symbol.

5 Make three more copies of the new
symbol and arrange them in a square. You
can use the Edit > Copy and Edit > Paste
commands to create duplicates, or use any
other familiar method. To rotate the symbol
instances, use the Rotation tool. Move the
symbol instances around with the Selection
tool.
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6 Create yet another symbol, in this case
from a simple orange disk, and put four
instances of that symbol in the corners of
the square. Add two concentric rectangles
(use a beige stroke).

You can now edit all the symbol
components in separate LivePresets objects
and interactively modify the border
arrangement.

7 Start with the orange disk. Select one of
the corner instances and click the Make
button in the LivePresets palette. This
creates an editable copy of the symbol. You
can then change the disk color and add
another symbol in the center of the disk.

Make sure that the object has a gray border
(click the Target with Drawing Tools button

 if it does not), choose Window > Symbol
Libraries > Flowers, click the Aster symbol,
and click Place Symbol Instance in the
Symbols palette. This inserts the Aster
symbol into the orange disk symbol.
Optionally scale and center the inserted
symbol. Notice that the entire border arrangement changes immediately to reflect
your edits.
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Next you want to edit the red square symbol. Note that if you select the composite
symbol (the one that contains three base symbols), LivePresets will let you make an
editable copy of the composite symbol, but not of the red square symbol itself.

This is where the LivePresets object created in step 3 will be useful. If you did not
create that object at that time, place a new instance of the red square symbol in the
artwork and make a LivePresets object now.

8 Select the red square in the LivePresets
object created in step 3 and add a beige
stroke. Notice again that the entire border
arrangement changes with your edits.

To experiment further, you can click the
Target with Drawing Tools button  and
add a small beige disk in the center of the
square.

The border arrangement at this stage is in
the file Border.ai in the Tutorial folder
inside your LivePresets folder.

Finally, note that you do not have to dispose of one LivePresets object to start
working on another. You can have as many such objects as you wish, even several
editable copies for each preset. Then edit the LivePresets objects in turn and see you
edits applied throughout the artwork. See “Initial and Current swatches” on page 11.
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